summaryrefslogtreecommitdiff
path: root/sys-apps/hw-probe
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-10-20 10:22:14 +0100
committerV3n3RiX <venerix@koprulu.sector>2021-10-20 10:22:14 +0100
commit46eedbedafdb0040c37884982d4c775ce277fb7b (patch)
treedb33a91259730be84999e13a8d8168c799f50ac0 /sys-apps/hw-probe
parente23a08d0c97a0cc415aaa165da840b056f93c997 (diff)
gentoo resync : 20.10.2021
Diffstat (limited to 'sys-apps/hw-probe')
-rw-r--r--sys-apps/hw-probe/Manifest2
-rw-r--r--sys-apps/hw-probe/hw-probe-1.6.ebuild67
2 files changed, 69 insertions, 0 deletions
diff --git a/sys-apps/hw-probe/Manifest b/sys-apps/hw-probe/Manifest
index df32c0b55853..22cbfde9c5ff 100644
--- a/sys-apps/hw-probe/Manifest
+++ b/sys-apps/hw-probe/Manifest
@@ -1,5 +1,7 @@
AUX README.gentoo 296 BLAKE2B df18c0796912c5cfe6e8f88427ea690512bfd519aa3502528df6f6936571497937a22f8edcd9e9143d915e648f9b341043141cc6d0ae35de55d22d44c0335f6e SHA512 4ae61b89352a4bbe70f4ea1b85eb19e58c2b81475722dda25c289fbe15e7e6e07df51b08471c5d3c5d7a3b12cc09ba599e0d2158dee68c9c66f60908d57b4326
AUX hw-probe-1.5-disable-automatic-upload.patch 1140 BLAKE2B 47ae86326941c5a86f9efd7614509a9af36261c51ef85f21ea1172ae91c3966c113aa51f8841a56005f75b0370b57dff6196fe49a77c766ce1efd9003ee0e249 SHA512 7cbe2dc17cb513086f85052b43349fb64bd12a0f3671bb37109a20d62cf565f8bc8d9e798a7d0a7e53896d187e8c575f850861e381885f2ac1f40d2c0c919063
+DIST hw-probe-1.6.tar.gz 158879 BLAKE2B 96d36be283d497df8aed944f3ba14c620e3abc7d3dd728c274f3ebaca3f064d1ac92bd4d47cbae51500264d785feda25082950fde6fdbd6c1b35f48736015659 SHA512 9ef51c0acc450d1f2073c03885e097231a745a456ae384825c56804f94c62ac85bf4c795627e6ea738636fa83d50d7ef60e20c6dd9621247ff06c51461d91249
DIST hw-probe-1.6_beta2.tar.gz 143569 BLAKE2B fc7b7562f86eb1b26fef32a8ed9b4a8d01c5621bedbc7e810d5a011c53d528b000ff9df312cf5e3f0ab455558e08e2b9a3ddcd543cd6856208466721f9a0e13c SHA512 2727e7b0fe449cbb6dd21fc112660df4ec666be845bbfd21037b41372a499dfb80c8c2dc37bd222032c68faadff91192a6d6f5229353cb0fc63b8e3dbd715f5d
+EBUILD hw-probe-1.6.ebuild 2380 BLAKE2B 284ca257c11e56bd355a9fdd030e9f4c5814ecf0d3aec8b090ed3141342a37aad0f86e774d08570fc88c83ecf439611372415bf04457fcd6d4008c2f311e1145 SHA512 84a4f07b78f065179efdbc30251940e3f4e57b4a06bbaa0bf5f4ebfc8e6c83f740d4fecf83165340e4364450b8e69934fb92196c1f49b899e6f69de50469aa17
EBUILD hw-probe-1.6_beta2-r1.ebuild 2447 BLAKE2B df0aa62976532b17319cf17259211cc493008be2478855574979eb73b3f8cb471eae04ee8b315c49a5eefc828a7be6896b6d2dbe8114a584be42c6b878bd6318 SHA512 43d9118e85be8fdf07b96c1e32c3cdaa27b5e3b2da9b9780fe133481b087be04b33b276618283ec596fc381ead99b7f1765175f89ca04793641065aefc496e0c
MISC metadata.xml 647 BLAKE2B 522741fd8d5f7b64d686ce02dd5ccd7d9ba42df1e50a3e51921fa17c110c6db114ee22d5a903c8bb61a2a5f3884fad5e8b1a929a062af111fd52faf047638ab1 SHA512 ef6e4af1150d72b3cc26ba56267dae006ae8a19a8df2606a9f02df0dc6b091f0bd3dd9caee2171e896dd7b5e582b853f228e899dbd9281dd07b435a1da1f6b7b
diff --git a/sys-apps/hw-probe/hw-probe-1.6.ebuild b/sys-apps/hw-probe/hw-probe-1.6.ebuild
new file mode 100644
index 000000000000..504704b069f7
--- /dev/null
+++ b/sys-apps/hw-probe/hw-probe-1.6.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_PV="${PV/_/-}"
+MY_PV_BETA="${MY_PV/2/}"
+
+inherit optfeature readme.gentoo-r1
+
+DESCRIPTION="A tool to probe for hardware, check it's operability and find drivers"
+HOMEPAGE="https://github.com/linuxhw/hw-probe/"
+SRC_URI="https://github.com/linuxhw/hw-probe/archive/${MY_PV_BETA}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-${MY_PV_BETA}"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-lang/perl
+ dev-perl/Digest-SHA1
+ net-misc/curl
+ sys-apps/dmidecode
+ sys-apps/edid-decode
+ sys-apps/hwinfo
+ sys-apps/pciutils
+ sys-apps/smartmontools
+ sys-apps/usbutils
+ virtual/perl-Data-Dumper
+"
+
+src_compile() {
+ :;
+}
+
+src_install() {
+ default
+
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+
+ optfeature "showing Machine Check Exceptions." app-admin/mcelog
+ optfeature "showing additional I/O statistics." app-admin/sysstat
+ optfeature "showing display data channel (ddc) information." app-misc/ddcutil
+ optfeature "showing smart card (reader) information." dev-libs/opensc
+ optfeature "showing Vulkan GPU hardware information." dev-util/vulkan-tools
+ optfeature "showing information of attached scanners." media-gfx/sane-backends
+ optfeature "showing GPU information provided by MESA." media-libs/mesa
+ optfeature "showing zeroconf statistics." net-dns/avahi
+ optfeature "showing HP printer statistics." net-print/hplip
+ optfeature "showing status about rfkill switches on communication devices." net-wireless/rfkill
+ optfeature "showing additional CPU capabilities." sys-apps/cpuid
+ optfeature "showing hard disk (HDD, SSD, ..) capabilities." sys-apps/hdparm
+ optfeature "showing available I2C sensors." sys-apps/i2c-tools
+ optfeature "showing additional hardware and system information detected by inxi." sys-apps/inxi
+ optfeature "showing information about tested memory for faults." sys-apps/memtester
+ optfeature "showing 'Plug & Play' devices." sys-apps/pnputils
+ optfeature "showing systemd boot process information." sys-apps/systemd
+ optfeature "showing ACPI statistics and tables." sys-power/iasl
+ optfeature "showing information about NUMA." sys-process/numactl
+ optfeature "showing additional GPU information provided by MESA progs." x11-apps/mesa-progs
+ optfeature "showing available Xinput devices." x11-apps/xinput
+}