summaryrefslogtreecommitdiff
path: root/sys-apps/hexdump-esr/hexdump-esr-1.8.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sys-apps/hexdump-esr/hexdump-esr-1.8.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'sys-apps/hexdump-esr/hexdump-esr-1.8.ebuild')
-rw-r--r--sys-apps/hexdump-esr/hexdump-esr-1.8.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/sys-apps/hexdump-esr/hexdump-esr-1.8.ebuild b/sys-apps/hexdump-esr/hexdump-esr-1.8.ebuild
new file mode 100644
index 000000000000..309feaa76fac
--- /dev/null
+++ b/sys-apps/hexdump-esr/hexdump-esr-1.8.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit toolchain-funcs
+
+MY_P="${P/-esr/}"
+
+DESCRIPTION="Eric Raymond's hex dumper"
+HOMEPAGE="http://www.catb.org/~esr/hexdump/"
+SRC_URI="http://www.catb.org/~esr/hexdump/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 hppa ~ia64 ppc ppc64 ~sparc x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE=""
+
+S="${WORKDIR}/${MY_P}"
+
+# tests are broken in this release(missing files)
+RESTRICT="test"
+
+src_prepare() {
+ sed -i Makefile \
+ -e "s|-O |${CFLAGS} ${LDFLAGS} |g" \
+ || die "sed on Makefile failed"
+ tc-export CC
+}
+
+src_install() {
+ newbin hexdump ${PN}
+ newman hexdump.1 ${PN}.1
+ dodoc NEWS README
+ dosym ${PN} /usr/bin/hex
+}