summaryrefslogtreecommitdiff
path: root/sys-apps/help2man
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-01-22 20:28:19 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-01-22 20:28:19 +0000
commitabaa75b10f899ada8dd05b23cc03205064394bc6 (patch)
treeeca3dd248b73b92013cba00a0fcc1edf2696e19a /sys-apps/help2man
parent24fd814c326e282c4321965c31f341dad77e270d (diff)
gentoo resync : 22.01.2021
Diffstat (limited to 'sys-apps/help2man')
-rw-r--r--sys-apps/help2man/Manifest2
-rw-r--r--sys-apps/help2man/help2man-1.47.17.ebuild41
2 files changed, 43 insertions, 0 deletions
diff --git a/sys-apps/help2man/Manifest b/sys-apps/help2man/Manifest
index 12f834395ab4..79f7a3358acc 100644
--- a/sys-apps/help2man/Manifest
+++ b/sys-apps/help2man/Manifest
@@ -1,4 +1,6 @@
AUX help2man-1.46.1-linguas.patch 2352 BLAKE2B c79cf163fc358f08192517527ee59df2ac429fdf8b8bcc4e387ed686d44b3aceebcd517578cbf6348d751ce2fb62f1b7580d6a645a4f912c7fa374eb165b2600 SHA512 5907aed1745b199b0cad44f6e7669c663761b308b2bb1b669be8ba118d990481c37d1da5477df2cfa9cba30ecffe99c3863215779d683f056fe0c41241a0049b
DIST help2man-1.47.16.tar.xz 203036 BLAKE2B 8e06c2c2e90adfc2ab8345908516b15ae50b02a7a9554d5d9beee4373b71c131aeaa0c148b9a988c531bbfe2149c25069af56a79101a4248b6c1adfeb734a132 SHA512 b427e60a9e3d2e805caf1ae84c337b09c7ca6f92b7ff14771f946c4a1bf7adf177df99b9c1c223ad76df99756005ababf5b548ff8e08d4746702ff7f8150b544
+DIST help2man-1.47.17.tar.xz 211476 BLAKE2B 67b1ccd4b6b66510a2fff424663bc2051e49e93c37c7e2a2b4631f3781d3773a97fd1773f96ca5ca2ba644bcd79ae35338931eff857ce199a847cc312d778b0e SHA512 185cd04aa6db6d8a4c898b61ad6a0aded7775659c7f02244b45927310eb3f8cd932fe9dd725ccac3e793aa22c656338b5d16f291f3a0420ed121681d4a4bac25
EBUILD help2man-1.47.16.ebuild 1034 BLAKE2B dc7c42555d1efd3896ba09d0602017ad721ab5aa94cc2dad5b9cc4f127f191a64fffc19f47f838ed81d2f4918d5262189ff369c220e9afd4f02d6a2dc6f11bb9 SHA512 e6dac61eb7d535c184cc15ea54c70bda3e0745a21cb8d47acaf6186780fb836e90f92d1869c9335433f857a44b9d6be24cc21ffe25986320cd33b8bd4e2054bc
+EBUILD help2man-1.47.17.ebuild 1043 BLAKE2B a409c6688242306b58aa9b395c4800166b31a301bd356cd93505e522169ebb4e1b1b82b61b3f2ed737691956fae33516faf69dd9819b8b07abe4bbc981ab7f23 SHA512 68652e40fd2ab4e8ffd862c9783bc7aa891e76a30419b955891134a7a96f8e132ce08dcb4b1be32937398970dfff57c6a09b401fad7cb6207c16a99a12a2a491
MISC metadata.xml 253 BLAKE2B 295e9d6d93aaa12af413972e1590c67087801cc09c9aa6b59d4606c0f4106d1dacf2baa9858559083b4c6d91beeef218d0729e8593a33788958da6d2897e8ce2 SHA512 54a9069aeb4165d2dff3d473c8001bc51613aac9dff3f7f5e9971a9891a737a31511ffa11cbd523febe581ac1d9de2bdf2f40410f0c4239138f2ccca3ef15555
diff --git a/sys-apps/help2man/help2man-1.47.17.ebuild b/sys-apps/help2man/help2man-1.47.17.ebuild
new file mode 100644
index 000000000000..2f5c10989e9b
--- /dev/null
+++ b/sys-apps/help2man/help2man-1.47.17.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="GNU utility to convert program --help output to a man page"
+HOMEPAGE="https://www.gnu.org/software/help2man/"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="nls"
+
+RDEPEND="dev-lang/perl
+ nls? ( dev-perl/Locale-gettext )"
+DEPEND="${RDEPEND}"
+
+DOCS=( debian/changelog NEWS README THANKS ) #385753
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.46.1-linguas.patch
+)
+
+src_prepare() {
+ if [[ ${CHOST} == *-darwin* ]] ; then
+ sed -i \
+ -e 's/-shared/-bundle/' \
+ Makefile.in || die
+ fi
+ default
+}
+
+src_configure() {
+ # Disable gettext requirement as the release includes the gmo files #555018
+ local myeconfargs=(
+ ac_cv_path_MSGFMT=$(type -P false)
+ $(use_enable nls)
+ )
+ econf "${myeconfargs[@]}"
+}