summaryrefslogtreecommitdiff
path: root/sys-apps/hd-idle/hd-idle-1.05-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-12 09:56:54 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-12 09:56:54 +0000
commitebc282ef4dfa408accac685565b8ee5f6faec119 (patch)
treec0a4f713228cda0ab17eed46f0bb7ca8cb8be2f6 /sys-apps/hd-idle/hd-idle-1.05-r2.ebuild
parent6c8694a707151d59555b0e4e48235f085ce166c3 (diff)
gentoo auto-resync : 12:02:2023 - 09:56:54
Diffstat (limited to 'sys-apps/hd-idle/hd-idle-1.05-r2.ebuild')
-rw-r--r--sys-apps/hd-idle/hd-idle-1.05-r2.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/sys-apps/hd-idle/hd-idle-1.05-r2.ebuild b/sys-apps/hd-idle/hd-idle-1.05-r2.ebuild
new file mode 100644
index 000000000000..7c244e6021ed
--- /dev/null
+++ b/sys-apps/hd-idle/hd-idle-1.05-r2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit linux-info systemd
+
+DESCRIPTION="Utility for spinning down hard disks after a period of idle time"
+HOMEPAGE="https://hd-idle.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+S="${WORKDIR}/${PN}"
+
+CONFIG_CHECK="~PROC_FS"
+
+DOCS=( debian/changelog README )
+
+src_install() {
+ default
+ systemd_newunit "${FILESDIR}"/hd-idle.service ${PN}.service
+ systemd_install_serviced "${FILESDIR}"/hd-idle-dropin.conf
+ newinitd "${FILESDIR}"/hd-idle-init hd-idle
+ newconfd "${FILESDIR}"/hd-idle-conf hd-idle
+
+ elog "The systemd unit file for hd-idle no longer sources ${EPREFIX}/etc/conf.d/hd-idle ."
+ elog "Configuration is still done via ${EPREFIX}/etc/conf.d/hd-idle for OpenRC systems"
+ elog "while for systemd systems, a systemd drop-in file located at"
+ elog "${EPREFIX}/etc/systemd/system/hd-idle.service.d/00gentoo.conf"
+ elog "is used for configuration."
+}