summaryrefslogtreecommitdiff
path: root/sys-apps/groff
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-20 14:27:17 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-20 14:27:17 +0000
commit5bb9ff1ee56d2b5e75e01a7f066d8b0cec84ec02 (patch)
tree66e860a5099bcad013f1cf667255dc372a7c11b3 /sys-apps/groff
parent7218e1b46bceac05841e90472501742d905fb3fc (diff)
gentoo resync : 20.03.2021
Diffstat (limited to 'sys-apps/groff')
-rw-r--r--sys-apps/groff/Manifest2
-rw-r--r--sys-apps/groff/groff-1.22.4.ebuild38
2 files changed, 19 insertions, 21 deletions
diff --git a/sys-apps/groff/Manifest b/sys-apps/groff/Manifest
index 85b7bc9fc672..c19ee177d995 100644
--- a/sys-apps/groff/Manifest
+++ b/sys-apps/groff/Manifest
@@ -1,4 +1,4 @@
AUX groff-1.19.2-man-unicode-dashes.patch 582 BLAKE2B 73e0868465b5372376e5bb5b382f2a4918fb9227208ad001f35ae041af93fda494a9be355e732697d264ec974d6e9528f9f91e0d26b2ecd82a41508222f1e439 SHA512 7d9f88c8bcc1b220c82c214f2f638601e8b44bd3933df03c74a2ef51b555773734c92044a3162bf5815932ddaae08158994a7c5106098de3e9f3bf202975de97
DIST groff-1.22.4.tar.gz 4137480 BLAKE2B cdda8a7e8e42b8d8991656ecfbffe0cd0ed5d8932467cab2f3c1eecb3365f4a5c03321b6ed929d451c3dfb00a46046a781303a1c55c4aa65eb7d178fb36b1cbc SHA512 1c42d3cd71efaf067b5850945d9097fa1f0fadd5e2b6ba7446bd9d4f439fe1ad058e4ddb0d4e0f503682137dfc7c822944ce1e3e5cf981673f8ba197ea77126d
-EBUILD groff-1.22.4.ebuild 2576 BLAKE2B 3016dae2d330453774d6c9ffa56b8824d5bd11b0f9766c85679d394f2a44d6278d9a565e9cfdeee5f2ea6626ae41be11fc6f07c545ee802fae9298b113da495b SHA512 e1d78778c61e1510335564ea673c455520679b6d1a1ebff21d1e1444d0631c14daaf20893d1efd269ce6ebc76829226ebba1275bfd6f72d1d44e6b05730f7b03
+EBUILD groff-1.22.4.ebuild 2561 BLAKE2B 6a525c7d600dcffa276b15a6755ad0072c68434ddb5cff628ab7f7f6c97469fa500792915f959cb96ae53ec87b90b4f3b235b4d7e7c036cdbb8ebe08a5f2c2cb SHA512 192fe962721594878bd767eb97edaf6ba05748ec0bba7bcfaedd9249ec76612a48ac217e12d609be60b5a2c3936546d86f295c281c281da8ec721006278832d0
MISC metadata.xml 365 BLAKE2B 0cf4dd1abdfcb39494154dc55c2e86b43d23638caa9644b6002e2e7919b05503feda2e7ab85c0a620a8a29b7c2fef7d699795c7d3185fe24afb6c863af80336b SHA512 4fcb10e056f0c0933c7877635fe42b565f330e0b99946855f223fb6624bc3a756a94d9170bfef89ae6eddee4f751a6c0234f3a126f0a11e456c70fd931927544
diff --git a/sys-apps/groff/groff-1.22.4.ebuild b/sys-apps/groff/groff-1.22.4.ebuild
index 375b70f0e78c..9b743edaf3b4 100644
--- a/sys-apps/groff/groff-1.22.4.ebuild
+++ b/sys-apps/groff/groff-1.22.4.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
inherit toolchain-funcs
@@ -10,7 +10,7 @@ MY_P="${P/_/.}"
DESCRIPTION="Text formatter used for man pages"
HOMEPAGE="https://www.gnu.org/software/groff/groff.html"
SRC_URI="mirror://gnu/groff/${MY_P}.tar.gz
- mirror://gnu-alpha/groff/${MY_P}.tar.gz"
+ https://alpha.gnu.org/gnu/groff/${MY_P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
@@ -21,14 +21,15 @@ IUSE="examples uchardet X"
RDEPEND="
uchardet? ( app-i18n/uchardet )
X? (
+ x11-libs/libICE
+ x11-libs/libSM
x11-libs/libX11
- x11-libs/libXt
- x11-libs/libXmu
x11-libs/libXaw
- x11-libs/libSM
- x11-libs/libICE
+ x11-libs/libXmu
+ x11-libs/libXt
)"
-DEPEND="${RDEPEND}
+DEPEND="${RDEPEND}"
+BDEPEND="
dev-lang/perl
sys-apps/texinfo"
@@ -70,16 +71,13 @@ src_configure() {
}
src_compile() {
- if tc-is-cross-compiler ; then
- local CROSS_ARGS=(
- GROFFBIN="$(type -P groff)"
- TROFFBIN="$(type -P troff)"
- GROFF_BIN_DIR=
- GROFF_BIN_PATH=
- )
- else
- unset CROSS_ARGS
- fi
+ local -a CROSS_ARGS
+ tc-is-cross-compiler && CROSS_ARGS+=(
+ GROFFBIN="$(type -P groff)"
+ TROFFBIN="$(type -P troff)"
+ GROFF_BIN_DIR=
+ GROFF_BIN_PATH=
+ )
emake AR="$(tc-getAR)" "${CROSS_ARGS[@]}"
}
@@ -93,11 +91,11 @@ src_install() {
if ! use examples ; then
# The pdf files might not be generated if ghostscript is unavailable. #602020
- local pdf="${ED%/}/usr/share/doc/${PF}/examples/mom/mom-pdf.pdf"
+ local pdf="${ED}/usr/share/doc/${PF}/examples/mom/mom-pdf.pdf"
if [[ -e ${pdf} ]] ; then
# Keep mom-pdf.pdf since it's more of a manual than an example. #454196 #516732
- mv "${pdf}" "${ED%/}"/usr/share/doc/${PF}/pdf/ || die
+ mv "${pdf}" "${ED}/usr/share/doc/${PF}/pdf/" || die
fi
- rm -rf "${ED%/}"/usr/share/doc/${PF}/examples
+ rm -rf "${ED}/usr/share/doc/${PF}/examples"
fi
}