summaryrefslogtreecommitdiff
path: root/sys-apps/grepcidr/grepcidr-2.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-06-15 14:57:03 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-06-15 14:57:03 +0100
commitd18bf1e01b65ee4bf0c804e2843b282d3d4e5d7c (patch)
tree4a95cbc6ffdf13bad6ecbc7f8d5af99631984123 /sys-apps/grepcidr/grepcidr-2.0.ebuild
parente748ba9741f6540f4675c23e3e37b73e822c13a4 (diff)
gentoo resync : 15.06.2021
Diffstat (limited to 'sys-apps/grepcidr/grepcidr-2.0.ebuild')
-rw-r--r--sys-apps/grepcidr/grepcidr-2.0.ebuild18
1 files changed, 11 insertions, 7 deletions
diff --git a/sys-apps/grepcidr/grepcidr-2.0.ebuild b/sys-apps/grepcidr/grepcidr-2.0.ebuild
index 77b3863961fd..4b99fd34edbb 100644
--- a/sys-apps/grepcidr/grepcidr-2.0.ebuild
+++ b/sys-apps/grepcidr/grepcidr-2.0.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
inherit toolchain-funcs
@@ -12,17 +12,21 @@ SRC_URI="http://www.pc-tools.net/files/unix/${P}.tar.gz"
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
-DEPEND=""
-RDEPEND="${DEPEND}"
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.0-Makefile.patch
+)
src_compile() {
- emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}"
+ emake \
+ CC="$(tc-getCC)" \
+ CFLAGS="${CFLAGS}" \
+ CPPFLAGS="${CPPFLAGS}" \
+ LDFLAGS="${LDFLAGS}"
}
src_install() {
- emake DESTDIR="${D}" PREFIX="${EROOT}/usr" install
+ emake DESTDIR="${D}" PREFIX="${EPREFIX}/usr" install
dodoc README ChangeLog
}