summaryrefslogtreecommitdiff
path: root/sys-apps/grep/grep-3.7.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-12-28 07:37:55 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-12-28 07:37:55 +0000
commitd46d1d3a5897cade51811b3848c7bf27969da625 (patch)
tree0dabb04db53e3fe66abe43df0a3cdff5d3b664db /sys-apps/grep/grep-3.7.ebuild
parente67d5b4ba05349b3bf4229d0cf7d069809c4420e (diff)
gentoo auto-resync : 28:12:2023 - 07:37:55
Diffstat (limited to 'sys-apps/grep/grep-3.7.ebuild')
-rw-r--r--sys-apps/grep/grep-3.7.ebuild75
1 files changed, 0 insertions, 75 deletions
diff --git a/sys-apps/grep/grep-3.7.ebuild b/sys-apps/grep/grep-3.7.ebuild
deleted file mode 100644
index e960d031fe79..000000000000
--- a/sys-apps/grep/grep-3.7.ebuild
+++ /dev/null
@@ -1,75 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-VERIFY_SIG_OPENPGP_KEY_PATH=/usr/share/openpgp-keys/grep.asc
-inherit flag-o-matic toolchain-funcs verify-sig
-
-DESCRIPTION="GNU regular expression matcher"
-HOMEPAGE="https://www.gnu.org/software/grep/"
-SRC_URI="mirror://gnu/${PN}/${P}.tar.xz"
-SRC_URI+=" verify-sig? ( mirror://gnu/${PN}/${P}.tar.xz.sig )"
-
-LICENSE="GPL-3+"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
-IUSE="nls pcre static"
-
-# We lack dev-libs/libsigsegv[static-libs] for now
-REQUIRED_USE="static? ( !sparc )"
-
-LIB_DEPEND="pcre? ( >=dev-libs/libpcre-7.8-r1[static-libs(+)] )
- sparc? ( dev-libs/libsigsegv )"
-RDEPEND="!static? ( ${LIB_DEPEND//\[static-libs(+)]} )
- nls? ( virtual/libintl )
- virtual/libiconv"
-DEPEND="${RDEPEND}
- static? ( ${LIB_DEPEND} )"
-BDEPEND="
- virtual/pkgconfig
- nls? ( sys-devel/gettext )
- verify-sig? ( sec-keys/openpgp-keys-grep )"
-
-PATCHES=(
- "${FILESDIR}/ppc-musl.patch"
- "${FILESDIR}/loong-fix-build.patch"
-)
-
-DOCS=( AUTHORS ChangeLog NEWS README THANKS TODO )
-
-src_prepare() {
- sed -i \
- -e "s:@SHELL@:${EPREFIX}/bin/sh:g" \
- -e "s:@grep@:${EPREFIX}/bin/grep:" \
- src/egrep.sh || die #523898
-
- default
-
- # touch generated files after patching m4, to avoid activating maintainer
- # mode
- # remove when loong-fix-build.patch is no longer necessary
- touch ./aclocal.m4 ./config.hin ./configure || die
- find . -name Makefile.in -exec touch {} + || die
-}
-
-src_configure() {
- use static && append-ldflags -static
-
- # We used to turn this off unconditionally (bug #673524) but we now
- # allow it for cases where libsigsegv is better for userspace handling
- # of stack overflows.
- # In particular, it's necessary for sparc: bug #768135
- export ac_cv_libsigsegv=$(usex sparc)
-
- # Always use pkg-config to get lib info for pcre.
- export ac_cv_search_pcre_compile=$(
- usex pcre "$($(tc-getPKG_CONFIG) --libs $(usex static --static '') libpcre)" ''
- )
- local myeconfargs=(
- --bindir="${EPREFIX}"/bin
- $(use_enable nls)
- $(use_enable pcre perl-regexp)
- )
- econf "${myeconfargs[@]}"
-}