summaryrefslogtreecommitdiff
path: root/sys-apps/gnome-disk-utility
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-09-19 05:21:10 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-09-19 05:21:10 +0100
commitfc32d443f6a2e4d05c712c050bb74e8f79f4af1f (patch)
tree88e65306c8610da66618d02504f074b776841055 /sys-apps/gnome-disk-utility
parentf39c6dab71f5188f95650d367ece1df4f263e474 (diff)
gentoo auto-resync : 19:09:2022 - 05:21:10
Diffstat (limited to 'sys-apps/gnome-disk-utility')
-rw-r--r--sys-apps/gnome-disk-utility/Manifest2
-rw-r--r--sys-apps/gnome-disk-utility/gnome-disk-utility-43.0.ebuild63
2 files changed, 65 insertions, 0 deletions
diff --git a/sys-apps/gnome-disk-utility/Manifest b/sys-apps/gnome-disk-utility/Manifest
index 86ab81e4543a..5d93f99de659 100644
--- a/sys-apps/gnome-disk-utility/Manifest
+++ b/sys-apps/gnome-disk-utility/Manifest
@@ -1,3 +1,5 @@
DIST gnome-disk-utility-42.0.tar.xz 1740332 BLAKE2B 4d05876364a475d1e16651569862fe3e9bb97549463146e69722c55922c0609069334e198eff91208448dc0baf7fcefe6bab56612e89fd7412fea42ba20549d2 SHA512 c47c37262295ba455b483a7ebe7799e92f94b97d177327817bb088cddcc3ff1f5840c3e270651287ff6a88257ec7cfcd1abe4167bf7454bbf55e145c8f1dc7c9
+DIST gnome-disk-utility-43.0.tar.xz 1752240 BLAKE2B 906183e7f61c4e9d2206fe2c99034f06a0aa3869d253587325ae18b336dffc6d8523a2f4d89c4338ed64947e73c5a24de15dfdb15a9d42d77fe51fd2321bf159 SHA512 8cb1b10fba21c90bceec9521103defe092dea9a4c89a39ae44e4d5981dd0d1958649e7a2743535f0135a3c9179cad0e0aced98dfc805e19bdec81651abcecf48
EBUILD gnome-disk-utility-42.0.ebuild 1420 BLAKE2B f49175cccf7b980232eead9e9d9c8bb88c89c6b1fbd9e80d54f1d1d74505757995c40d50c70e6cf1b70866306ebf8d138f86c9d27aa8d0f630e676a72ca1c8d1 SHA512 07e8d01b90398ec739b4a2d1d421e7b340fde1b437707312e71b0572663c91a2d4881dc7fbd95cbe44819f77d383a1c6a9f6da0d0f56ebb77282680d832cd769
+EBUILD gnome-disk-utility-43.0.ebuild 1420 BLAKE2B 86a4aa721ce5a0064388dbfdc39e598a754ccd475201e5717baabeee5a1019bd8321f98cfbda22287a758a682f252b593a428cad6d2c861afe349a2df22fb3af SHA512 dbd9f2153790c9d6524b4098264a54a112b63a56ea969cb0b924fa046ffcba8e21d8ca32d106cbdeb63f7a2e15868ec8911c9440539e48d06f3e409ba559287f
MISC metadata.xml 598 BLAKE2B e9bd803739e63d5667cf9d84b27af2efeeac8e31591d022cfce00fa147f4ee267ea2c03624f43c2d822c00b853b1606f6663814a731182aaf557be259ab2fe45 SHA512 fa5f53e258f9db1447b28979f655b6794491af9eafd0d6f113d43fd2073d36fcedc126fef7fde4a21b99e2ad11e4442c7c333d9dfaeee92064b0de23c071c23e
diff --git a/sys-apps/gnome-disk-utility/gnome-disk-utility-43.0.ebuild b/sys-apps/gnome-disk-utility/gnome-disk-utility-43.0.ebuild
new file mode 100644
index 000000000000..7151173932fa
--- /dev/null
+++ b/sys-apps/gnome-disk-utility/gnome-disk-utility-43.0.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome.org gnome2-utils meson xdg
+
+DESCRIPTION="Disk Utility for GNOME using udisks"
+HOMEPAGE="https://wiki.gnome.org/Apps/Disks"
+
+LICENSE="GPL-2+"
+SLOT="0"
+IUSE="fat elogind gnome systemd"
+REQUIRED_USE="?? ( elogind systemd )"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+DEPEND="
+ >=media-libs/libdvdread-4.2.0:0=
+ >=dev-libs/glib-2.31:2
+ >=x11-libs/gtk+-3.16.0:3
+ >=media-libs/libcanberra-0.1[gtk3]
+ >=gui-libs/libhandy-1.5.0:1
+ >=app-arch/xz-utils-5.0.5
+ >=x11-libs/libnotify-0.7
+ >=app-crypt/libsecret-0.7
+ >=dev-libs/libpwquality-1.0.0
+ >=sys-fs/udisks-2.7.6:2
+ elogind? ( >=sys-auth/elogind-209 )
+ systemd? ( >=sys-apps/systemd-209:0= )
+"
+RDEPEND="${DEPEND}
+ x11-themes/adwaita-icon-theme
+ fat? ( sys-fs/dosfstools )
+ gnome? ( >=gnome-base/gnome-settings-daemon-3.8 )
+"
+# libxml2 for xml-stripblanks in gresource
+BDEPEND="
+ dev-libs/libxml2:2
+ app-text/docbook-xsl-stylesheets
+ dev-libs/libxslt
+ dev-util/glib-utils
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local emesonargs=(
+ -Dlogind=$(usex systemd libsystemd $(usex elogind libelogind none))
+ $(meson_use gnome gsd_plugin)
+ -Dman=true
+ )
+ meson_src_configure
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}