summaryrefslogtreecommitdiff
path: root/sys-apps/gentoo-systemd-integration
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sys-apps/gentoo-systemd-integration
reinit the tree, so we can have metadata
Diffstat (limited to 'sys-apps/gentoo-systemd-integration')
-rw-r--r--sys-apps/gentoo-systemd-integration/Manifest6
-rw-r--r--sys-apps/gentoo-systemd-integration/gentoo-systemd-integration-7.ebuild36
-rw-r--r--sys-apps/gentoo-systemd-integration/gentoo-systemd-integration-9999.ebuild36
-rw-r--r--sys-apps/gentoo-systemd-integration/metadata.xml11
4 files changed, 89 insertions, 0 deletions
diff --git a/sys-apps/gentoo-systemd-integration/Manifest b/sys-apps/gentoo-systemd-integration/Manifest
new file mode 100644
index 000000000000..38ab9beeb271
--- /dev/null
+++ b/sys-apps/gentoo-systemd-integration/Manifest
@@ -0,0 +1,6 @@
+DIST gentoo-systemd-integration-7.tar.gz 64243 SHA256 f850a15cc16e80256a144402e8a67e010974b7a5bbc1510858b051a6b9c3c3ce SHA512 cd47caa01d73da57998b6b37d89cbeb53fa722c7f4a31bb03d03762350490cde1db3ce06090df6b6ff25c1cafb40f6c2186efbd52156ebc6d078b4a59d6fef52 WHIRLPOOL f972878ad1fee2cfa2bb101dccaf8cc8ea67e84c650c61510330885c0b114864b88f47a796321ea7c1e53eaa7c66b395c5b005a7f41ba85f1bd645875b5a2315
+EBUILD gentoo-systemd-integration-7.ebuild 784 SHA256 5fcb27ee5483c549e72a812d59253f1f3efa0e7649138b2358266d3307188083 SHA512 35d53e71463b53acf5096b904a5dcd15efbe5eae2a8649ae3ac7d8348a920f14e2e0e5dbb1eb652016e0d6d512ac12664f1456a479a45809953c02520d81afb1 WHIRLPOOL e154d50c0b4d44d6945028ad57d865c85a9767d2e6d211a5e7e4015b313d3ecd18224d47aecfad37eb3c1a170daa24bd8b62b27414be3be8389faa95a413658b
+EBUILD gentoo-systemd-integration-9999.ebuild 792 SHA256 944771ba5a39e3581a62fc013dcd7b5cf33ea37724f22cab49a0a77342b87ac5 SHA512 cefd3d785b861966a977948f1095f959249f33c7ee9de9e1021026d4ec76bb9ac09311fa8c5cce19a5726d92e23bdf940b0bca91e3551755fe61848283c7eed6 WHIRLPOOL 662aa35a69d99a68c035793d678e2d7569074b0b5076a3e24eb977a034efd01ca972d587331338ec050bbf8925f7a1c2394d13d1faa1f2fd0f4e32327ca68a4b
+MISC ChangeLog 3503 SHA256 bd6b92ae325cd5afadbe4c4ef1b2e264505322e608a81ff2f58142c634559888 SHA512 0acaee6fbc2a5b12a5703aff65b2b49003a0a8bc6eb5e73031a14a33e6d050db51d77028abe868768b9d63ed16c9cbe85e563eb73ccb7082c344670fdfaea35c WHIRLPOOL 2c7fd308da4d053c99181e2b03f8db4844d1cc841c242dbab213743789e9aa1e62d374412843f9d75fb18b9eda260a364dd5821bc226396202076eb841509a66
+MISC ChangeLog-2015 5129 SHA256 aa053242220a9ee96b891c591a957cb69a4c4208021e0a638ae2775bbfc04784 SHA512 13160f9bb0806a6931abb790135f712144871a9c453451018ef201ab6b0ad9637f900bd59e6fdaa64f24d4ade8c6c1909e045c3c912cb4830cfa274d85e12bbb WHIRLPOOL af62dceddbb4dca5e0dd16372eb0256a920269818cd0fddf6a0407286311c40b59c3b3ee6ea4e35a88682cc3c0f90751a393e4752cc61af828bbd712b665a9b5
+MISC metadata.xml 355 SHA256 e76b6777a93292cb4b2f8e9f98cede234e4771f2d8e85c430059eb005e32011b SHA512 b590b927b555441da6f665dbf637ffaa27651f074a62d1738959c5913f45ee648146f9054e07ade42d5f28f93cb350b43c94299a50506d01d446de22ebacdbc0 WHIRLPOOL 713436cbd994616c830de0a1e15d5125f10b4fc2c3a141d03222ef39bade8d1439ac6248c7d20ad3192d877afdb04a0b835eb8f4537d9078587814306f87d4b5
diff --git a/sys-apps/gentoo-systemd-integration/gentoo-systemd-integration-7.ebuild b/sys-apps/gentoo-systemd-integration/gentoo-systemd-integration-7.ebuild
new file mode 100644
index 000000000000..7a5689085273
--- /dev/null
+++ b/sys-apps/gentoo-systemd-integration/gentoo-systemd-integration-7.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+if [[ ${PV} == 9999 ]]; then
+ EGIT_REPO_URI="https://anongit.gentoo.org/git/proj/gentoo-systemd-integration.git"
+ inherit autotools git-r3
+else
+ SRC_URI="https://dev.gentoo.org/~floppym/dist/${P}.tar.gz"
+ KEYWORDS="alpha amd64 arm ~arm64 ia64 ppc ppc64 sparc x86"
+fi
+
+inherit systemd
+
+DESCRIPTION="systemd integration files for Gentoo"
+HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Systemd"
+
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND=">=sys-apps/systemd-207
+ !sys-fs/eudev
+ !sys-fs/udev"
+DEPEND=">=sys-apps/systemd-207
+ virtual/pkgconfig"
+
+if [[ ${PV} == 9999 ]]; then
+ DEPEND+=" sys-devel/systemd-m4"
+fi
+
+src_prepare() {
+ default
+ [[ ${PV} != 9999 ]] || eautoreconf
+}
diff --git a/sys-apps/gentoo-systemd-integration/gentoo-systemd-integration-9999.ebuild b/sys-apps/gentoo-systemd-integration/gentoo-systemd-integration-9999.ebuild
new file mode 100644
index 000000000000..1813ffb135fb
--- /dev/null
+++ b/sys-apps/gentoo-systemd-integration/gentoo-systemd-integration-9999.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+if [[ ${PV} == 9999 ]]; then
+ EGIT_REPO_URI="https://anongit.gentoo.org/git/proj/gentoo-systemd-integration.git"
+ inherit autotools git-r3
+else
+ SRC_URI="https://dev.gentoo.org/~floppym/dist/${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+fi
+
+inherit systemd
+
+DESCRIPTION="systemd integration files for Gentoo"
+HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Systemd"
+
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND=">=sys-apps/systemd-207
+ !sys-fs/eudev
+ !sys-fs/udev"
+DEPEND=">=sys-apps/systemd-207
+ virtual/pkgconfig"
+
+if [[ ${PV} == 9999 ]]; then
+ DEPEND+=" sys-devel/systemd-m4"
+fi
+
+src_prepare() {
+ default
+ [[ ${PV} != 9999 ]] || eautoreconf
+}
diff --git a/sys-apps/gentoo-systemd-integration/metadata.xml b/sys-apps/gentoo-systemd-integration/metadata.xml
new file mode 100644
index 000000000000..0c04b426d911
--- /dev/null
+++ b/sys-apps/gentoo-systemd-integration/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>systemd@gentoo.org</email>
+ <name>Gentoo systemd team</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="bitbucket">mgorny/gentoo-systemd-integration</remote-id>
+ </upstream>
+</pkgmetadata>