summaryrefslogtreecommitdiff
path: root/sys-apps/gentoo-functions
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
commitd934827bf44b7cfcf6711964418148fa60877668 (patch)
tree0625f358789b5e015e49db139cc1dbc9be00428f /sys-apps/gentoo-functions
parent2e34d110f164bf74d55fced27fe0000201b3eec5 (diff)
gentoo resync : 25.11.2020
Diffstat (limited to 'sys-apps/gentoo-functions')
-rw-r--r--sys-apps/gentoo-functions/Manifest2
-rw-r--r--sys-apps/gentoo-functions/gentoo-functions-0.14.ebuild28
2 files changed, 30 insertions, 0 deletions
diff --git a/sys-apps/gentoo-functions/Manifest b/sys-apps/gentoo-functions/Manifest
index 3488d68e5ec7..58ccc4023503 100644
--- a/sys-apps/gentoo-functions/Manifest
+++ b/sys-apps/gentoo-functions/Manifest
@@ -1,4 +1,6 @@
DIST gentoo-functions-0.13.tar.gz 11334 BLAKE2B 740e6d950b62b777e533d16b707cbf6f9ab0e9de4c92c5e755af186571539949017aadcd7d428b1e635f43052a575f89787b3e92087675b600a6b7350fda24a6 SHA512 61185197e1eb4155d0db9ba024dcb1b9eb0d272e3369f986668634012e35b57c3cdcd7beecd4714b9b48a0e44e8bb73472713949e16827aa05c055ec83d537dd
+DIST gentoo-functions-0.14.tar.gz 11330 BLAKE2B 72543941f2954e35d3671c1c482eda44ae00cf0c636a1d706c5b90c56dfbb985d20c156b6de650e5d33ff9fac0abaf9fc50b1172832c2bd5276f6adfe5baf3b8 SHA512 e1e0fee9f3e8b79478aaf2b9a54c8623c858e62f72f2885ea88f7006631cf513bdfaac7122f2a5fc97379bde57851793bf7d6c63a1c63a6923a7f13a73d803fc
EBUILD gentoo-functions-0.13.ebuild 886 BLAKE2B 7bb2051509bc332c95b1a2d6ee7d0aebe3ddfeb487559de756474cd96d46263b5af57389a16f53df1c673daaec4dd618e5140800c79227d18337980091dd1c9d SHA512 5ba8f91873a2ad75848ef3b443c0c7a99665df73dc2c20a61a1b64ef3ac38478bda80abd0e0e059ed9ad97fcfa1eb73d6318c1e68efe4e7b79859ffce1600fff
+EBUILD gentoo-functions-0.14.ebuild 895 BLAKE2B 0e9cb57058a2d4141cd57c169ced43ee6f9afd33c0214e3303e01572b3667df7b5634a40ef78087b3e2333ada242f010f33042abd7e030848a3044a85a83d792 SHA512 dad2d0c9786786eca6dd55156599f1c2db030a15556ede83d03a170317f3f25d9226bba805575d82e46041759763e7972de05a6c34808e2b2e0ee6f8853701f2
EBUILD gentoo-functions-9999.ebuild 895 BLAKE2B 0e9cb57058a2d4141cd57c169ced43ee6f9afd33c0214e3303e01572b3667df7b5634a40ef78087b3e2333ada242f010f33042abd7e030848a3044a85a83d792 SHA512 dad2d0c9786786eca6dd55156599f1c2db030a15556ede83d03a170317f3f25d9226bba805575d82e46041759763e7972de05a6c34808e2b2e0ee6f8853701f2
MISC metadata.xml 492 BLAKE2B cd68fc088438ae1171d801f7aeb93ac09a21dd2e628ab14c11e2f3f28fba3ad3653005d087ab5c44362b9b6fbc66b1c14256176c6f181313cbf3aa6a01c6739b SHA512 991fa3c3f302d26f4beb103c5dab1b943599aa83ca538b04a785ba608059471047061296d219b637a8b16185105c0ace8b0ff511ec2d94c840be27d96ac8e3c6
diff --git a/sys-apps/gentoo-functions/gentoo-functions-0.14.ebuild b/sys-apps/gentoo-functions/gentoo-functions-0.14.ebuild
new file mode 100644
index 000000000000..04f1a329e9ec
--- /dev/null
+++ b/sys-apps/gentoo-functions/gentoo-functions-0.14.ebuild
@@ -0,0 +1,28 @@
+# Copyright 2014-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+if [[ ${PV} == 9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://anongit.gentoo.org/git/proj/gentoo-functions.git"
+else
+ SRC_URI="https://gitweb.gentoo.org/proj/gentoo-functions.git/snapshot/${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris ~x86-winnt"
+fi
+
+inherit toolchain-funcs flag-o-matic
+
+DESCRIPTION="base functions required by all Gentoo systems"
+HOMEPAGE="https://gitweb.gentoo.org/proj/gentoo-functions.git"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+src_configure() {
+ tc-export CC
+ append-lfs-flags
+ export ROOTPREFIX="${EPREFIX}"
+ export PREFIX="${EPREFIX}/usr"
+}