summaryrefslogtreecommitdiff
path: root/sys-apps/gentoo-functions
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-02-16 23:37:06 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-02-16 23:37:06 +0000
commitd228f661892a9e55a86f00c2c14625490631d797 (patch)
tree1ff5297945a5544ca5b30a9206eb788ab4c431d7 /sys-apps/gentoo-functions
parent3b00f2d2f95f5d6ff01e71259eb94fa714a92232 (diff)
gentoo auto-resync : 16:02:2024 - 23:37:06
Diffstat (limited to 'sys-apps/gentoo-functions')
-rw-r--r--sys-apps/gentoo-functions/Manifest2
-rw-r--r--sys-apps/gentoo-functions/gentoo-functions-1.0.ebuild36
2 files changed, 38 insertions, 0 deletions
diff --git a/sys-apps/gentoo-functions/Manifest b/sys-apps/gentoo-functions/Manifest
index fbe310dc357a..070fa83b7148 100644
--- a/sys-apps/gentoo-functions/Manifest
+++ b/sys-apps/gentoo-functions/Manifest
@@ -1,4 +1,6 @@
DIST gentoo-functions-0.19.tar.bz2 12079 BLAKE2B be0a3a54d4dee1755866047b670a69cd6fec368239123c3f0c08180b79a33c20147bca0e35e568faef6877513551e731bdf0c181aeb0460f6574d2d708219373 SHA512 2674d3fe5724cc6d685ae58bf0ee33f4a1bdba2c5e5809cfb193fd0a710d4678c2d9392c2c62d2321cf455f524950266dc1629ab684fe46632d179e539d5a39e
+DIST gentoo-functions-1.0.tar.bz2 18066 BLAKE2B a843de65d5d8f93396713dd5c80377dad478482d5749736ec3a08e0d0cc40f1a2ce5c967282b8060452d73f6377590f06e5c2a12cdfc753e7f6a18754cde4997 SHA512 057a7159a613108710a40f2ca54403adf64ab9649732be49d3a72314e2ca3c65d7a9093168e26ec12814203e1fe14cc1fc5cf2cefa2f923ec8bb714972d20f55
EBUILD gentoo-functions-0.19.ebuild 877 BLAKE2B 457e5c405c05e9e928c4f8e9e764fe07b7ace335750bebb01d7226e9b7b1f7ceac0fcb49148087439c8a6b42c034aa1f7590b4203e9d42f06031f2b3acee58d4 SHA512 c846b3451c764b64ec601e9d579542a47d68775e94eac97b8680a08891076226279f0611a19a72ba1b75b0cb35941b22ff3c734831e6c8665c2ca5b65cd1f5b4
+EBUILD gentoo-functions-1.0.ebuild 1025 BLAKE2B ec059aed56465fcfd1ee9e057b77c1d1f9c4c251a863c742806a191459b2432a1bc5c7d339d4028fd80f4a77de2c8a21bd7d3724e2dd7c17fa628e7110d658c6 SHA512 0e0b913559b3bd975a53a69bdebb1b04350f59c6c3f5e761ad3ac6472db70a8cbe4c3273158569ce35597d4e81a0e4e15c5805e2585e6ff3025967b02e0b503d
EBUILD gentoo-functions-9999.ebuild 1025 BLAKE2B fdfa38a3fa0dbd7bceff4f1a211924f5efa890b6f4ee75e1a46d182a508eb89e153994a6d2805147f1c8cf0556460927479e598cb053ff716b6c81a45f1fca53 SHA512 31dd91c713f4172825d28c2d018baaf46b7e0e408cd2c0f1f9cfafaba6932d1a8ea80e9a9b9402b7d483295524a384de2320adae70ed63820e3334acfab1bc7b
MISC metadata.xml 487 BLAKE2B c34b1b196d84a44ca3f2729101b826a6460f6b560f942e95e444d23b821256e9c4f330e5b7a2530dabd34b0f1e0a3844ed4b52ea5944500b0b4c72bd955f988a SHA512 3c3008734be30e74ccf3a1f34e4112eef2df0f4e8b0b5d1dd1e90037d130428b21b05ad3686a74c18e5a035a15b32e89cd04de4274e311aa1e30a42ad8cf97f0
diff --git a/sys-apps/gentoo-functions/gentoo-functions-1.0.ebuild b/sys-apps/gentoo-functions/gentoo-functions-1.0.ebuild
new file mode 100644
index 000000000000..8df3a1e88bad
--- /dev/null
+++ b/sys-apps/gentoo-functions/gentoo-functions-1.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 2014-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+if [[ ${PV} == 9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://anongit.gentoo.org/git/proj/gentoo-functions.git"
+else
+ SRC_URI="https://gitweb.gentoo.org/proj/gentoo-functions.git/snapshot/${P}.tar.bz2"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+fi
+
+inherit meson
+
+DESCRIPTION="Base functions required by all Gentoo systems"
+HOMEPAGE="https://gitweb.gentoo.org/proj/gentoo-functions.git"
+
+LICENSE="GPL-2 public-domain"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+# Specifically needs GNU find, as well.
+RDEPEND=">=sys-apps/findutils-4.9"
+
+src_configure() {
+ local emesonargs=(
+ # Deliberately avoid /usr as consumers assume we're at /lib/gentoo.
+ --prefix="${EPREFIX:-/}"
+ --mandir="${EPREFIX}/usr/share/man"
+ $(meson_use test tests)
+ )
+
+ meson_src_configure
+}