summaryrefslogtreecommitdiff
path: root/sys-apps/gentoo-functions
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-06-09 15:48:37 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-06-09 15:48:37 +0100
commit60010a4cd6d7c12aaa62f00b5e8a158ed24efba6 (patch)
treea961dd82d2d2719fe5bede9343e9e83cce856d9f /sys-apps/gentoo-functions
parent65a4d80ebaba5d4d407b3d09320b337e0ca20f0a (diff)
gentoo auto-resync : 09:06:2023 - 15:48:36
Diffstat (limited to 'sys-apps/gentoo-functions')
-rw-r--r--sys-apps/gentoo-functions/Manifest2
-rw-r--r--sys-apps/gentoo-functions/gentoo-functions-9999.ebuild16
2 files changed, 12 insertions, 6 deletions
diff --git a/sys-apps/gentoo-functions/Manifest b/sys-apps/gentoo-functions/Manifest
index 488d611e478b..8d77b2ef346b 100644
--- a/sys-apps/gentoo-functions/Manifest
+++ b/sys-apps/gentoo-functions/Manifest
@@ -2,5 +2,5 @@ DIST gentoo-functions-0.17.tar.bz2 10798 BLAKE2B 1b725945421ab36b1412f9addc22e9f
DIST gentoo-functions-0.19.tar.bz2 12079 BLAKE2B be0a3a54d4dee1755866047b670a69cd6fec368239123c3f0c08180b79a33c20147bca0e35e568faef6877513551e731bdf0c181aeb0460f6574d2d708219373 SHA512 2674d3fe5724cc6d685ae58bf0ee33f4a1bdba2c5e5809cfb193fd0a710d4678c2d9392c2c62d2321cf455f524950266dc1629ab684fe46632d179e539d5a39e
EBUILD gentoo-functions-0.17.ebuild 801 BLAKE2B 4978d1de5281924566ba4f25eb79c7b4960fad0288a6bf6a51a2e1815a1bce61bd8f284c2ba4912812e3be8a703fcbe52b95ccc489b4de726ed22684fd34c5c2 SHA512 96e464b073d00a9901e8d899a3d88371267966f58a314b3c800f475d112ef349f77ddcfd0d78b68c508a4707d15c81f4fe4c0a1e1d5cdfa557352ead09729797
EBUILD gentoo-functions-0.19.ebuild 877 BLAKE2B 457e5c405c05e9e928c4f8e9e764fe07b7ace335750bebb01d7226e9b7b1f7ceac0fcb49148087439c8a6b42c034aa1f7590b4203e9d42f06031f2b3acee58d4 SHA512 c846b3451c764b64ec601e9d579542a47d68775e94eac97b8680a08891076226279f0611a19a72ba1b75b0cb35941b22ff3c734831e6c8665c2ca5b65cd1f5b4
-EBUILD gentoo-functions-9999.ebuild 885 BLAKE2B fd04a8b67e45517aa030500507ca31d2e77e119a614d74e1ce4d17b243993b949a44912ff860f451d61c387868fc1bbe8b41d157989054d336baa818456ef616 SHA512 7dac7df3ec5f0acec19c0d4ccdc35e398772bb133de879378602357a60cc8ee06f82d850db4ffe52b70baf85ada46a0da52fc975d0e7ca734f93e0c8f957df7c
+EBUILD gentoo-functions-9999.ebuild 1011 BLAKE2B cf8c057f158e46b8c3eca48663d82ae42dcb4ebdd213e7f37bbddfe908dc7bbc0b209fa25831d485f15914fadf943468b2d605a564644b2acbde1d5987ced1d6 SHA512 a69705a6b57437e5e29b244c7d43e58c186a85053fe7b809e2758064df7518bbe056aa78fa2e1113413713552787e93aecd527f53c87682f4d2c9e28ec02643e
MISC metadata.xml 416 BLAKE2B 08b6d649521646ff28c4738fbc3b9a292740bceb2430dab5ee4391bded078bd0c05dff69a28f722a1c23bbbb86af546935a055f93720ea759b141902f367394a SHA512 88409b09c14a2eb4859166e88f4a59ffc2e84e18a246b942f50ebd58bf83f0e6710f0405f08d102853cbd94562140a267cb60db29b4170893b7c3b3e24ec1ae3
diff --git a/sys-apps/gentoo-functions/gentoo-functions-9999.ebuild b/sys-apps/gentoo-functions/gentoo-functions-9999.ebuild
index d704dea16611..b43489741598 100644
--- a/sys-apps/gentoo-functions/gentoo-functions-9999.ebuild
+++ b/sys-apps/gentoo-functions/gentoo-functions-9999.ebuild
@@ -11,20 +11,26 @@ else
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
fi
-inherit toolchain-funcs flag-o-matic
+inherit meson
DESCRIPTION="Base functions required by all Gentoo systems"
HOMEPAGE="https://gitweb.gentoo.org/proj/gentoo-functions.git"
LICENSE="GPL-2"
SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
# Specifically needs GNU find, as well.
RDEPEND=">=sys-apps/findutils-4.9"
src_configure() {
- tc-export CC
- append-lfs-flags
- export ROOTPREFIX="${EPREFIX}"
- export PREFIX="${EPREFIX}/usr"
+ local emesonargs=(
+ # Deliberately avoid /usr as consumers assume we're at /lib/gentoo.
+ --prefix="${EPREFIX:-/}"
+ --mandir="${EPREFIX}/usr/share/man"
+ $(meson_use test tests)
+ )
+
+ meson_src_configure
}