summaryrefslogtreecommitdiff
path: root/sys-apps/gentoo-functions
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sys-apps/gentoo-functions
reinit the tree, so we can have metadata
Diffstat (limited to 'sys-apps/gentoo-functions')
-rw-r--r--sys-apps/gentoo-functions/Manifest6
-rw-r--r--sys-apps/gentoo-functions/gentoo-functions-0.12.ebuild30
-rw-r--r--sys-apps/gentoo-functions/gentoo-functions-9999.ebuild30
-rw-r--r--sys-apps/gentoo-functions/metadata.xml21
4 files changed, 87 insertions, 0 deletions
diff --git a/sys-apps/gentoo-functions/Manifest b/sys-apps/gentoo-functions/Manifest
new file mode 100644
index 000000000000..27c7e5f945d2
--- /dev/null
+++ b/sys-apps/gentoo-functions/Manifest
@@ -0,0 +1,6 @@
+DIST gentoo-functions-0.12.tar.gz 11514 SHA256 4a6ddb1d8be7b52aae68761fb26546663b6b0e74b155df263cddfbfa72373965 SHA512 181e09216e1ed78f590e0bb50c60cfb0295bfeef335ed6c957ea7f2a1d6145d91c0a6dc4377bd6cd538fb4e5871e9a5ef8332d91bc91931792d5f05f62bc4705 WHIRLPOOL 18b10a8fab6c4bd4f206d752915d5a43ee21d60d0dec952b2c5db44c5b9e9abfa05aca34984750a3fbbdc48b159a017cb9923afd92b79e3e868da702ef8db267
+EBUILD gentoo-functions-0.12.ebuild 862 SHA256 8ecba8780ea8dfcd7ce9daaa2899fae1ae62fd01808b6abee6b90f2c31b2262d SHA512 dfbc0d762ce7c4ce9bf7f85b1600ae746135e876b57b01acc9d47d886a7efc72786f52bf21e99bf15ed4c13f9b887ba4fe7fe017d97bdf6ab8cb477be83d5746 WHIRLPOOL 5407ff84df0c3678497de20a200b332bf118eef9d9310044660998f156d6da939d9bfe9251f4491bbfd0106b6dcf3f8ec056b8134864234ecbe038651f8fcc99
+EBUILD gentoo-functions-9999.ebuild 859 SHA256 98ea1be4b63cc92d5110b3af9183135186e96679202cbb969da48ab5d6c2eab2 SHA512 8ed5e1564aad2a5c26f8f771cf027f3dc2ae471b08a50ab945cc9703c7dd96fb5a947f9a8e9d5f33a8afcd98876507279187165d0dca8bcf29a5fe56bac25633 WHIRLPOOL 82feff0a19710b851a7e6bdbcc105c9b482ed867db11f18148d3f2ff8c7d6ff56a84495433f3b94ca53f1c59e2ca06c0b393a857fbb09e4a801bf095da94f9ae
+MISC ChangeLog 5239 SHA256 9460e738b2ea06b94dd6c85e7f1448cb399e307e5bcb26e1be37f272b3d62846 SHA512 c7e8111205caba5daf092ae274c8ac3e8370ba2ca5ead57b3f11c3a27517c12fcc90f07a49cd9d2704e34d53b18a50f87249b14842bcee2a35107b5f34fa464a WHIRLPOOL 735cfac218a8315a20e88cf82fd99025d1e976c0a085809c251a6f98f45ba288582d3dac917c96661ef5438ad94f4c212f4e348c450b40a2d17291b55ae38776
+MISC ChangeLog-2015 5503 SHA256 2df4dca4854d7339cf71f9bc729b3acb3573097ad59182bde4ec94425e6bec47 SHA512 49ebd966165f42323c3e70d6f8819ec4734f1f2c983cce378513b2120e82ba3f8bc999285309ffc6a283d1194c898b3c096d8b30a1705c7352958cfccb9084f1 WHIRLPOOL b361df049bc98647ebf66627e58441e9680fcae3e044c495eccebd0235cb3f10296d863874edb72b1c700d6183a2037a2489d76d1a23bf0f96e77833e26486d2
+MISC metadata.xml 626 SHA256 88089c3d0cb964235fb2ae816735d90430873f5c9e17524f80a851dfb7e99a51 SHA512 c63b4d51b0cd8ae662f66870ca15a26300005fd683a4a16643aa553128b2ded5ee0542a8185ae09b989040f602f2f42f79e02574e44bb1ce63457b5c0d8b4dd2 WHIRLPOOL ed25cb9f1dba2d8c107bccbabc4f2da65fa0ef4b8614ccca2cc6794ab4a392d1eb06161cb01c5fb5c527beff38398fe1f45c50b64b2416225f5b927cc1560172
diff --git a/sys-apps/gentoo-functions/gentoo-functions-0.12.ebuild b/sys-apps/gentoo-functions/gentoo-functions-0.12.ebuild
new file mode 100644
index 000000000000..e35ad11a09f4
--- /dev/null
+++ b/sys-apps/gentoo-functions/gentoo-functions-0.12.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+if [[ ${PV} == 9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/gentoo/${PN}.git"
+else
+ SRC_URI="https://github.com/gentoo/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~m68k ~mips ppc ppc64 ~s390 ~sh sparc x86 ~ppc-aix ~x64-cygwin ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris ~x86-winnt"
+fi
+
+inherit toolchain-funcs flag-o-matic
+
+DESCRIPTION="base functions required by all Gentoo systems"
+HOMEPAGE="https://www.gentoo.org"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+src_prepare() {
+ tc-export CC
+ append-lfs-flags
+}
+
+src_install() {
+ emake install DESTDIR="${ED}"
+}
diff --git a/sys-apps/gentoo-functions/gentoo-functions-9999.ebuild b/sys-apps/gentoo-functions/gentoo-functions-9999.ebuild
new file mode 100644
index 000000000000..94ee57ba1007
--- /dev/null
+++ b/sys-apps/gentoo-functions/gentoo-functions-9999.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+if [[ ${PV} == 9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/gentoo/${PN}.git"
+else
+ SRC_URI="https://github.com/gentoo/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris ~x86-winnt"
+fi
+
+inherit toolchain-funcs flag-o-matic
+
+DESCRIPTION="base functions required by all Gentoo systems"
+HOMEPAGE="https://www.gentoo.org"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+src_prepare() {
+ tc-export CC
+ append-lfs-flags
+}
+
+src_install() {
+ emake install DESTDIR="${ED}"
+}
diff --git a/sys-apps/gentoo-functions/metadata.xml b/sys-apps/gentoo-functions/metadata.xml
new file mode 100644
index 000000000000..1cc4955d2ebd
--- /dev/null
+++ b/sys-apps/gentoo-functions/metadata.xml
@@ -0,0 +1,21 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="person">
+ <email>williamh@gentoo.org</email>
+</maintainer>
+<maintainer type="person">
+ <email>blueness@gentoo.org</email>
+</maintainer>
+<maintainer type="project">
+ <email>base-system@gentoo.org</email>
+ <name>Gentoo Base System</name>
+</maintainer>
+<longdescription lang="en">
+ This package contains base shell functions which are required by
+ all Gentoo systems.
+</longdescription>
+<upstream>
+ <remote-id type="github">gentoo/gentoo-functions</remote-id>
+</upstream>
+</pkgmetadata>