summaryrefslogtreecommitdiff
path: root/sys-apps/gawk
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-04-21 00:01:06 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-04-21 00:01:06 +0100
commitd33b3cf6cff9fdbfc8362bf854c3c34b2c28d518 (patch)
tree7fb87b3c81930bc74ab84958c42e07fde61f6b7f /sys-apps/gawk
parent1e2d947ea35b8fd5d14d55f60265f9763fa70a72 (diff)
gentoo auto-resync : 21:04:2023 - 00:01:05
Diffstat (limited to 'sys-apps/gawk')
-rw-r--r--sys-apps/gawk/Manifest2
-rw-r--r--sys-apps/gawk/gawk-5.2.1c.ebuild139
2 files changed, 141 insertions, 0 deletions
diff --git a/sys-apps/gawk/Manifest b/sys-apps/gawk/Manifest
index 30661bf257ef..ec364d1f539e 100644
--- a/sys-apps/gawk/Manifest
+++ b/sys-apps/gawk/Manifest
@@ -1,4 +1,6 @@
DIST gawk-5.2.1.tar.xz 3411420 BLAKE2B 5dbbfe92ed4c11a38b2f995e9267dd2e392a9f393af1c63aaf3c5dd6d1681c01db900e05a118831125f914fcffe2218de7f30891ccc6f64abc5f572aef5feeff SHA512 f81da3e61987d1460326dc79fdbabacfd4660219bf66ec8ba18877500fd24e160761e401a5b868067f82bec46a6a808098f3f6a1f4c8b710e439cd3f99ffa56c
DIST gawk-5.2.1.tar.xz.sig 488 BLAKE2B 5dcdc9ae90d4744a968cc750526a9c1c38915f85c56c2eca80b219ba8519c927ab55b7f569d55054b0499f7bf37d3413b97e9d3cf36f5573f9ecd4855663064e SHA512 97a9cfb069f235bef31892ec6e5c56ee6a8733129ae3d02e871d5407de4d7a6140fc0a87001b2b21e3cffd714d1b4d164876de47144dfdce6dea92c670ed0217
+DIST gawk-5.2.1c.tar.gz 6645383 BLAKE2B b4cf841f56f5646f95c746ad9f8d5e526fc98c4f057fa439edea8d38b5db06c8f3d3984e91378fbafaa35ef7c0c9f83810704262df85efd91a8d5ec4e946a06c SHA512 8324b7a1bac9afa3aeda1ad2c4d1d89c52e55712852105dac2797994f84bb9408b458e0d0f93f582fde040672cd70bf0eae1e65c2eba235f4db07a39aaa640d7
EBUILD gawk-5.2.1.ebuild 3563 BLAKE2B a991de67ab955d2d9f161d0fe98b89851781c77acea867e1cefa2f32b20f76ceea455193473a304851648fddf9cbe3149178f9c07653d5cf6a8a4f5d339eaa6a SHA512 6946e93fdd8dfa6c7313eaa5e98d8c7848c1227ae4cd4a3f91523d3b3478bd1e3fec7976e9070e4cb149f505692b7476b1368879ef1a8ffaf467f07df2d7f867
+EBUILD gawk-5.2.1c.ebuild 3564 BLAKE2B b9b32218f0e56cbb190e7b50b10f82e8b5528a38fa59aaf2bdca902aba2abb096b1315fa324ad91097070502516f3fed8c72c01bcc1a060eab574142eee45d51 SHA512 e85b65961492f9da427899cf4a269a26652121b9029f3f9a96264721703bd373af1979fbe67f661f1639c50d09f0503d3668e2e99e9e2bbb5a597c6ac0551552
MISC metadata.xml 654 BLAKE2B e04183a376da2006e727296257a18431f2e4f29fdabcee48edebb1c9dbf099c846af6bfe90d9e551ec4536c2dd034a80b47e6a1b8e442a89c1228929bef7d956 SHA512 9bb5a19c4b9a8ff7669c7ae7320a88d64eb68b4897f06d2046f71efe562a4846cb8c611bcc03b0111dfde19b40275f3357a5cd6285d4d5f0b4464a9c8b3eacb2
diff --git a/sys-apps/gawk/gawk-5.2.1c.ebuild b/sys-apps/gawk/gawk-5.2.1c.ebuild
new file mode 100644
index 000000000000..07a1fcd8d2b9
--- /dev/null
+++ b/sys-apps/gawk/gawk-5.2.1c.ebuild
@@ -0,0 +1,139 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+GAWK_IS_BETA=yes
+
+DESCRIPTION="GNU awk pattern-matching language"
+HOMEPAGE="https://www.gnu.org/software/gawk/gawk.html"
+
+if [[ ${GAWK_IS_BETA} == yes || ${PV} == *_beta* ]] ; then
+ if [[ ${PV} == *_beta* ]] ; then
+ # Beta versioning is sometimes for the release prior, e.g.
+ # 5.2.1_beta is labelled upstream as 5.2.0b.
+ MY_PV=${PV/_beta/b}
+ MY_PV=$(ver_cut 1-2 ${MY_PV}).$(($(ver_cut 3 ${MY_PV}) - 1))$(ver_cut 4- ${MY_PV})
+ MY_P=${PN}-${MY_PV}
+
+ S="${WORKDIR}"/${MY_P}
+ else
+ MY_P=${P}
+ fi
+
+ SRC_URI="https://www.skeeve.com/gawk/${MY_P}.tar.gz"
+else
+ VERIFY_SIG_OPENPGP_KEY_PATH="${BROOT}"/usr/share/openpgp-keys/gawk.asc
+ inherit verify-sig
+
+ SRC_URI="mirror://gnu/gawk/${P}.tar.xz"
+ SRC_URI+=" verify-sig? ( mirror://gnu/gawk/${P}.tar.xz.sig )"
+
+ KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~x64-cygwin ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+# While tempting to enable mpfr by default as e.g. Fedora do, as of 5.2.x,
+# MPFR support is "on parole" and may be removed:
+# https://www.gnu.org/software/gawk/manual/html_node/MPFR-On-Parole.html.
+IUSE="mpfr pma nls readline"
+
+RDEPEND="
+ mpfr? (
+ dev-libs/gmp:=
+ dev-libs/mpfr:=
+ )
+ readline? ( sys-libs/readline:= )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ >=sys-apps/texinfo-6.7
+ >=sys-devel/bison-3.5.4
+ nls? ( sys-devel/gettext )
+"
+
+if [[ ${GAWK_IS_BETA} != yes ]] ; then
+ BDEPEND+=" verify-sig? ( sec-keys/openpgp-keys-gawk )"
+fi
+
+src_prepare() {
+ default
+
+ # Use symlinks rather than hardlinks, and disable version links
+ sed -i \
+ -e '/^LN =/s:=.*:= $(LN_S):' \
+ -e '/install-exec-hook:/s|$|\nfoo:|' \
+ Makefile.in doc/Makefile.in || die
+
+ # bug #413327
+ sed -i '/^pty1:$/s|$|\n_pty1:|' test/Makefile.in || die
+
+ # Fix standards conflict on Solaris
+ if [[ ${CHOST} == *-solaris* ]] ; then
+ sed -i \
+ -e '/\<_XOPEN_SOURCE\>/s/1$/600/' \
+ -e '/\<_XOPEN_SOURCE_EXTENDED\>/s/1//' \
+ extension/inplace.c || die
+ fi
+}
+
+src_configure() {
+ # Avoid automagic dependency on libsigsegv
+ export ac_cv_libsigsegv=no
+
+ # README says gawk may not work properly if built with non-Bison.
+ # We already BDEPEND on Bison, so just unset YACC rather than
+ # guessing if we need to do yacc.bison or bison -y.
+ unset YACC
+
+ local myeconfargs=(
+ --cache-file="${S}"/config.cache
+ --libexec='$(libdir)/misc'
+ $(use_with mpfr)
+ $(use_enable nls)
+ $(use_enable pma)
+ $(use_with readline)
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ # Automatic dodocs barfs
+ rm -rf README_d || die
+
+ default
+
+ # Install headers
+ insinto /usr/include/awk
+ doins *.h
+ rm "${ED}"/usr/include/awk/config.h || die
+}
+
+pkg_postinst() {
+ # Symlink creation here as the links do not belong to gawk, but to any awk
+ if has_version app-admin/eselect && has_version app-eselect/eselect-awk ; then
+ eselect awk update ifunset
+ else
+ local l
+ for l in "${EROOT}"/usr/share/man/man1/gawk.1* "${EROOT}"/usr/bin/gawk ; do
+ if [[ -e ${l} ]] && ! [[ -e ${l/gawk/awk} ]] ; then
+ ln -s "${l##*/}" "${l/gawk/awk}" || die
+ fi
+ done
+
+ if ! [[ -e ${EROOT}/bin/awk ]] ; then
+ # /bin might not exist yet (stage1)
+ [[ -d "${EROOT}/bin" ]] || mkdir "${EROOT}/bin" || die
+
+ ln -s "../usr/bin/gawk" "${EROOT}/bin/awk" || die
+ fi
+ fi
+}
+
+pkg_postrm() {
+ if has_version app-admin/eselect && has_version app-eselect/eselect-awk ; then
+ eselect awk update ifunset
+ fi
+}