summaryrefslogtreecommitdiff
path: root/sys-apps/gawk/gawk-5.0.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-05-22 07:31:18 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-05-22 07:31:18 +0100
commit908778078736bd36f7a60a2d576d415cb8e000fa (patch)
treec6a4796c48b608c14dc7e9674cdbd38f905e3c15 /sys-apps/gawk/gawk-5.0.1.ebuild
parent185fa19bbf68a4d4dca534d2b46729207a177f16 (diff)
gentoo resync : 22.05.2021
Diffstat (limited to 'sys-apps/gawk/gawk-5.0.1.ebuild')
-rw-r--r--sys-apps/gawk/gawk-5.0.1.ebuild87
1 files changed, 0 insertions, 87 deletions
diff --git a/sys-apps/gawk/gawk-5.0.1.ebuild b/sys-apps/gawk/gawk-5.0.1.ebuild
deleted file mode 100644
index 4d4f28b7627a..000000000000
--- a/sys-apps/gawk/gawk-5.0.1.ebuild
+++ /dev/null
@@ -1,87 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit toolchain-funcs multilib
-
-DESCRIPTION="GNU awk pattern-matching language"
-HOMEPAGE="https://www.gnu.org/software/gawk/gawk.html"
-SRC_URI="mirror://gnu/gawk/${P}.tar.xz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="mpfr nls readline"
-
-RDEPEND="
- dev-libs/gmp:0=
- mpfr? ( dev-libs/mpfr:0= )
- readline? ( sys-libs/readline:0= )
-"
-DEPEND="${RDEPEND}"
-BDEPEND="
- nls? ( sys-devel/gettext )
-"
-
-src_prepare() {
- default
-
- # use symlinks rather than hardlinks, and disable version links
- sed -i \
- -e '/^LN =/s:=.*:= $(LN_S):' \
- -e '/install-exec-hook:/s|$|\nfoo:|' \
- Makefile.in doc/Makefile.in || die
- sed -i '/^pty1:$/s|$|\n_pty1:|' test/Makefile.in || die #413327
- # fix standards conflict on Solaris
- if [[ ${CHOST} == *-solaris* ]] ; then
- sed -i \
- -e '/\<_XOPEN_SOURCE\>/s/1$/600/' \
- -e '/\<_XOPEN_SOURCE_EXTENDED\>/s/1//' \
- extension/inplace.c || die
- fi
-}
-
-src_configure() {
- export ac_cv_libsigsegv=no
- local myeconfargs=(
- --libexec='$(libdir)/misc'
- $(use_with mpfr)
- $(use_enable nls)
- $(use_with readline)
- )
- econf "${myeconfargs[@]}"
-}
-
-src_install() {
- rm -rf README_d # automatic dodocs barfs
- default
-
- # Install headers
- insinto /usr/include/awk
- doins *.h
- rm "${ED}"/usr/include/awk/config.h || die
-}
-
-pkg_postinst() {
- # symlink creation here as the links do not belong to gawk, but to any awk
- if has_version app-admin/eselect && has_version app-eselect/eselect-awk ; then
- eselect awk update ifunset
- else
- local l
- for l in "${EROOT}"/usr/share/man/man1/gawk.1* "${EROOT}"/usr/bin/gawk ; do
- if [[ -e ${l} ]] && ! [[ -e ${l/gawk/awk} ]] ; then
- ln -s "${l##*/}" "${l/gawk/awk}" || die
- fi
- done
- if ! [[ -e ${EROOT}/bin/awk ]] ; then
- ln -s "../usr/bin/gawk" "${EROOT}/bin/awk" || die
- fi
- fi
-}
-
-pkg_postrm() {
- if has_version app-admin/eselect && has_version app-eselect/eselect-awk ; then
- eselect awk update ifunset
- fi
-}