summaryrefslogtreecommitdiff
path: root/sys-apps/fwts/fwts-23.11.00.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-12-30 07:33:01 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-12-30 07:33:01 +0000
commitaa3d072f61e6cd7fc4df214959d003f944fe1619 (patch)
tree7963dc15cd686cf863046c2d8eca4203e66b89b4 /sys-apps/fwts/fwts-23.11.00.ebuild
parent65e0298c5630af19b2b181c2dd143bb47aa54231 (diff)
gentoo auto-resync : 30:12:2023 - 07:33:01
Diffstat (limited to 'sys-apps/fwts/fwts-23.11.00.ebuild')
-rw-r--r--sys-apps/fwts/fwts-23.11.00.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/sys-apps/fwts/fwts-23.11.00.ebuild b/sys-apps/fwts/fwts-23.11.00.ebuild
new file mode 100644
index 000000000000..fc9c4f7e275a
--- /dev/null
+++ b/sys-apps/fwts/fwts-23.11.00.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="Firmware Test Suite"
+HOMEPAGE="https://wiki.ubuntu.com/Kernel/Reference/fwts https://github.com/fwts/fwts"
+SRC_URI="https://github.com/fwts/fwts/archive/refs/tags/V${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+#https://github.com/fwts/fwts/issues/13
+#KEYWORDS="~amd64"
+
+DEPEND="dev-libs/glib:2
+ >=dev-libs/json-c-0.10-r1
+ dev-libs/libbsd
+ dev-libs/libpcre
+ sys-apps/dmidecode
+ sys-apps/dtc
+ sys-apps/pciutils
+ sys-power/iasl
+ sys-power/pmtools
+"
+RDEPEND="${DEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-22.03.00-werror.patch"
+)
+
+src_prepare() {
+ default
+
+ sed -e 's:/usr/bin/lspci:'$(type -p lspci)':' \
+ -e 's:/usr/sbin/dmidecode:'$(type -p dmidecode)':' \
+ -e 's:/usr/bin/iasl:'$(type -p iasl)':' \
+ -i src/lib/include/fwts_binpaths.h || die
+
+ eautoreconf
+}
+
+src_compile() {
+ # https://github.com/fwts/fwts/issues/7
+ emake -j1 --shuffle=none
+}
+
+src_install() {
+ default
+
+ find "${ED}" -name '*.la' -delete || die
+}