summaryrefslogtreecommitdiff
path: root/sys-apps/findutils/findutils-4.8.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
committerV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
commit752d6256e5204b958b0ef7905675a940b5e9172f (patch)
tree330d16e6362a49cbed8875a777fe641a43376cd3 /sys-apps/findutils/findutils-4.8.0.ebuild
parent0c100b7dd2b30e75b799d806df4ef899fd98e1ea (diff)
gentoo resync : 12.05.2022
Diffstat (limited to 'sys-apps/findutils/findutils-4.8.0.ebuild')
-rw-r--r--sys-apps/findutils/findutils-4.8.0.ebuild71
1 files changed, 0 insertions, 71 deletions
diff --git a/sys-apps/findutils/findutils-4.8.0.ebuild b/sys-apps/findutils/findutils-4.8.0.ebuild
deleted file mode 100644
index b4570b8b0f65..000000000000
--- a/sys-apps/findutils/findutils-4.8.0.ebuild
+++ /dev/null
@@ -1,71 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7..9} )
-
-inherit flag-o-matic python-any-r1
-
-DESCRIPTION="GNU utilities for finding files"
-HOMEPAGE="https://www.gnu.org/software/findutils/"
-SRC_URI="mirror://gnu/${PN}/${P}.tar.xz"
-
-LICENSE="GPL-3+"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="nls selinux static test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="selinux? ( sys-libs/libselinux )
- nls? ( virtual/libintl )"
-DEPEND="${RDEPEND}
- test? ( ${PYTHON_DEPS} )
-"
-BDEPEND="
- nls? ( sys-devel/gettext )
-"
-
-pkg_setup() {
- use test && python-any-r1_pkg_setup
-}
-
-src_prepare() {
- # Don't build or install locate because it conflicts with mlocate,
- # which is a secure version of locate. See bug 18729
- sed \
- -e '/^SUBDIRS/s@locate@@' \
- -e '/^built_programs/s@ frcode locate updatedb@@' \
- -i Makefile.in || die
-
- default
-}
-
-src_configure() {
- if use static; then
- append-flags -pthread
- append-ldflags -static
- fi
-
- if [[ ${CHOST} == *-darwin* ]] ; then
- # https://lists.gnu.org/archive/html/bug-findutils/2021-01/msg00050.html
- # https://lists.gnu.org/archive/html/bug-findutils/2021-01/msg00051.html
- append-cppflags '-D__nonnull\(X\)='
- fi
-
- local myeconfargs=(
- --with-packager="Gentoo"
- --with-packager-version="${PVR}"
- --with-packager-bug-reports="https://bugs.gentoo.org/"
- $(use_enable nls)
- $(use_with selinux)
- --libexecdir='$(libdir)'/find
- )
- econf "${myeconfargs[@]}"
-}
-
-src_compile() {
- # We don't build locate, but the docs want a file in there.
- emake -C locate dblocation.texi
- default
-}