summaryrefslogtreecommitdiff
path: root/sys-apps/file
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-10-20 10:22:14 +0100
committerV3n3RiX <venerix@koprulu.sector>2021-10-20 10:22:14 +0100
commit46eedbedafdb0040c37884982d4c775ce277fb7b (patch)
treedb33a91259730be84999e13a8d8168c799f50ac0 /sys-apps/file
parente23a08d0c97a0cc415aaa165da840b056f93c997 (diff)
gentoo resync : 20.10.2021
Diffstat (limited to 'sys-apps/file')
-rw-r--r--sys-apps/file/Manifest2
-rw-r--r--sys-apps/file/file-5.41.ebuild144
2 files changed, 146 insertions, 0 deletions
diff --git a/sys-apps/file/Manifest b/sys-apps/file/Manifest
index 6e07f651f153..998681feb843 100644
--- a/sys-apps/file/Manifest
+++ b/sys-apps/file/Manifest
@@ -5,6 +5,8 @@ AUX file-5.40-seccomp-fstatat64-musl.patch 723 BLAKE2B cb6e5151b863328a4764f38f4
AUX file-5.40-seccomp-fstatat64.patch 727 BLAKE2B 164574b98126ad8804c7a3ef51c80567a83d89c609b731b84f2d5e0b8fe54d060f45b6db38258ece2e2af1e0d0674e4fdf5b62df6217695d06042bb86ad72f5b SHA512 5e5364659e2c96e438000e698f9099be1d2bee94890c51ed849f6e0d139ba637a8026d975200476636cd8282791b6c3e5b71326fb8519323d6c07604975b5b0c
AUX file-5.40-xz_magic.patch 1277 BLAKE2B 3af2322360ab9d7b3340dd34a2190e249dac5d0dc91843efd07e9fdd92f48ebab0a67decae23e68d9dc6a5fae38880d56977dfa4b3a72d74e362c8f3aab42fee SHA512 4e9e64c1ac0e7e95a113577a32be0fe2f2c2d9acbbe323622c2409d2e1b9f9a6cb3e8572569bbef156ca06c6470ee7db38d2579582622f224919eb37243319e5
DIST file-5.40.tar.gz 1004214 BLAKE2B 4e15a1ca62fe7c03c90b0e509dc899b87f4474f758ad3d08172b3d838dc3f7c2954ba1074eeeeb3da8c04b8df84eff2b8cdf3177da334a926914429df67f60bf SHA512 3b70df75fa4c9050d55b1ffdc28e5f3c8b8ef7d4efd1a06bf53f113b676d81114a85aae56e0897d32b53716662d64ad18ab251ca8c92c6405c69eb758bb99afb
+DIST file-5.41.tar.gz 1064097 BLAKE2B 56fe8a58d9497bb1bfe3ed6b3ce5df70dd27cc308eb0cfdac8e91ba81c733a96aa622c120ac59079986c6d84901c6f2d82fa24f698d481d7f77e6cfdd432d648 SHA512 bbf2d8e39450b31d0ba8d76d202790fea953775657f942f06e6dc9091798d4a395f7205e542388e4a25b6a4506d07f36c5c4da37cfce0734133e9203a3b00654
EBUILD file-5.40-r3.ebuild 3556 BLAKE2B 52835f37e7c4c78cc5239e86a2b096da50200e2cee7d07d904242f7c42eaa8369d1e4ed5b9239d53708e4bc7bfd54a55e7856c0850e8247a471bf68f529a8d71 SHA512 03fe26852e181ecd4ffd456482abb31717eaa3d3190a33a116cb9b3abac66532b7802d1dfe3bfaeac8a30c45d9a683ee0529e5d200a6e83c41ca7c3cfa16b14b
+EBUILD file-5.41.ebuild 3355 BLAKE2B 750df996eaf9a5384e80f6a188eca765945ddc22be2555fe7d5bfd4f9d5da845d24d7b7d263607f0fb169f197fc24d6953881bfa1e96d90c20c100542f167d14 SHA512 b818b49befa9dd286123cb462ee091edaaa7066b4ff14ce8fc373f2281fbd08e0f0c6407eafd1efbfdd4ee3a3476e3fa03171ac736e778393fbec3db2f25ba39
EBUILD file-9999.ebuild 3273 BLAKE2B 691dabede60ccb8f756ee3a03a5e2db17f58e556cc19f28493685996ac637e7343803a5667e591fc1b336611458b8550c222238983d797fa21e1fe66c60d1625 SHA512 20a7db1cd42cb5c47d5a0c7a607b3e547e1e76b6fe3effd8a456425929312981b47d940c4deee82f14b20e6be50416206aae4b32cbab80bbdf459cce76443347
MISC metadata.xml 382 BLAKE2B 204b7440b6a18907045d7eae05e8c99d017fa57b5178462125b998d8b3af3e2be656353f5c69823f3b5ea4d86e7e6c028229af27abaf2f7ace6f181f9ebf4153 SHA512 0e56117ac1957f2393ab47dc875e5f07851f3866014388418f84668f5f9767f6ca83963547442606e1c637ed3bcbb81b317cf994de4a04cd28725d8f6cb49b5e
diff --git a/sys-apps/file/file-5.41.ebuild b/sys-apps/file/file-5.41.ebuild
new file mode 100644
index 000000000000..cb9244c374de
--- /dev/null
+++ b/sys-apps/file/file-5.41.ebuild
@@ -0,0 +1,144 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..10} )
+DISTUTILS_OPTIONAL=1
+
+inherit distutils-r1 libtool toolchain-funcs multilib-minimal
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/glensc/file.git"
+ inherit autotools git-r3
+else
+ SRC_URI="ftp://ftp.astron.com/pub/file/${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+fi
+
+DESCRIPTION="identify a file's format by scanning binary data for patterns"
+HOMEPAGE="https://www.darwinsys.com/file/"
+
+LICENSE="BSD-2"
+SLOT="0"
+IUSE="bzip2 lzma python seccomp static-libs zlib"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+DEPEND="
+ bzip2? ( app-arch/bzip2[${MULTILIB_USEDEP}] )
+ lzma? ( app-arch/xz-utils[${MULTILIB_USEDEP}] )
+ python? (
+ ${PYTHON_DEPS}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ )
+ zlib? ( >=sys-libs/zlib-1.2.8-r1[${MULTILIB_USEDEP}] )"
+RDEPEND="${DEPEND}
+ python? ( !dev-python/python-magic )
+ seccomp? ( sys-libs/libseccomp[${MULTILIB_USEDEP}] )"
+
+PATCHES=(
+ "${FILESDIR}/file-5.39-portage-sandbox.patch" #713710 #728978
+ "${FILESDIR}/file-5.40-seccomp-fstatat64-musl.patch" #789336, not upstream yet
+)
+
+src_prepare() {
+ default
+
+ if [[ ${PV} == 9999 ]] ; then
+ eautoreconf
+ fi
+
+ elibtoolize
+
+ # don't let python README kill main README #60043
+ mv python/README.md python/README.python.md || die
+ sed 's@README.md@README.python.md@' -i python/setup.py || die #662090
+}
+
+multilib_src_configure() {
+ local myeconfargs=(
+ --enable-fsect-man5
+ $(use_enable bzip2 bzlib)
+ $(use_enable lzma xzlib)
+ $(use_enable seccomp libseccomp)
+ $(use_enable static-libs static)
+ $(use_enable zlib)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+build_src_configure() {
+ local myeconfargs=(
+ --disable-shared
+ --disable-libseccomp
+ --disable-bzlib
+ --disable-xzlib
+ --disable-zlib
+ )
+ tc-env_build econf "${myeconfargs[@]}"
+}
+
+need_build_file() {
+ # when cross-compiling, we need to build up our own file
+ # because people often don't keep matching host/target
+ # file versions #362941
+ tc-is-cross-compiler && ! has_version -b "~${CATEGORY}/${P}"
+}
+
+src_configure() {
+ local ECONF_SOURCE="${S}"
+
+ if need_build_file ; then
+ mkdir -p "${WORKDIR}"/build || die
+ cd "${WORKDIR}"/build || die
+ build_src_configure
+ fi
+
+ multilib-minimal_src_configure
+}
+
+multilib_src_compile() {
+ if multilib_is_native_abi ; then
+ emake
+ else
+ cd src || die
+ emake magic.h #586444
+ emake libmagic.la
+ fi
+}
+
+src_compile() {
+ if need_build_file ; then
+ emake -C "${WORKDIR}"/build/src magic.h #586444
+ emake -C "${WORKDIR}"/build/src file
+ local -x PATH="${WORKDIR}/build/src:${PATH}"
+ fi
+ multilib-minimal_src_compile
+
+ if use python ; then
+ cd python || die
+ distutils-r1_src_compile
+ fi
+}
+
+multilib_src_install() {
+ if multilib_is_native_abi ; then
+ default
+ else
+ emake -C src install-{nodist_includeHEADERS,libLTLIBRARIES} DESTDIR="${D}"
+ fi
+}
+
+multilib_src_install_all() {
+ dodoc ChangeLog MAINT # README
+
+ # Required for `file -C`
+ insinto /usr/share/misc/magic
+ doins -r magic/Magdir/*
+
+ if use python ; then
+ cd python || die
+ distutils-r1_src_install
+ fi
+ find "${ED}" -type f -name "*.la" -delete || die
+}