summaryrefslogtreecommitdiff
path: root/sys-apps/ethtool/ethtool-6.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-20 13:51:21 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-20 13:51:21 +0000
commit4161fa7d1be6dac96e36f8ed343f234a8ef3a74f (patch)
treeee6d7260a8c03fb6191fead616b7dd50f07a7aa4 /sys-apps/ethtool/ethtool-6.1.ebuild
parentef4d67f1907798e309efed58d673fd60594a14a8 (diff)
gentoo auto-resync : 20:12:2022 - 13:51:21
Diffstat (limited to 'sys-apps/ethtool/ethtool-6.1.ebuild')
-rw-r--r--sys-apps/ethtool/ethtool-6.1.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/sys-apps/ethtool/ethtool-6.1.ebuild b/sys-apps/ethtool/ethtool-6.1.ebuild
new file mode 100644
index 000000000000..8d122a733c09
--- /dev/null
+++ b/sys-apps/ethtool/ethtool-6.1.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Utility for examining and tuning ethernet-based network interfaces"
+HOMEPAGE="https://www.kernel.org/pub/software/network/ethtool/"
+SRC_URI="https://www.kernel.org/pub/software/network/ethtool/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="+netlink"
+
+RDEPEND="netlink? ( net-libs/libmnl )"
+DEPEND="${RDEPEND}"
+BDEPEND="app-arch/xz-utils"
+
+src_configure() {
+ econf $(use_enable netlink)
+}