summaryrefslogtreecommitdiff
path: root/sys-apps/elfix
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-04-28 20:02:04 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-04-28 20:02:04 +0100
commita4e2a46beb5e4858ef27bdedbb0ff6d2ced430ad (patch)
tree852c90a4bf354c30ea66504f70bfab5401fba18d /sys-apps/elfix
parent5e8702bcbbed438e6c6cce023e7ef0cc9baa3e02 (diff)
gentoo resync : 28.04.2018
Diffstat (limited to 'sys-apps/elfix')
-rw-r--r--sys-apps/elfix/Manifest4
-rw-r--r--sys-apps/elfix/elfix-0.9.2.ebuild25
-rw-r--r--sys-apps/elfix/elfix-9999.ebuild25
3 files changed, 26 insertions, 28 deletions
diff --git a/sys-apps/elfix/Manifest b/sys-apps/elfix/Manifest
index f63ebbf9ed57..e33c9d41d64f 100644
--- a/sys-apps/elfix/Manifest
+++ b/sys-apps/elfix/Manifest
@@ -1,4 +1,4 @@
DIST elfix-0.9.2.tar.gz 398758 BLAKE2B 22f8d9e85be2ae9bd906dfa6a1d8b7614f017686b4563ef7e97898a112a56cff59a8cb906ec957b7a111a5c9251a3de6b13dfb66ef9f732099ac610928d5321e SHA512 a7be30722abe7249ec42024d33b2bda00524cfb85da66b4511c5056efbdbfae1d3c2b42048bcf4d5cb7c0ae675f763b74a834d93a25b541ebac42fddcd2c6cf9
-EBUILD elfix-0.9.2.ebuild 1129 BLAKE2B f3626db1d33b9a16635879a5e03ab487f25cf9c14f21f2a5368a7de86fcd9f31fdbd8d6f696a1b974a7a3ef537284ba5867ca8047854878e68bfda94b98267f8 SHA512 ec804aad98f81c5354d5de715cdf1032d03a149bdbbe04288d1c2cf77c0bb2b99003d2d55e87a8d8de4d761e18af7a110b2925a8771062543939d8d0533c991c
-EBUILD elfix-9999.ebuild 1138 BLAKE2B 8ea9a153bb2f2fb696402f780943969b58616dda29fb7f04042de8a884df1a1c53da4f31759fa85df89756096cee26bcc879fa497f498fc9cc363ffcd9772710 SHA512 b80e67c75acd1110accd8d3808cf728fa96e997a570878b08b128f8e6364c0936ed39f00f66b6486b7520ba44aebd3b5ea9c05895ec1d470d8c7673f291c51a1
+EBUILD elfix-0.9.2.ebuild 1131 BLAKE2B 6b23b4204cee8654d34140967e95d0f6e8d5340ebf12948a168c260fefc0dc8f5f8891564579c52d27b3a7b79cb260ae7bd2f008489e4d83d809874fa49c593b SHA512 0b2eeed50d4478894cf3e3d576fef84d725caca54da95e41e98698c4a1fa226172d9ae8fa2b343f59db2229aa5596a7fdb8266868a63667f548567d262a4d451
+EBUILD elfix-9999.ebuild 1143 BLAKE2B 1e55957bc737f3704ce1568008920e68d86dbd3f7696b0d24c0cd86b83153ed1ba6c7fb401c910a3b2aeffe0535bb2c5ca942f7b82fcf2734ac61f6f0c28c24f SHA512 24f765049459a7014547b391a658f1a549b7f4a64169b1d844395acd6a75126eb1d89d827ed438871b840ba592c501718a8ff4d1dcb39ed4014fe831fe4ad606
MISC metadata.xml 496 BLAKE2B a26ee20b4388a77bf12e032c2091b534653874b6f0880775298da89286487d07709511d64e52b0240206d661f8874c55d4d87ce3bdc73e60e9a1432a232cf219 SHA512 b934fa247d4d5bb1d188de8bead5980aba83abe50423dd1e56c534b762b535faa242dbab58021e91bea43951542dc4f5885aff3754cc0957f01e86832bdd2c5e
diff --git a/sys-apps/elfix/elfix-0.9.2.ebuild b/sys-apps/elfix/elfix-0.9.2.ebuild
index 11349cf6d6f6..2bc81bd6ca54 100644
--- a/sys-apps/elfix/elfix-0.9.2.ebuild
+++ b/sys-apps/elfix/elfix-0.9.2.ebuild
@@ -1,13 +1,11 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI="5"
+EAPI=6
-inherit eutils
-
-if [[ ${PV} == "9999" ]] ; then
- EGIT_REPO_URI="git://anongit.gentoo.org/proj/elfix.git"
- inherit git-2
+if [[ ${PV} == *9999* ]] ; then
+ EGIT_REPO_URI="https://anongit.gentoo.org/git/proj/elfix.git"
+ inherit autotools git-r3
else
SRC_URI="https://dev.gentoo.org/~blueness/elfix/${P}.tar.gz"
KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 sparc x86"
@@ -21,6 +19,8 @@ LICENSE="GPL-3"
SLOT="0"
IUSE="+ptpax +xtpax"
+DOCS=( AUTHORS ChangeLog INSTALL README THANKS TODO )
+
REQUIRED_USE="|| ( ptpax xtpax )"
# These only work with a properly configured PaX kernel
@@ -33,7 +33,11 @@ DEPEND="~dev-python/pypax-${PV}[ptpax=,xtpax=]
RDEPEND="${DEPEND}"
src_prepare() {
- [[ ${PV} == "9999" ]] && ./autogen.sh
+ default
+ if [[ ${PV} == *9999* ]]; then
+ eautoreconf
+ cd doc && ./make.sh || die
+ fi
}
src_configure() {
@@ -42,8 +46,3 @@ src_configure() {
$(use_enable ptpax) \
$(use_enable xtpax)
}
-
-src_install() {
- emake DESTDIR="${D}" install
- dodoc AUTHORS ChangeLog INSTALL README THANKS TODO
-}
diff --git a/sys-apps/elfix/elfix-9999.ebuild b/sys-apps/elfix/elfix-9999.ebuild
index 9e35e46644dc..0eaa5ebdfecf 100644
--- a/sys-apps/elfix/elfix-9999.ebuild
+++ b/sys-apps/elfix/elfix-9999.ebuild
@@ -1,13 +1,11 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI="5"
+EAPI=6
-inherit eutils
-
-if [[ ${PV} == "9999" ]] ; then
- EGIT_REPO_URI="git://anongit.gentoo.org/proj/elfix.git"
- inherit git-2
+if [[ ${PV} == *9999* ]] ; then
+ EGIT_REPO_URI="https://anongit.gentoo.org/git/proj/elfix.git"
+ inherit autotools git-r3
else
SRC_URI="https://dev.gentoo.org/~blueness/elfix/${P}.tar.gz"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
@@ -21,6 +19,8 @@ LICENSE="GPL-3"
SLOT="0"
IUSE="+ptpax +xtpax"
+DOCS=( AUTHORS ChangeLog INSTALL README.md THANKS TODO )
+
REQUIRED_USE="|| ( ptpax xtpax )"
# These only work with a properly configured PaX kernel
@@ -33,7 +33,11 @@ DEPEND="~dev-python/pypax-${PV}[ptpax=,xtpax=]
RDEPEND="${DEPEND}"
src_prepare() {
- [[ ${PV} == "9999" ]] && ./autogen.sh
+ default
+ if [[ ${PV} == *9999* ]]; then
+ eautoreconf
+ cd doc && ./make.sh || die
+ fi
}
src_configure() {
@@ -42,8 +46,3 @@ src_configure() {
$(use_enable ptpax) \
$(use_enable xtpax)
}
-
-src_install() {
- emake DESTDIR="${D}" install
- dodoc AUTHORS ChangeLog INSTALL README THANKS TODO
-}