summaryrefslogtreecommitdiff
path: root/sys-apps/elfix/elfix-0.9.5.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-27 09:11:36 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-27 09:11:36 +0100
commite67c9b35124c5b3338943cf7793fe4402f03ad0f (patch)
treeae666570705e3bb470ce37171e065978b46063f5 /sys-apps/elfix/elfix-0.9.5.ebuild
parent9e68aee0e16e4b361fe06f9566c74b4bb2a22a27 (diff)
gentoo auto-resync : 27:05:2023 - 09:11:36
Diffstat (limited to 'sys-apps/elfix/elfix-0.9.5.ebuild')
-rw-r--r--sys-apps/elfix/elfix-0.9.5.ebuild15
1 files changed, 7 insertions, 8 deletions
diff --git a/sys-apps/elfix/elfix-0.9.5.ebuild b/sys-apps/elfix/elfix-0.9.5.ebuild
index d3dc77ed17fb..0f1ed96f6f05 100644
--- a/sys-apps/elfix/elfix-0.9.5.ebuild
+++ b/sys-apps/elfix/elfix-0.9.5.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -17,14 +17,12 @@ HOMEPAGE="https://www.gentoo.org/proj/en/hardened/pax-quickstart.xml
LICENSE="GPL-3"
SLOT="0"
-IUSE="+ptpax +xtpax"
-
-DOCS=( AUTHORS ChangeLog INSTALL README THANKS TODO )
-
+IUSE="+ptpax test +xtpax"
REQUIRED_USE="|| ( ptpax xtpax )"
-
# These only work with a properly configured PaX kernel
-RESTRICT="test"
+RESTRICT="!test? ( test ) test"
+
+DOCS=( AUTHORS ChangeLog INSTALL README THANKS TODO )
DEPEND="~dev-python/pypax-${PV}[ptpax=,xtpax=]
ptpax? ( dev-libs/elfutils )
@@ -42,7 +40,8 @@ src_prepare() {
src_configure() {
rm -f "${S}/scripts/setup.py"
- econf --disable-tests \
+ econf \
+ $(use_enable test tests) \
$(use_enable ptpax) \
$(use_enable xtpax)
}