summaryrefslogtreecommitdiff
path: root/sys-apps/edid-decode
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
commit7bc9c63c9da678a7e6fceb095d56c634afd22c56 (patch)
tree4a67d50a439e9af63947e5f8b6ba3719af98b6c9 /sys-apps/edid-decode
parentb284a3168fa91a038925d2ecf5e4791011ea5e7d (diff)
gentoo resync : 15.12.2019
Diffstat (limited to 'sys-apps/edid-decode')
-rw-r--r--sys-apps/edid-decode/Manifest4
-rw-r--r--sys-apps/edid-decode/edid-decode-0_pre20191207.ebuild35
-rw-r--r--sys-apps/edid-decode/edid-decode-9999.ebuild31
-rw-r--r--sys-apps/edid-decode/metadata.xml15
4 files changed, 85 insertions, 0 deletions
diff --git a/sys-apps/edid-decode/Manifest b/sys-apps/edid-decode/Manifest
new file mode 100644
index 000000000000..c640517af892
--- /dev/null
+++ b/sys-apps/edid-decode/Manifest
@@ -0,0 +1,4 @@
+DIST edid-decode-0_pre20191207.tar.gz 56644 BLAKE2B 85869293a3f47558f0e1c7dc22e482299cfa19ad62bb4801aa03f303a7f4e63f4a8424fdd177fbc9aa510183283322d68b519e8436648d763e7b983e490a39e4 SHA512 bbbf98394409f6bb043e67be0a91b4aa0a596b3f10d5e8b033597fac723b98df3b57e5ecc591a5dcb768eb98cae8390474000fb67ca82cf25d617652bd835ba1
+EBUILD edid-decode-0_pre20191207.ebuild 690 BLAKE2B ff56c136cd30ee131d5e8a91886054ff6b497955ee6af9b1ef319e93ac19a8ce1ee96f5b181d29c8ec42416f5376fd4a8e485c0a56914ac8cdd174fa5d496c7f SHA512 a747f1bb0ca00d23c28c54aa57d48a2be1ef93199cf47ed146270ac6d196a2ff0a4fe86138d8f8adcb21d679eb7b169030f637e39a68a9b8f3e13edc8060903f
+EBUILD edid-decode-9999.ebuild 550 BLAKE2B 6e79eb700ebfe891bcd2f5451ecb80a27bcbb29af23d0126f5105f984372986c23527e7781b5f5db1737fd1c6c3efe8688e2de6c84e1515f7ad6cbaf7b783739 SHA512 c913ea25760f4ef10d56c1467f3de2a9c79bac6f0f25768989207aab8354dc0fa8903d100773fb81cfdc0118d8ae6762ab9436db11c0cfba7e270fbd17bc3d76
+MISC metadata.xml 646 BLAKE2B 37a3db350195905c7a4b420d0d2d2d4741cca1b3954d42620a9a411696a734702e145bde400c4d68997aedd0de45d418faacb1d132ab385f8454f7f5c0039260 SHA512 95293d61feeeca16b0341a5c5fad464db4fca0d2dcfc9b7f51cb3d2984f3ff4530d2938d80ecdf658fc2c784368166bc5fbd220787de6564938ee2171f1816e2
diff --git a/sys-apps/edid-decode/edid-decode-0_pre20191207.ebuild b/sys-apps/edid-decode/edid-decode-0_pre20191207.ebuild
new file mode 100644
index 000000000000..782193f55c43
--- /dev/null
+++ b/sys-apps/edid-decode/edid-decode-0_pre20191207.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+EGIT_COMMIT="46a0691551e44d49a2c3951a7d944786131c97c3"
+MY_P="${PN}-${EGIT_COMMIT}"
+
+DESCRIPTION="Decode EDID data in a human-readable format"
+HOMEPAGE="https://git.linuxtv.org/edid-decode.git/"
+SRC_URI="https://dev.gentoo.org/~conikost/files/${MY_P}.tar.gz -> ${P}.tar.gz"
+
+KEYWORDS="~amd64 ~x86"
+LICENSE="MIT"
+SLOT="0"
+IUSE="examples"
+
+S="${WORKDIR}/${MY_P}"
+
+src_compile() {
+ tc-export CXX
+ default
+}
+
+src_install() {
+ emake DESTDIR="${ED}" install
+ einstalldocs
+
+ if use examples; then
+ insinto /usr/share/edid-decode/examples
+ doins data/*
+ fi
+}
diff --git a/sys-apps/edid-decode/edid-decode-9999.ebuild b/sys-apps/edid-decode/edid-decode-9999.ebuild
new file mode 100644
index 000000000000..8e35fcbc1324
--- /dev/null
+++ b/sys-apps/edid-decode/edid-decode-9999.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit git-r3 toolchain-funcs
+
+EGIT_REPO_URI="https://git.linuxtv.org/${PN}.git"
+
+DESCRIPTION="Decode EDID data in a human-readable format"
+HOMEPAGE="https://git.linuxtv.org/edid-decode.git/"
+
+KEYWORDS=""
+LICENSE="MIT"
+SLOT="0"
+IUSE="examples"
+
+src_compile() {
+ tc-export CXX
+ default
+}
+
+src_install() {
+ emake DESTDIR="${ED}" install
+ einstalldocs
+
+ if use examples; then
+ insinto /usr/share/edid-decode/examples
+ doins data/*
+ fi
+}
diff --git a/sys-apps/edid-decode/metadata.xml b/sys-apps/edid-decode/metadata.xml
new file mode 100644
index 000000000000..207a2c8a4f1d
--- /dev/null
+++ b/sys-apps/edid-decode/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>conikost@gentoo.org</email>
+ <name>Conrad Kostecki</name>
+ </maintainer>
+ <longdescription>
+ Decodes EDID monitor description data in human-readable format.
+ If invoked with no arguments it reads from standard input and writes to standard output.
+ With one argument, the file named by the argument is read instead.
+ With two arguments, normal output is suppressed, and the binary EDID blob is
+ written to the file named by the second argument.
+ </longdescription>
+</pkgmetadata>