summaryrefslogtreecommitdiff
path: root/sys-apps/edac-utils
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-30 02:16:21 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-30 02:16:21 +0000
commitb7cf34e541f10778605d8740e2690d8459908ac5 (patch)
tree98d91f7ea7de88f6f7d667af0deb3ffaff5b4d5e /sys-apps/edac-utils
parent8467a7e8af97ab17f54668fd7d348e68754dd0cc (diff)
gentoo auto-resync : 30:12:2022 - 02:16:21
Diffstat (limited to 'sys-apps/edac-utils')
-rw-r--r--sys-apps/edac-utils/Manifest1
-rw-r--r--sys-apps/edac-utils/edac-utils-0.18-r2.ebuild64
2 files changed, 65 insertions, 0 deletions
diff --git a/sys-apps/edac-utils/Manifest b/sys-apps/edac-utils/Manifest
index 31c7c22a744d..0a44823fd5ba 100644
--- a/sys-apps/edac-utils/Manifest
+++ b/sys-apps/edac-utils/Manifest
@@ -3,4 +3,5 @@ AUX edac.init 336 BLAKE2B 7ebffaf4d4431977d607448f43beb5f17903e28a1aef3a8445e0c8
AUX edac.service 230 BLAKE2B a38c84a994bcaf884ed1a23c406971c57c4353a226029d5c08cd71481ca888dae91c5a6c6422a20181319c3199d2e97fb1985a05415ffc9f1cdad318281f50d6 SHA512 de8838c5f2227e4c81c8b571dd117ac90aeabeb082b767e84bd208a80c24496f3bd5105fb15fab890ea3224616646a882d12dc7c37af6d0e554f95cd8d081b7d
DIST edac-utils-0.18.tar.gz 285909 BLAKE2B 7d2662daf94c4ff796760b4863837861015397016bb79202baaa194608b61450d6749981cec621571267ac818a09af758167d2d768513e7d5bf7e763aed7ee51 SHA512 5c81b11c28e8fb3198f2d656171493877393024d9e31233c252d358d8029aa83065e7b66ea87d742518f710466c9ba7dfcf57a1641374ce169cf95fd379101fa
EBUILD edac-utils-0.18-r1.ebuild 1248 BLAKE2B 783ef2c3610b4ba9c90cb02e78a041310646f95bb43bef911b05f0cc5799156bf871e191f2a70a5a0552bbca9d648112b1e7ff8ca6f91bd26f0b09760954a2db SHA512 eb431b56f4bb70f9ee1265d45350f07791f4adda0554e3f33a3d6ba91328e86e9a77fd7cf6e0ad48a55d3a462883a915496a070ea8c5d756d2248ee9fe52d928
+EBUILD edac-utils-0.18-r2.ebuild 1532 BLAKE2B 7811eda58f60a2df5126805959a0ab806c543b6cb0c2e01c22b0b0115b5ada1aaa2910d656d6d1946fb434943aba833838d36b622a90dd874f4672c1b2d74e3a SHA512 f3b10fcfce727d10edc7248ccc5d27c0294eaecf7e4f0aff0579e9138a87c6df8ad9c26a3bea302639b859cf56c2a93bf85d4030a34bcbfc86c453dddafcb4cf
MISC metadata.xml 322 BLAKE2B c1061e042359164cc6c5b8e415531fd42abda781fa2590cb3efe97e72e3d38c11af9bb5eb2594a2c4f8ef5f72115e3036caa188f6231211b5bebc401bb7baf1c SHA512 83d32053df33f00dee91b75e4e7a626871cb8e96ed002623f9df67cb2065a8f8a4c8264598d3e9e908b477d9c7878231661904f2c822a22c109aaaccc285f04d
diff --git a/sys-apps/edac-utils/edac-utils-0.18-r2.ebuild b/sys-apps/edac-utils/edac-utils-0.18-r2.ebuild
new file mode 100644
index 000000000000..0562dd9fe509
--- /dev/null
+++ b/sys-apps/edac-utils/edac-utils-0.18-r2.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools systemd
+
+DESCRIPTION="Userspace helper for Linux kernel EDAC drivers"
+HOMEPAGE="https://github.com/grondo/edac-utils"
+SRC_URI="https://github.com/grondo/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+IUSE="debug"
+
+DEPEND="sys-fs/sysfsutils"
+RDEPEND="${DEPEND}
+ sys-apps/dmidecode"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-mitac-hawk.patch
+)
+
+pkg_pretend() {
+ ewarn "edac-utils can't handle the interface newer kernels use to report"
+ ewarn "EDAC events, so it may miss some (or all) events which occur."
+ ewarn "See app-admin/rasdaemon's README for technical details."
+ ewarn "Consider using app-admin/rasdaemon instead."
+}
+
+src_prepare() {
+ default
+
+ # Needed to refresh libtool and friends to not call CC directly
+ # bug #725540
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --disable-static \
+ $(use_enable debug)
+}
+
+src_install() {
+ default
+
+ # Dump the inappropriate-for-us bundled init script
+ rm -rf "${ED}/etc/init.d" || die
+
+ # Install our own
+ newinitd "${FILESDIR}"/edac.init edac
+ systemd_dounit "${FILESDIR}"/edac.service
+
+ find "${ED}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ elog "There must be an entry for your mainboard in ${EROOT}/etc/edac/labels.db"
+ elog "in case you want nice labels in /sys/module/*_edac/"
+ elog "Run the following command to check whether such an entry is already available:"
+ elog " edac-ctl --print-labels"
+}