summaryrefslogtreecommitdiff
path: root/sys-apps/earlyoom/earlyoom-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
commit21435953e16cda318a82334ddbadb3b5c36d9ea7 (patch)
treee1810a4b135afce04b34862ef0fab2bfaeb8aeca /sys-apps/earlyoom/earlyoom-9999.ebuild
parent7bc9c63c9da678a7e6fceb095d56c634afd22c56 (diff)
gentoo resync : 15.01.2020
Diffstat (limited to 'sys-apps/earlyoom/earlyoom-9999.ebuild')
-rw-r--r--sys-apps/earlyoom/earlyoom-9999.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/sys-apps/earlyoom/earlyoom-9999.ebuild b/sys-apps/earlyoom/earlyoom-9999.ebuild
new file mode 100644
index 000000000000..a54b0d570f73
--- /dev/null
+++ b/sys-apps/earlyoom/earlyoom-9999.ebuild
@@ -0,0 +1,40 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit systemd
+
+DESCRIPTION="Early OOM Daemon for Linux"
+HOMEPAGE="https://github.com/rfjakob/earlyoom"
+
+LICENSE="MIT-with-advertising"
+SLOT="0"
+if [ "${PV}" = "9999" ]; then
+ EGIT_REPO_URI="https://github.com/rfjakob/earlyoom.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/rfjakob/earlyoom/archive/v$PV.tar.gz -> $P.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+IUSE="systemd docs"
+
+DEPEND="docs? ( app-text/pandoc )"
+RDEPEND=""
+
+src_compile() {
+ VERSION="v${PV}" emake earlyoom
+ use docs && VERSION="v${PV}" emake earlyoom.1
+ use systemd && emake PREFIX=/usr earlyoom.service
+}
+
+src_install() {
+ dobin earlyoom
+ use docs && doman earlyoom.1
+
+ insinto /etc/default
+ newins earlyoom.default earlyoom
+
+ doinitd "${FILESDIR}/${PN}"
+ use systemd && systemd_dounit earlyoom.service
+}