summaryrefslogtreecommitdiff
path: root/sys-apps/earlyoom/earlyoom-1.6.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-02-27 23:40:34 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-02-27 23:40:34 +0000
commitfdd31f37b982d2c1b6d73b85f99718b13031be36 (patch)
treeb53698971171aec857ab0822be99fc89cac616c6 /sys-apps/earlyoom/earlyoom-1.6.2.ebuild
parent5cf235d5f7f308ba0183f7fa588514966b692114 (diff)
gentoo auto-resync : 27:02:2024 - 23:40:33
Diffstat (limited to 'sys-apps/earlyoom/earlyoom-1.6.2.ebuild')
-rw-r--r--sys-apps/earlyoom/earlyoom-1.6.2.ebuild49
1 files changed, 0 insertions, 49 deletions
diff --git a/sys-apps/earlyoom/earlyoom-1.6.2.ebuild b/sys-apps/earlyoom/earlyoom-1.6.2.ebuild
deleted file mode 100644
index dd56e9eba184..000000000000
--- a/sys-apps/earlyoom/earlyoom-1.6.2.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 2020-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit systemd
-
-DESCRIPTION="Early OOM Daemon for Linux"
-HOMEPAGE="https://github.com/rfjakob/earlyoom"
-
-LICENSE="MIT"
-SLOT="0"
-if [ "${PV}" = "9999" ]; then
- EGIT_REPO_URI="https://github.com/rfjakob/earlyoom.git"
- inherit git-r3
-else
- SRC_URI="https://github.com/rfjakob/earlyoom/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="amd64 x86"
-fi
-IUSE="docs systemd test"
-
-RDEPEND=""
-DEPEND=""
-BDEPEND="
- docs? ( virtual/pandoc )
- test? ( dev-lang/go )
-"
-
-#tests don't work
-RESTRICT=test
-
-src_compile() {
- VERSION="v${PV}" emake earlyoom
- use docs && VERSION="v${PV}" emake earlyoom.1
- use systemd && emake PREFIX=/usr earlyoom.service
-}
-
-src_install() {
- dobin earlyoom
- use docs && doman earlyoom.1
-
- insinto /etc/default
- newins earlyoom.default earlyoom
- dodir /etc/conf.d
- ln -s ../default/earlyoom "${ED}/etc/conf.d/earlyoom"
-
- newinitd "${FILESDIR}/${PN}-r1" "${PN}"
- use systemd && systemd_dounit earlyoom.service
-}