summaryrefslogtreecommitdiff
path: root/sys-apps/dtc/dtc-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /sys-apps/dtc/dtc-9999.ebuild
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'sys-apps/dtc/dtc-9999.ebuild')
-rw-r--r--sys-apps/dtc/dtc-9999.ebuild49
1 files changed, 37 insertions, 12 deletions
diff --git a/sys-apps/dtc/dtc-9999.ebuild b/sys-apps/dtc/dtc-9999.ebuild
index d60b43b0b331..5d8cb20a5b37 100644
--- a/sys-apps/dtc/dtc-9999.ebuild
+++ b/sys-apps/dtc/dtc-9999.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
inherit multilib toolchain-funcs eutils
if [[ ${PV} == "9999" ]] ; then
@@ -9,7 +9,7 @@ if [[ ${PV} == "9999" ]] ; then
inherit git-r3
else
SRC_URI="https://www.kernel.org/pub/software/utils/${PN}/${P}.tar.xz"
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
fi
DESCRIPTION="Open Firmware device tree compiler"
@@ -17,21 +17,41 @@ HOMEPAGE="https://devicetree.org/ https://git.kernel.org/cgit/utils/dtc/dtc.git/
LICENSE="GPL-2"
SLOT="0"
-IUSE="static-libs"
+IUSE="static-libs yaml"
-DEPEND="
+BDEPEND="
sys-devel/bison
sys-devel/flex
+ virtual/pkgconfig
"
+RDEPEND="yaml? ( dev-libs/libyaml )"
+DEPEND="${RDEPEND}"
+
DOCS="
Documentation/dt-object-internal.txt
Documentation/dts-format.txt
Documentation/manual.txt
"
-PATCHES=(
- "${FILESDIR}"/${PN}-1.4.4-posix-shell.patch
-)
+_emake() {
+ # valgrind is used only in 'make checkm'
+ emake \
+ NO_PYTHON=1 \
+ NO_VALGRIND=1 \
+ NO_YAML=$(usex !yaml 1 0) \
+ \
+ AR="$(tc-getAR)" \
+ CC="$(tc-getCC)" \
+ PKG_CONFIG="$(tc-getPKG_CONFIG)" \
+ \
+ V=1 \
+ \
+ PREFIX="${EPREFIX}/usr" \
+ \
+ LIBDIR="\$(PREFIX)/$(get_libdir)" \
+ \
+ "$@"
+}
src_prepare() {
default
@@ -41,16 +61,21 @@ src_prepare() {
-e '/^CPPFLAGS =/s:=:+=:' \
-e 's:-Werror::' \
-e 's:-g -Os::' \
- -e "/^PREFIX =/s:=.*:= ${EPREFIX}/usr:" \
- -e "/^LIBDIR =/s:=.*:= \$(PREFIX)/$(get_libdir):" \
Makefile || die
- tc-export AR CC
- export V=1
+ tc-export AR CC PKG_CONFIG
+}
+
+src_compile() {
+ _emake
+}
+
+src_test() {
+ _emake check
}
src_install() {
- default
+ _emake DESTDIR="${D}" install
use static-libs || find "${ED}" -name '*.a' -delete
}