summaryrefslogtreecommitdiff
path: root/sys-apps/dstat
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-04-12 03:41:30 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-04-12 03:41:30 +0100
commit623ee73d661e5ed8475cb264511f683407d87365 (patch)
tree993eb27c93ec7a2d2d19550300d888fc1fed9e69 /sys-apps/dstat
parentceeeb463cc1eef97fd62eaee8bf2196ba04bc384 (diff)
gentoo Easter resync : 12.04.2020
Diffstat (limited to 'sys-apps/dstat')
-rw-r--r--sys-apps/dstat/Manifest1
-rw-r--r--sys-apps/dstat/dstat-0.7.4-r1.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/sys-apps/dstat/Manifest b/sys-apps/dstat/Manifest
index dce7c5f47aba..23d89dc2fc36 100644
--- a/sys-apps/dstat/Manifest
+++ b/sys-apps/dstat/Manifest
@@ -4,5 +4,6 @@ AUX fix-collections-deprecation-warning.patch 899 BLAKE2B ec02bf38b8c40f8f018ba6
DIST dstat-0.7.3.tar.gz 135583 BLAKE2B c846a06b6039e49944d43cc36178fed74fd4e0e3a1a4418dbe0e5987763995eb36dff0245cfa7107d446b8ac2ea500e13980f87e97aa8e5b8d566ee188be1639 SHA512 db37cc8bb7afd235ae9088e76c4defaa4d76651b111fbfdcd0980bc96376de20d57964912799a413397a79651730503bdeb8fea5cb97ab4d6d81632f528aefd2
DIST dstat-0.7.4.tar.gz 139992 BLAKE2B c8226358956687a4f64e248ef539b431b9e394e87986366f9941df2e86f0dac3032261ec2ca9c816d3bc89afabc352bc8bc80f9ad3eaa6118fd16bd7b0f1e68e SHA512 d100223887ebd83d0fd1259436f39419a85df9002556abcfc8e4195aa63be73d85707dcd5c4fb56a979b29131485dce6e97c177fbfca08dc50bd0f92b15cc6f5
EBUILD dstat-0.7.3.ebuild 865 BLAKE2B 60f79ac34d777a864ad9aaa154346323b7818e219833ff152597cf1f148f60439e19430e303b0ca3fc66c69538fde1d3744d91246fe5779644a73c77558fe52a SHA512 b4462000fcd9ff5554f6e3c5571997e0db595613efb13eaf7fe2a722a79e5115046039fd09ecac7578b661c6aec15a4180ff53f87dee51e17b3b9e11f95cfbe0
+EBUILD dstat-0.7.4-r1.ebuild 1275 BLAKE2B 51870a9cc5553793b931271e93fd3abe9cb46f61d02fe416b2a6edbf62b6b84fb991009311127082fc429c888ff4d3b34d123633528026a8bc2144dcf3628b79 SHA512 00dcb52acf1cab2a0c2550e8b6b713c85cef0283dcfb77f975101928eaf02a6ae438d4a0bea6c279e42f2a7e06724e9087c90085567135591fdd3ebf595a9b01
EBUILD dstat-0.7.4.ebuild 1166 BLAKE2B b5978c06f2ca4e89f6966fb4454c221519b15c8f35630b4e456e8696d4c2d50e4a1f58da7760d78cf03890c548c9367193e78eaf44681ccd5725121aed61afd3 SHA512 af9c40ee325c6907eecc4dc3b46071fe21f3e142addd05920ed9c8d4d9c1772228a190319f6414b6b209a395e9d972d3df2c7a1459cb3845de050178e1a4dfcb
MISC metadata.xml 867 BLAKE2B 11beeb2f2c4f397a0be3f5c97351be3d0ad6a3d54132c8a354ee405ca429d99b0d8983ca844e4d07d4d25d3be2642f6b1c4cd47068d91bebf89b5637ea86a7ef SHA512 751ac86ff9b2aa7435743d9fff4d44a1c34a9e6bbd568c3637f2f32564723c45d8de84840b90372cd809a6d9edf7ddd706927e24d6611583ea33d7be17eef1f9
diff --git a/sys-apps/dstat/dstat-0.7.4-r1.ebuild b/sys-apps/dstat/dstat-0.7.4-r1.ebuild
new file mode 100644
index 000000000000..b2f209299e75
--- /dev/null
+++ b/sys-apps/dstat/dstat-0.7.4-r1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_{6,7}} )
+
+inherit python-r1
+
+DESCRIPTION="Versatile replacement for vmstat, iostat and ifstat"
+HOMEPAGE="http://dag.wieers.com/home-made/dstat/"
+SRC_URI="https://github.com/dagwieers/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha amd64 ~arm64 hppa ~ia64 ~mips ppc ppc64 sparc x86 ~amd64-linux ~x86-linux"
+IUSE="doc examples wifi"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ dev-python/six[${PYTHON_USEDEP}]
+ wifi? (
+ net-wireless/python-wifi
+ )"
+DEPEND="${RDEPEND}"
+
+PATCHES=( \
+ "${FILESDIR}/dstat-${PV}-skip-non-sandbox-tests.patch" \
+ "${FILESDIR}/fix-collections-deprecation-warning.patch" \
+)
+
+src_prepare() {
+
+ # bug fix: allow delay to be specified
+ # backport from: https://github.com/dagwieers/dstat/pull/167/files
+ sed -i -e 's; / op\.delay; // op.delay;' "dstat" || die
+
+ default
+}
+
+src_install() {
+ python_foreach_impl python_doscript dstat
+
+ insinto /usr/share/dstat
+ newins dstat dstat.py
+ doins plugins/dstat_*.py
+
+ doman docs/dstat.1
+
+ einstalldocs
+
+ if use examples; then
+ dodoc examples/{mstat,read}.py
+ fi
+ if use doc; then
+ dodoc docs/*.html
+ fi
+}