summaryrefslogtreecommitdiff
path: root/sys-apps/dstat/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-11-03 16:06:58 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-11-03 16:06:58 +0000
commitbd4aeefe33e63f613512604e47bfca7b2187697d (patch)
treeadb35b5a9a00ee7ea591ab0c987f70167c23b597 /sys-apps/dstat/files
parent48ece6662cbd443015f5a57ae6d8cbdbd69ef37c (diff)
gentoo resync : 03.11.2019
Diffstat (limited to 'sys-apps/dstat/files')
-rw-r--r--sys-apps/dstat/files/dstat-0.7.4-skip-non-sandbox-tests.patch18
-rw-r--r--sys-apps/dstat/files/fix-collections-deprecation-warning.patch25
2 files changed, 43 insertions, 0 deletions
diff --git a/sys-apps/dstat/files/dstat-0.7.4-skip-non-sandbox-tests.patch b/sys-apps/dstat/files/dstat-0.7.4-skip-non-sandbox-tests.patch
new file mode 100644
index 000000000000..38457cdc95dc
--- /dev/null
+++ b/sys-apps/dstat/files/dstat-0.7.4-skip-non-sandbox-tests.patch
@@ -0,0 +1,18 @@
+diff --git a/Makefile b/Makefile
+index c371f62..42ef84d 100644
+--- a/Makefile
++++ b/Makefile
+@@ -32,10 +32,12 @@ clean:
+ rm -f examples/*.pyc plugins/*.pyc
+ $(MAKE) -C docs clean
+
++TEST_PLUGINS=--cpufreq --disk-tps --dstat-cpu --dstat-ctxt --dstat-mem --dstat --helloworld --md-status --net-packets --proc-count --snooze --test --top-bio-adv --top-bio --top-childwait --top-cpu-adv --top-cpu --top-cputime-avg --top-cputime --top-int --top-io-adv --top-io --top-latency-avg --top-latency --top-mem --top-oom
++
+ test:
+ ./dstat --version
+ ./dstat -taf 1 5
+- ./dstat -t --all-plugins 1 5
++ ./dstat -t $(TEST_PLUGINS) 1 5
+
+ dist: clean
+ $(MAKE) -C docs dist
diff --git a/sys-apps/dstat/files/fix-collections-deprecation-warning.patch b/sys-apps/dstat/files/fix-collections-deprecation-warning.patch
new file mode 100644
index 000000000000..e505c98d89fa
--- /dev/null
+++ b/sys-apps/dstat/files/fix-collections-deprecation-warning.patch
@@ -0,0 +1,25 @@
+diff --git a/dstat b/dstat
+index 9359965..777242f 100755
+--- a/dstat
++++ b/dstat
+@@ -19,6 +19,11 @@
+ from __future__ import absolute_import, division, generators, print_function
+ __metaclass__ = type
+
++try:
++ from collections.abc import Sequence
++except ImportError:
++ from collections import Sequence
++
+ import collections
+ import fnmatch
+ import getopt
+@@ -512,7 +517,7 @@ class dstat:
+ scale = self.scales[i]
+ else:
+ scale = self.scale
+- if isinstance(self.val[name], collections.Sequence) and not isinstance(self.val[name], six.string_types):
++ if isinstance(self.val[name], Sequence) and not isinstance(self.val[name], six.string_types):
+ line = line + cprintlist(self.val[name], ctype, self.width, scale)
+ sep = theme['frame'] + char['colon']
+ if i + 1 != len(self.vars):