summaryrefslogtreecommitdiff
path: root/sys-apps/diffutils
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-08-07 00:16:33 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-08-07 00:16:33 +0100
commitd162ba1860a88062f4cd61f8b52fc303ba0b2991 (patch)
tree24cd2cf57f3932a24b96e4a0f6666489447e43ba /sys-apps/diffutils
parent590b9b7b03bf4651e099949e318755af7cfa81b8 (diff)
gentoo resync : 07.08.2021
Diffstat (limited to 'sys-apps/diffutils')
-rw-r--r--sys-apps/diffutils/Manifest2
-rw-r--r--sys-apps/diffutils/diffutils-3.8.ebuild36
2 files changed, 38 insertions, 0 deletions
diff --git a/sys-apps/diffutils/Manifest b/sys-apps/diffutils/Manifest
index 3975d629751f..080b51a932b1 100644
--- a/sys-apps/diffutils/Manifest
+++ b/sys-apps/diffutils/Manifest
@@ -1,3 +1,5 @@
DIST diffutils-3.7.tar.xz 1448828 BLAKE2B d9f115e0ec9b2499545a3bef4e469fb7786d4a95e0a1c8459c885c53e8b1dc797027979e42c53c2a7df4e1e224942bd9ce5214813977af2bcc67f0698ea0c647 SHA512 7b12cf8aea1b9844773748f72272d9c6a38adae9c3c3a8c62048f91fb56c60b76035fa5f51665dceaf2cfbf1d1f4a3efdcc24bf47a5a16ff4350543314b12c9c
+DIST diffutils-3.8.tar.xz 1585120 BLAKE2B 573abbfba55c62ba30d2084ca68860e9681cfe92648407f7fb04e1aaed2e4719e2fb5a29cf25bd125d762f4dfd52f85ee91f2ec19b099365bada7fe27a0394af SHA512 279441270987e70d5ecfaf84b6285a4866929c43ec877e50f154a788858d548a8a316f2fc26ad62f7348c8d289cb29a09d06dfadce1806e3d8b4ea88c8b1aa7c
EBUILD diffutils-3.7-r1.ebuild 1179 BLAKE2B aa0c831588bceba6c855b67d53b51fe853b94659c70f63e829540b46e61be3a87fa2dc3889f81640a819ff4ed1a0db2a8d2903b707f27f59bf5b839916271209 SHA512 3a4287c690502ea4890850726d42ae937f726821a712435eb749e1ef82ef40ab415739dc3981872c541a2007596b22319aea7909e1dabee721c3f076d733599c
+EBUILD diffutils-3.8.ebuild 1069 BLAKE2B 3eabc7ddcfaf257fbd02b045b02ee0e4137d5e4dd539966c2bd979f48b4e1175ff24132ec43810c37de1aa84010831f72ed59b01ceb3d5403458e158cd5ef121 SHA512 c3a42f0971680cc09fce254badc285c2aaa8f263f2cbacbd864f2f88862ea61f57c168fcfb8c923cf9424ecaa2c4174ac68574bfeb98c9f45c3cabd5a9666aef
MISC metadata.xml 253 BLAKE2B 295e9d6d93aaa12af413972e1590c67087801cc09c9aa6b59d4606c0f4106d1dacf2baa9858559083b4c6d91beeef218d0729e8593a33788958da6d2897e8ce2 SHA512 54a9069aeb4165d2dff3d473c8001bc51613aac9dff3f7f5e9971a9891a737a31511ffa11cbd523febe581ac1d9de2bdf2f40410f0c4239138f2ccca3ef15555
diff --git a/sys-apps/diffutils/diffutils-3.8.ebuild b/sys-apps/diffutils/diffutils-3.8.ebuild
new file mode 100644
index 000000000000..48330a993112
--- /dev/null
+++ b/sys-apps/diffutils/diffutils-3.8.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit flag-o-matic
+
+DESCRIPTION="Tools to make diffs and compare files"
+HOMEPAGE="https://www.gnu.org/software/diffutils/"
+SRC_URI="mirror://gnu/diffutils/${P}.tar.xz
+ https://alpha.gnu.org/gnu/diffutils/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="nls static"
+
+BDEPEND="nls? ( sys-devel/gettext )"
+
+src_configure() {
+ use static && append-ldflags -static
+
+ # Disable automagic dependency over libsigsegv; see bug #312351.
+ export ac_cv_libsigsegv=no
+
+ # required for >=glibc-2.26, bug #653914
+ use elibc_glibc && export gl_cv_func_getopt_gnu=yes
+
+ local myeconfargs=(
+ --with-packager="Gentoo"
+ --with-packager-version="${PVR}"
+ --with-packager-bug-reports="https://bugs.gentoo.org/"
+ $(use_enable nls)
+ )
+ econf "${myeconfargs[@]}"
+}