summaryrefslogtreecommitdiff
path: root/sys-apps/dchroot
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /sys-apps/dchroot
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'sys-apps/dchroot')
-rw-r--r--sys-apps/dchroot/Manifest3
-rw-r--r--sys-apps/dchroot/dchroot-0.12.1.ebuild9
-rw-r--r--sys-apps/dchroot/files/dchroot-0.12.1-no-werror.patch13
3 files changed, 22 insertions, 3 deletions
diff --git a/sys-apps/dchroot/Manifest b/sys-apps/dchroot/Manifest
index 48c34609e6b1..f85f75ee82fd 100644
--- a/sys-apps/dchroot/Manifest
+++ b/sys-apps/dchroot/Manifest
@@ -1,3 +1,4 @@
+AUX dchroot-0.12.1-no-werror.patch 399 BLAKE2B eca3d10bbb230632a7c52a479e2a83e54c1181106ef62828b56028098d17e70b593046232448aa37725e43d74360e3b8eba48193d9c37d0ffcfc337c91f1621a SHA512 9cac8e139674f90cf676b46c9d51e3d2e0b291fc54a0b75931f356dce7f9501adf4314d9606ce9693773fb98407632e096b26c3c9ed94011fc22fc43d5e2514e
DIST dchroot_0.12.1.tar.gz 20287 BLAKE2B 9353817ba93ad65dd76b21d4db5e2546480850cea51efeec1918d538c25944ee40e459af2c6c4d24c5bc80c8f8611219088962b24c32ff236f9259764ab99384 SHA512 4c0b9e30c68f7ff953a259b4d21f0fab58b6a15dd8ebf0666267879114c0fce37a9fc38d71e5047003676c1ec4211feb0d2c51aa44def81d0d5a40815fd1c600
-EBUILD dchroot-0.12.1.ebuild 681 BLAKE2B e82872abaefbfe4464eea0f0aec349dc58719ccdc585187967e637ef8d2413d209d7b5d658f195113805fbd9325ac2ed5c69b42d5823e767e5fbaaad3c9bc839 SHA512 d57e2e1ae3a0ed61064cc2f5655c9e7bec854bf5fa7d0c989a0b94192dec188ff100517a44404111087f87a7d6b06cd7a5a57d70290975b075bbe1af0d06fced
+EBUILD dchroot-0.12.1.ebuild 736 BLAKE2B 2ab718c441a810ac97bc4aaeee9532fa6ce4db9e1fe2c8d4c202a4b818b9565eaea089c7eba5a3f5edd54a8b044cfaf7f4addb69e122b92faeb997b6318c55e8 SHA512 3d05031869171eb29bfc474834d5f7270215237d107bab1cb6a47ed0230091acd4063212030b6c19e5b478eaf11afabb8c82388c0abc108a87b3f5e38e85db5f
MISC metadata.xml 167 BLAKE2B 868e3b584722eaacf68273db062bb773d8c7e5d7ab2b81ca7e8397643bf7cc106c3a1033594401c99c54f667bb45d6b73f9048fc335580bbd44b4589ad26a832 SHA512 30caadd1496c3b9969136038239a1d8e01f236726b4022c2d7e19ca7575f25f735e556835e581afbf44fbd3e4104c40f2b5ef5fa70118d75c881fdf871962d0a
diff --git a/sys-apps/dchroot/dchroot-0.12.1.ebuild b/sys-apps/dchroot/dchroot-0.12.1.ebuild
index eee10e8bef06..7f02674ae0ae 100644
--- a/sys-apps/dchroot/dchroot-0.12.1.ebuild
+++ b/sys-apps/dchroot/dchroot-0.12.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -17,13 +17,18 @@ IUSE=""
DEPEND="sys-apps/help2man"
RDEPEND="!dev-util/schroot[dchroot]"
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.12.1-no-werror.patch
+)
+
src_prepare() {
- default
sed -i \
-e '/^all:/s:$: docs:' \
-e '/^CFLAGS/s:-O2:@CFLAGS@:' \
-e '/@CFLAGS@/ s:@CFLAGS@:@CFLAGS@ @LDFLAGS@:' \
Makefile.in || die "sed failed"
+
+ default
}
src_compile() {
diff --git a/sys-apps/dchroot/files/dchroot-0.12.1-no-werror.patch b/sys-apps/dchroot/files/dchroot-0.12.1-no-werror.patch
new file mode 100644
index 000000000000..4cd270190456
--- /dev/null
+++ b/sys-apps/dchroot/files/dchroot-0.12.1-no-werror.patch
@@ -0,0 +1,13 @@
+https://bugs.gentoo.org/824542
+https://bugs.gentoo.org/722920
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -3,7 +3,7 @@ mandir = ${prefix}/share/man
+ sysconfdir = $(DESTDIR)/etc
+
+ INSTALL=install
+-CFLAGS=-Wl,-z,now @CFLAGS@ @LDFLAGS@ -Wall -Wstrict-prototypes -Werror -g \
++CFLAGS=-Wl,-z,now @CFLAGS@ @LDFLAGS@ -Wall -Wstrict-prototypes \
+ -DDCHROOT_VERSION="\"@DCHROOT_VERSION@\""
+
+ all: dchroot docs