summaryrefslogtreecommitdiff
path: root/sys-apps/daisydog
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sys-apps/daisydog
reinit the tree, so we can have metadata
Diffstat (limited to 'sys-apps/daisydog')
-rw-r--r--sys-apps/daisydog/Manifest6
-rw-r--r--sys-apps/daisydog/daisydog-2014.05.30.ebuild34
-rw-r--r--sys-apps/daisydog/files/daisydog.conf.d4
-rwxr-xr-xsys-apps/daisydog/files/daisydog.init.d12
-rw-r--r--sys-apps/daisydog/metadata.xml7
5 files changed, 63 insertions, 0 deletions
diff --git a/sys-apps/daisydog/Manifest b/sys-apps/daisydog/Manifest
new file mode 100644
index 000000000000..441e8dc45d60
--- /dev/null
+++ b/sys-apps/daisydog/Manifest
@@ -0,0 +1,6 @@
+AUX daisydog.conf.d 115 SHA256 0cdadcfe27245cc0134b27405a3feeadd84631e828b2c453dc0957b1f03ff966 SHA512 81d9f238f4240d452e6316e0a94c489fc88eb3c8fe189958292a02dd0ce669bf957e614cd2864b7ccada8a174c94c6ee1cda7216e4fe96582a5cc266657710ea WHIRLPOOL 55d0737979a3f0f9a886f27500bbb797dad9d3e6d7db35557addee3717004c4cb3aec516cc78e385df5b53efd23d2c8da47345517bdd11af215d9ca9828655ee
+AUX daisydog.init.d 359 SHA256 6276299b8896e0449c788163e60e579fb2d0abdd1e994f37a2610714ed2ddd29 SHA512 ecb063e6fec9a463ac03977ac1a1d4f8ddb2864c6bd3ed3f041af70a797ca7bd3134c45aab99d42c136ffca4f00ce87f55df1fd42826fa92c1da75264d4389b1 WHIRLPOOL effd4f583a90bc348c0344c1d55a490f4c017c231d63a2274a74c3f6acdd70cab7238c805baa05317388caea756aded2cdcd0ac78e9044ed5d1a4ea936a0ad57
+DIST daisydog-3182aa85c087446e4358370549adc45db21ec124.tar.gz 10395 SHA256 b6185df3583e48e6b2cf16f6425aabe2dfdd94deaf8ac07f8dbd2c9a6f59809d SHA512 0a7312a3d9459487da8d20a80568187f51d4ae786939afbf38b8b89747831b2f7e0e32a3414b5d60863e33bcdebad9e457ff9a8f75143a7b60bf68fc9de17cd5 WHIRLPOOL a30263902a320e49f2d7c65669131476408f0b1d4eec3d5c2e5fbd3407417109184a4b25a5ac1b984b14cc7427fa3fc7b16559daa1da9d85b736a3b30a9721ff
+EBUILD daisydog-2014.05.30.ebuild 880 SHA256 90730bf0e54e4048cf9ba7ee0a8f4c1ac42c82b7f32ce4f6ea3692cbc40e0f75 SHA512 e80fe4a3279d88f78c00b779af7e7b361ba531e2061b7ba85d4e4f8aa0d478c068455d1f29ba120d69527305d3e39fe0507c3d8fdd7fe4a99c9f6d30307868b7 WHIRLPOOL 3a17b497f1cb1e332061ee72b7614e8cf77a0f657f9807bf81ab1ccc0c53c34984667bd72c7d176ec680cdf5bf88f8430ce31477eac37a4bbff7d4499c7daf09
+MISC ChangeLog 496 SHA256 067a68bc6918bdf6e501e3d6ae4118837797781d77808bd3701b20e895202a63 SHA512 ad642c85be39deb9aba1943aa624e5bf3f3d8abfb5d97e1c680ee0db33a3007464926ea91c625cff3e5a6456d7f4ec853ae248c69e62eee101e091ab5b3486a7 WHIRLPOOL 6918b45965ca1420ab83fef096904ea99ea3de0c4dee658b16d1091fd57d4efd186d1b19e18c7997e655d14b7b4c628ce2215aaa07368ba340d2bd7801fff0c1
+MISC metadata.xml 220 SHA256 8b7fa3a17e0058bf9e5c6ac8bf9329bfe9a2b0e5718d65b09711f8d421248504 SHA512 c262561324e85dc1fe18ceede654af3ae9f494b36233a807944dbbc7ac9764c93654d1faf958ef4c98c1fb370c71f5073443294289f43ddee0c76e606a703d32 WHIRLPOOL b4814ccae6bee1cea3e03b0df3e4a9e695289cc803bf0ed40166f3ba707ba2fa3a9b7fae0c621ba77c60bc1d729bdf002033072d86af66335b6e9cfef0bd3311
diff --git a/sys-apps/daisydog/daisydog-2014.05.30.ebuild b/sys-apps/daisydog/daisydog-2014.05.30.ebuild
new file mode 100644
index 000000000000..610bfeb4ebef
--- /dev/null
+++ b/sys-apps/daisydog/daisydog-2014.05.30.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+inherit toolchain-funcs flag-o-matic
+
+GIT_SHA1="3182aa85c087446e4358370549adc45db21ec124"
+MY_P="${PN}-${GIT_SHA1}"
+
+DESCRIPTION="A very simple /dev/watchdog daemon"
+HOMEPAGE="https://chromium.googlesource.com/chromiumos/third_party/daisydog/+/master"
+SRC_URI="mirror://gentoo/${MY_P}.tar.gz
+ https://chromium.googlesource.com/chromiumos/third_party/daisydog/+archive/${GIT_SHA1}.tar.gz -> ${MY_P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86"
+IUSE="static"
+
+S=${WORKDIR}
+
+src_configure() {
+ tc-export CC
+ use static && append-ldflags -static
+}
+
+src_install() {
+ dobin daisydog
+ dodoc README.chromiumos
+
+ newconfd "${FILESDIR}"/${PN}.conf.d ${PN}
+ newinitd "${FILESDIR}"/${PN}.init.d ${PN}
+}
diff --git a/sys-apps/daisydog/files/daisydog.conf.d b/sys-apps/daisydog/files/daisydog.conf.d
new file mode 100644
index 000000000000..05adc4531a22
--- /dev/null
+++ b/sys-apps/daisydog/files/daisydog.conf.d
@@ -0,0 +1,4 @@
+# /etc/conf.d/daisydog: config file for /etc/init.d/daisydog
+
+# for more info, see `daisydog -h`.
+WATCHDOG_OPTS=""
diff --git a/sys-apps/daisydog/files/daisydog.init.d b/sys-apps/daisydog/files/daisydog.init.d
new file mode 100755
index 000000000000..9513b7ef7578
--- /dev/null
+++ b/sys-apps/daisydog/files/daisydog.init.d
@@ -0,0 +1,12 @@
+#!/sbin/openrc-run
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+command="/usr/bin/daisydog"
+command_args="${WATCHDOG_OPTS}"
+description="watchdog daemon to pet /dev/watchdog devices"
+start_stop_daemon_args="--make-pidfile --background --pidfile /run/daisydog.pid"
+
+depend() {
+ provide watchdog
+}
diff --git a/sys-apps/daisydog/metadata.xml b/sys-apps/daisydog/metadata.xml
new file mode 100644
index 000000000000..aebca33be179
--- /dev/null
+++ b/sys-apps/daisydog/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>base-system@gentoo.org</email>
+</maintainer>
+</pkgmetadata>