summaryrefslogtreecommitdiff
path: root/sys-apps/cpuid/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-09-25 19:33:39 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-09-28 08:31:11 +0100
commitad6182343997a405079870a2fe91c4e0c6b94595 (patch)
tree4aa7483cd0ad7de54338afc8e7971417abe1dd81 /sys-apps/cpuid/files
parente8f81810baa21f490d6910e8e2d424546b72a333 (diff)
gentoo resync : 25.09.2019
Diffstat (limited to 'sys-apps/cpuid/files')
-rw-r--r--sys-apps/cpuid/files/cpuid-20180519-add-spec-ctrl-output.patch10
-rw-r--r--sys-apps/cpuid/files/cpuid-20180519-makefile.patch46
2 files changed, 56 insertions, 0 deletions
diff --git a/sys-apps/cpuid/files/cpuid-20180519-add-spec-ctrl-output.patch b/sys-apps/cpuid/files/cpuid-20180519-add-spec-ctrl-output.patch
new file mode 100644
index 000000000000..7cb078fe7eca
--- /dev/null
+++ b/sys-apps/cpuid/files/cpuid-20180519-add-spec-ctrl-output.patch
@@ -0,0 +1,10 @@
+--- a/cpuid.c 2018-05-19 14:09:29.000000000 +0200
++++ b/cpuid.c 2019-08-08 21:53:03.000000000 +0200
+@@ -4249,6 +4249,7 @@
+ { "fast short REP MOV" , 4, 4, bools },
+ { "PCONFIG" , 18, 18, bools },
+ { "CET_IBT: CET indirect branch tracking" , 20, 20, bools },
++ { "SPEC_CTRL: Speculation Control" , 26, 26, bools },
+ };
+ print_names(value, names, LENGTH(names, named_item),
+ /* max_len => */ 40);
diff --git a/sys-apps/cpuid/files/cpuid-20180519-makefile.patch b/sys-apps/cpuid/files/cpuid-20180519-makefile.patch
new file mode 100644
index 000000000000..e140c322fb19
--- /dev/null
+++ b/sys-apps/cpuid/files/cpuid-20180519-makefile.patch
@@ -0,0 +1,46 @@
+--- a/Makefile 2018-05-19 14:15:37.000000000 +0200
++++ b/Makefile 2019-08-08 21:43:09.000000000 +0200
+@@ -1,4 +1,4 @@
+-CFLAGS+=-g
++CFLAGS+=
+ CPPFLAGS?=
+ LDFLAGS?=
+ ifneq (,$(findstring arch=i386,$(CFLAGS)))
+@@ -36,7 +36,7 @@
+
+ BUILDROOT=
+
+-default: $(PROG) $(PROG).man.gz cpuinfo2cpuid cpuinfo2cpuid.man.gz
++default: $(PROG) cpuinfo2cpuid cpuinfo2cpuid.man
+
+ $(PROG): cpuid.c Makefile
+ $(CC) $(CFL) $(LDFLAGS) -o $@ cpuid.c
+@@ -50,11 +50,11 @@
+ cpuinfo2cpuid.man.gz: cpuinfo2cpuid.man
+ gzip < $< > $@
+
+-install: $(PROG) $(PROG).man.gz cpuinfo2cpuid cpuinfo2cpuid.man.gz
+- install -D -s -m 755 $(PROG) $(BUILDROOT)/usr/bin/$(PROG)
+- install -D -m 444 $(PROG).man.gz $(BUILDROOT)/usr/share/man/man1/$(PROG).1.gz
++install: $(PROG) cpuinfo2cpuid
++ install -D -m 755 $(PROG) $(BUILDROOT)/usr/bin/$(PROG)
++ install -D -m 444 $(PROG).man $(BUILDROOT)/usr/share/man/man1/$(PROG).1
+ install -D -m 755 cpuinfo2cpuid $(BUILDROOT)/usr/bin/cpuinfo2cpuid
+- install -D -m 444 cpuinfo2cpuid.man.gz $(BUILDROOT)/usr/share/man/man1/cpuinfo2cpuid.1.gz
++ install -D -m 444 cpuinfo2cpuid.man $(BUILDROOT)/usr/share/man/man1/cpuinfo2cpuid.1
+
+ clean:
+ rm -f $(PROG) $(PROG).i386 $(PROG).x86_64
+@@ -71,10 +71,10 @@
+ # Todd's Development rules
+
+ $(PROG).i386: cpuid.c Makefile
+- $(CC) -m32 -Wl,--hash-style=both $(CFL) $(LDFLAGS) -o $@ cpuid.c
++ $(CC) -m32 $(CFL) -o $@ cpuid.c
+
+ $(PROG).x86_64: cpuid.c Makefile
+- $(CC) -m64 $(CFL) $(LDFLAGS) -o $@ cpuid.c
++ $(CC) -m64 $(CFL) -o $@ cpuid.c
+
+ todd: $(PROG).i386 $(PROG).x86_64
+ rm -f ~/.bin/execs/i586/$(PROG)