summaryrefslogtreecommitdiff
path: root/sys-apps/cpuid/cpuid-20240330.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-04-02 20:14:09 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-04-02 20:14:09 +0100
commitdd955a48d88d9b98d49a61f10ab4b52f53cf83a0 (patch)
treede2fa72b509cdf2371fc67b9ec231bdad7d03b5b /sys-apps/cpuid/cpuid-20240330.ebuild
parent29e3ef4590d6bee24c4a3798d12a3cfef750bd54 (diff)
gentoo auto-resync : 02:04:2024 - 20:14:09
Diffstat (limited to 'sys-apps/cpuid/cpuid-20240330.ebuild')
-rw-r--r--sys-apps/cpuid/cpuid-20240330.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/sys-apps/cpuid/cpuid-20240330.ebuild b/sys-apps/cpuid/cpuid-20240330.ebuild
new file mode 100644
index 000000000000..d1563143acef
--- /dev/null
+++ b/sys-apps/cpuid/cpuid-20240330.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Linux tool to dump x86 CPUID information about the CPUs"
+HOMEPAGE="http://www.etallen.com/cpuid.html"
+SRC_URI="http://www.etallen.com/${PN}/${P}.src.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+
+BDEPEND="
+ app-arch/gzip
+ dev-lang/perl
+"
+
+DOCS=( "ChangeLog" "FUTURE" )
+
+PATCHES=( "${FILESDIR}/${PN}-20220620-makefile.patch" )
+
+src_prepare() {
+ default
+
+ tc-export CC
+}
+
+src_install() {
+ emake BUILDROOT="${ED}" install
+
+ einstalldocs
+}