summaryrefslogtreecommitdiff
path: root/sys-apps/conspy/conspy-1.10.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sys-apps/conspy/conspy-1.10.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'sys-apps/conspy/conspy-1.10.ebuild')
-rw-r--r--sys-apps/conspy/conspy-1.10.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/sys-apps/conspy/conspy-1.10.ebuild b/sys-apps/conspy/conspy-1.10.ebuild
new file mode 100644
index 000000000000..488d0abf5504
--- /dev/null
+++ b/sys-apps/conspy/conspy-1.10.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+AUTOTOOLS_AUTORECONF=true
+inherit autotools-utils
+
+DESCRIPTION="Remote control for Linux virtual consoles"
+HOMEPAGE="http://conspy.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}-1/${P}.tar.gz"
+
+LICENSE="AGPL-3"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND="sys-libs/ncurses:0="
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ autotools-utils_src_configure
+
+ mv \
+ "${WORKDIR}"/${P}_build/Makefile-automake \
+ "${WORKDIR}"/${P}_build/Makefile || die
+}
+
+src_install() {
+ dobin "${WORKDIR}"/${P}_build/${PN}
+ doman ${PN}.1
+ dodoc ChangeLog.txt README.txt
+ dohtml ${PN}.html
+}