summaryrefslogtreecommitdiff
path: root/sys-apps/consolation
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-10-13 22:19:36 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-10-14 23:22:23 +0100
commit4b19be30aa626b327c885dae62c559ec0e9fb935 (patch)
tree76e74807bc479502e13866b581b6bf86734ec634 /sys-apps/consolation
parent30d6f67c98d149508509d5e86f176d558793acc0 (diff)
gentoo resync : 13.10.2019
Diffstat (limited to 'sys-apps/consolation')
-rw-r--r--sys-apps/consolation/Manifest6
-rw-r--r--sys-apps/consolation/consolation-0.0.7.ebuild42
-rw-r--r--sys-apps/consolation/files/consolation-0.0.7-makefile.patch25
-rw-r--r--sys-apps/consolation/files/consolation-confd4
-rw-r--r--sys-apps/consolation/files/consolation-initd12
-rw-r--r--sys-apps/consolation/metadata.xml8
6 files changed, 97 insertions, 0 deletions
diff --git a/sys-apps/consolation/Manifest b/sys-apps/consolation/Manifest
new file mode 100644
index 000000000000..0c7fb32eccab
--- /dev/null
+++ b/sys-apps/consolation/Manifest
@@ -0,0 +1,6 @@
+AUX consolation-0.0.7-makefile.patch 838 BLAKE2B d4f196289a16239ce3b898abcb9d67c68959fe2fc854f55587edf7a1473e1db6ee2b6c8e46e83fb1839eadcf8d3323ef4383a339773fbffeae7f8091aa09d859 SHA512 af1b2baacf77b4472d9f0e42d69443b7fb9b1706479c4096f8f8ffab5acf34ba857cd816f66e22f5851629baee9b1c705a16944b6ce84f5c0937472f6965b67c
+AUX consolation-confd 83 BLAKE2B a43c1d7f58524345ebd5a6a39435505739560e7db38ccba294603767b3477484605f481f0af6e11bc92f7c90c37758dd81910b1d3cf0e08ecc7f19b642930618 SHA512 d801f5dd92f06003b8b08c2a59c91c1dd737683058deefcee1c59e4791a9df2cb3d7c9df0729fc24d287c54201d9c710e529abc0020f6a68b7e0fcf4382d21d5
+AUX consolation-initd 271 BLAKE2B d36dbee622c0abe1f52ec93d9d889f000925db5c05ebae3fff0e46cae4abd1cd527ae92ee997a3812919dd41cb5958fb8e8db7980b6ca9f5c6515eb5d78559a7 SHA512 382d9d1ca9ade50e20f52f84924d441021cca1eee274b89bbb988f5181f46e259c04e613deb584cc7a05583d065521d184dbd4fefe6e003d704521f8af3b2c11
+DIST consolation-consolation-0.0.7.tar.gz 11811 BLAKE2B 7d100a49b766a250eac622785b2f310bef4801a16eac665d7ce5ede249c533c3b948f039d7215e9c55d711f3d2b575972640357fa0e34c114705bef389cdc60f SHA512 dfe101c5198fd57e51e51339a031b5b7216a6df26e039457303f5269b78a98e3c80902c303fd82f26158760543ffa22d1a0c1e73c794c717e0bdd6f1d298a72c
+EBUILD consolation-0.0.7.ebuild 801 BLAKE2B e7289dc22e6cd7e0128b1e732fbc5a792cf23fbfed7c871839fef7f24e103e27196b6554a963cef7a95d36080961ef900d30724ab9ee670fb46abdc1fc248fcc SHA512 d3cbd82bf0b996667a392c4c69d05d5abd9a71b4436b81ba0485b0dc7ae65e3c11b659785e7869e89e3394f9c41ec75683e69b2be6ef941c3a526c41f1908089
+MISC metadata.xml 255 BLAKE2B 2bb3830b8cec850703f7912f4c22f5b0abeabeed0715222bc56141779d02160773cfd0f85417c553c1cd8f2738bfeb78c56dffb8e648e572019319657646d1ba SHA512 522158915afe67937f81ba572a918a2de8ca1f8591e097da56799c97870d7c44756c1acd8224d63bd3375c2b9ebc0e1ce50816899117948a48065a27804883bf
diff --git a/sys-apps/consolation/consolation-0.0.7.ebuild b/sys-apps/consolation/consolation-0.0.7.ebuild
new file mode 100644
index 000000000000..b616cd134fe1
--- /dev/null
+++ b/sys-apps/consolation/consolation-0.0.7.ebuild
@@ -0,0 +1,42 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit systemd autotools
+
+DESCRIPTION="libinput based console mouse daemon"
+HOMEPAGE="https://salsa.debian.org/consolation-team/consolation"
+SRC_URI="https://salsa.debian.org/consolation-team/${PN}/-/archive/${P}/${PN}-${P}.tar.gz"
+
+LICENSE="GPL-2+ MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-libs/libinput:=
+ virtual/libudev:=
+ dev-libs/libevdev:="
+RDEPEND="${DEPEND}"
+BDEPEND="sys-apps/help2man"
+
+S="${WORKDIR}/${PN}-${P}"
+
+PATCHES=(
+ "${FILESDIR}/consolation-0.0.7-makefile.patch"
+)
+
+src_prepare() {
+ default
+
+ eautoreconf
+}
+
+src_install() {
+ default
+
+ newinitd "${FILESDIR}/${PN}-initd" ${PN}
+ newconfd "${FILESDIR}/${PN}-confd" ${PN}
+
+ systemd_dounit consolation.service
+}
diff --git a/sys-apps/consolation/files/consolation-0.0.7-makefile.patch b/sys-apps/consolation/files/consolation-0.0.7-makefile.patch
new file mode 100644
index 000000000000..b699edc1e8e0
--- /dev/null
+++ b/sys-apps/consolation/files/consolation-0.0.7-makefile.patch
@@ -0,0 +1,25 @@
+diff --git a/Makefile.am b/Makefile.am
+index c577a9a..8a0e07f 100644
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -5,7 +5,7 @@ CLEANFILES = consolation.service
+
+ all: consolation.8 consolation.service
+
+-consolation.8: README src/shared.c $(top_srcdir)/configure.ac
++consolation.8: src/consolation-recursive README src/shared.c $(top_srcdir)/configure.ac
+ help2man --no-info --source=Debian --section=8 --include=README \
+ src/consolation \
+ | sed -e 's,\\fB,.TP\n\\fB,g' > consolation.8.new \
+diff --git a/configure.ac b/configure.ac
+index 10bf054..25bdebc 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -5,6 +5,7 @@ AC_INIT([consolation], [0.0.7])
+ AC_CONFIG_AUX_DIR(config)
+
+ AM_INIT_AUTOMAKE([1.11 foreign no-dist-gzip dist-xz])
++AM_EXTRA_RECURSIVE_TARGETS([src/consolation])
+ AM_CONFIG_HEADER(src/config.h)
+
+ # Check for programs
diff --git a/sys-apps/consolation/files/consolation-confd b/sys-apps/consolation/files/consolation-confd
new file mode 100644
index 000000000000..fd03ae38eeca
--- /dev/null
+++ b/sys-apps/consolation/files/consolation-confd
@@ -0,0 +1,4 @@
+# /etc/conf.d/consolation
+
+# arguments to pass to consolation
+#consolation_args=""
diff --git a/sys-apps/consolation/files/consolation-initd b/sys-apps/consolation/files/consolation-initd
new file mode 100644
index 000000000000..c9252a82b865
--- /dev/null
+++ b/sys-apps/consolation/files/consolation-initd
@@ -0,0 +1,12 @@
+#!/sbin/openrc-run
+# Copyright 2019 Sony Interactive Entertainment Inc.
+# Distributed under the terms of the GNU General Public License v2
+
+name="consolation daemon"
+description=""
+command=/usr/sbin/consolation
+command_args="${consolation_args}"
+
+depend() {
+ need udev
+}
diff --git a/sys-apps/consolation/metadata.xml b/sys-apps/consolation/metadata.xml
new file mode 100644
index 000000000000..56cae167d372
--- /dev/null
+++ b/sys-apps/consolation/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>chutzpah@gentoo.org</email>
+ <name>Patrick McLean</name>
+ </maintainer>
+</pkgmetadata>