summaryrefslogtreecommitdiff
path: root/sys-apps/cinit
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-06-18 19:48:47 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-06-18 19:48:47 +0100
commit1494784ae35c6fa7b6a92a80dea93265fc54ccd0 (patch)
treedbbb1b83e130750c3a55a4287c3a2ec2bbff7af8 /sys-apps/cinit
parentee74b33422f15493c315bdacf20da95d5b936d3c (diff)
gentoo auto-resync : 18:06:2023 - 19:48:47
Diffstat (limited to 'sys-apps/cinit')
-rw-r--r--sys-apps/cinit/Manifest2
-rw-r--r--sys-apps/cinit/cinit-0.2.1-r1.ebuild42
-rw-r--r--sys-apps/cinit/files/cinit-0.2.1-musl-clang16-build-fix.patch43
3 files changed, 87 insertions, 0 deletions
diff --git a/sys-apps/cinit/Manifest b/sys-apps/cinit/Manifest
index 1e3de39e3af1..1cdf7161c2fa 100644
--- a/sys-apps/cinit/Manifest
+++ b/sys-apps/cinit/Manifest
@@ -1,3 +1,5 @@
+AUX cinit-0.2.1-musl-clang16-build-fix.patch 1582 BLAKE2B afadee30b5de75c84d945622af2790eac58d7708a1f153b1aaba0f4bf78910cd778481f1e58cb097a1254f1ebdab67feba73b2b5af1073162e12905de8e7fe30 SHA512 b8764788e0ed934cb608248281a5ec19bc7b35e109989a34cb6cf95bc727ca9b01c35a5cf35a6c57a820fa5ebae5fdcbc825eebed2d2920873d8d0499d1ea27c
DIST cinit-0.2.1.tar.bz2 63545 BLAKE2B ef45cc1a2622d4dbf36e47fab2d09a576ea726e3aa2ac928827dae63fd976daf3dee3d91de21bc1f66200fcb90aecd267b0e9fef9575e525b8e75d00a0f818a5 SHA512 fce6a0c06b11a252023f7f0159fdfe4f9f4dc3c1545708997c148ed2f0a451bb68a5b98518fc48083e3518959d28b32b1719a9b89d00af7a997854230fca09d7
+EBUILD cinit-0.2.1-r1.ebuild 924 BLAKE2B 47a0dcf68cb2de7745ccfd6ea77b0b065c196fd624bd7b1c7fcabfe38a9d75d0b0a8d3b4390434b8597db460808d50588f286391966da05d7834d56f996f9e8e SHA512 bf3604a9ea75422d4b97d645931639b22bfc4c739c1796b56e444125d7b962d3710d0e546b72d24129879cff01e52debcaca09e98300524d278de3a9d6cb750a
EBUILD cinit-0.2.1.ebuild 855 BLAKE2B a509bcb0455f8b83af97fa2604e17fe7fbfe334e48781b407be5d1c466c819e9852a5cac18163aec5dd3ea8e81534e781f5c3e4a9f394e34052de6da5f015b08 SHA512 a5829fa70951104d1b0a9f326b4cb5706fd558af1fad96ca5143e28522169fda92ad7eb7da319407eea8c1739edc30b0fcc30b38f6ac37ee664b898f08e8df1f
MISC metadata.xml 167 BLAKE2B 868e3b584722eaacf68273db062bb773d8c7e5d7ab2b81ca7e8397643bf7cc106c3a1033594401c99c54f667bb45d6b73f9048fc335580bbd44b4589ad26a832 SHA512 30caadd1496c3b9969136038239a1d8e01f236726b4022c2d7e19ca7575f25f735e556835e581afbf44fbd3e4104c40f2b5ef5fa70118d75c881fdf871962d0a
diff --git a/sys-apps/cinit/cinit-0.2.1-r1.ebuild b/sys-apps/cinit/cinit-0.2.1-r1.ebuild
new file mode 100644
index 000000000000..22cbed1f0264
--- /dev/null
+++ b/sys-apps/cinit/cinit-0.2.1-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="a fast, small and simple init with support for profiles"
+HOMEPAGE="http://linux.schottelius.org/cinit/"
+SRC_URI="http://linux.schottelius.org/${PN}/archives/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~x86"
+IUSE="doc"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.2.1-musl-clang16-build-fix.patch
+)
+
+src_prepare() {
+ sed -i "/contrib+tools/d" Makefile || die
+ sed -i "/^STRIP/s/strip.*/true/" Makefile.include || die
+ default
+}
+
+src_compile() {
+ emake \
+ CC="$(tc-getCC)" \
+ LD="$(tc-getCC)" \
+ CFLAGS="${CFLAGS} -I." \
+ LDFLAGS="${LDFLAGS}" \
+ STRIP=/bin/true \
+ all
+}
+
+src_install() {
+ emake LD="$(tc-getCC)" DESTDIR="${D}" install
+ rm -f "${D}"/sbin/{init,shutdown,reboot} || die
+ dodoc Changelog CHANGES CREDITS README TODO
+ use doc && dodoc -r doc
+}
diff --git a/sys-apps/cinit/files/cinit-0.2.1-musl-clang16-build-fix.patch b/sys-apps/cinit/files/cinit-0.2.1-musl-clang16-build-fix.patch
new file mode 100644
index 000000000000..832e0590b5c6
--- /dev/null
+++ b/sys-apps/cinit/files/cinit-0.2.1-musl-clang16-build-fix.patch
@@ -0,0 +1,43 @@
+With musl and clang16 the following build error occurs:
+
+client/run_run_svcs.c:24:17: error: use of undeclared identifier 'PATH_MAX'
+ char pathbuf[PATH_MAX+1];
+ ^
+client/run_run_svcs.c:28:21: warning: if statement has empty body [-Wempty-body]
+ D_PRINTF(abspath);
+ ^
+client/run_run_svcs.c:28:21: note: put the semicolon on a separate line to silence this warning
+client/connect_sock.c:28:4: error: call to undeclared library function 'memset' with type
+ 'void *(void *, int, unsigned long)'; ISO C99 and later do not support implicit function declarations
+ [-Wimplicit-function-declaration]
+ memset(&addr,0,socke);
+ ^
+client/connect_sock.c:28:4: note: include the header <string.h> or explicitly provide a declaration for
+ 'memset'
+client/connect_sock.c:29:4: error: call to undeclared library function 'strcpy' with type
+ 'char *(char *, const char *)'; ISO C99 and later do not support implicit function declarations
+ [-Wimplicit-function-declaration]
+ strcpy(addr.sun_path, CINIT_SOCK);
+
+This patch fixes all three of those errors
+Bug: https://bugs.gentoo.org/898542
+--- a/client/connect_sock.c
++++ b/client/connect_sock.c
+@@ -8,6 +8,7 @@
+ #include <sys/socket.h>
+ #include <sys/un.h>
+ #include <stdio.h>
++#include <string.h>
+
+ #include "cinit.h"
+
+--- a/client/run_run_svcs.c
++++ b/client/run_run_svcs.c
+@@ -3,6 +3,7 @@
+ * (c) 2005 Nico Schottelius (nico-linux at schottelius.org)
+ * run services parallel
+ */
++#include <linux/limits.h>
+ #include <sys/types.h>
+ #include <sys/wait.h>
+ #include <dirent.h>