summaryrefslogtreecommitdiff
path: root/sys-apps/chname/chname-1.1-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-04-28 05:11:40 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-04-28 05:11:40 +0100
commit2099ff9b640e648be67527e29760263a7c6274e5 (patch)
tree238358af0ba45fd8fcc6cd4679736d6c4f07f851 /sys-apps/chname/chname-1.1-r1.ebuild
parentd198e0ebeee70707545d19ee3beb1de70802cc7c (diff)
gentoo auto-resync : 28:04:2023 - 05:11:40
Diffstat (limited to 'sys-apps/chname/chname-1.1-r1.ebuild')
-rw-r--r--sys-apps/chname/chname-1.1-r1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/sys-apps/chname/chname-1.1-r1.ebuild b/sys-apps/chname/chname-1.1-r1.ebuild
new file mode 100644
index 000000000000..c7d8a16b1961
--- /dev/null
+++ b/sys-apps/chname/chname-1.1-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Run a command with a new system hostname"
+HOMEPAGE="https://github.com/marineam/chname"
+SRC_URI="https://github.com/marineam/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND=">=sys-kernel/linux-headers-2.6.16"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-flags.patch
+)
+
+src_configure() {
+ tc-export CC
+}
+
+src_install() {
+ dobin "${PN}"
+ doman "${PN}.1"
+ dodoc README*
+}