summaryrefslogtreecommitdiff
path: root/sys-apps/busybox
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-01-24 10:45:40 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-01-24 10:45:40 +0000
commit1804d2ae908b26fe4e3d3a38646c7d6ffa733d92 (patch)
tree6f5cdff53cb2fde48a01817379124dc476b3742d /sys-apps/busybox
parent2fa0c8dbba3b2455531e5616eed64f2fe66cb58b (diff)
gentoo auto-resync : 24:01:2024 - 10:45:40
Diffstat (limited to 'sys-apps/busybox')
-rw-r--r--sys-apps/busybox/Manifest1
-rw-r--r--sys-apps/busybox/busybox-1.36.1.ebuild363
2 files changed, 0 insertions, 364 deletions
diff --git a/sys-apps/busybox/Manifest b/sys-apps/busybox/Manifest
index 7475def38d26..48e009549593 100644
--- a/sys-apps/busybox/Manifest
+++ b/sys-apps/busybox/Manifest
@@ -19,6 +19,5 @@ AUX watchdog.confd 232 BLAKE2B 14ff3813297bc987e98bf3cabee2e7b150e23d8aa9f016303
AUX watchdog.initd 219 BLAKE2B 3726fec4551962d6e20859c52e18582fbf127e2fc2807379afe9d490ad32b19a6d10d456155fdeb0468c67816f061b1cac166db7f104dbadadf0d175082efdb4 SHA512 d329fb72ce078a95a1fb77b72321dee56d19c76b45cb78a7a57a46d9fa385b982a114be49dd8696c2d4fc2b2dd90a17ee728ef2938172cc2f8b12b5a9ebd62f5
DIST busybox-1.36.1.tar.bz2 2525473 BLAKE2B e515825cb3ab1c520e16b9c2512e9fc72947366a72a0466bff59b507fdffbc78fc9d16b44a26116175fc7a429d849ad944b1bc379d36c6d3a0eb20969997336e SHA512 8c0c754c9ae04b5e6b23596283a7d3a4ef96225fe179f92d6f6a99c69c0caa95b1aa56c267f52d7c807f6cc69e1f0b7dd29a8ac624098f601738f8c0c57980d4
EBUILD busybox-1.36.1-r1.ebuild 10852 BLAKE2B a5ec27673706bd84cb26f1db9f3f6d0bc04c1b2517d49effedf5c2175e7972feed8658d6e4c731e6342e04b05dffc0f28ddba1e16e4c5127e3c027fe55145623 SHA512 0f1c5434e1c0b5fe91a29c82f2e9fe4f40acb993bb9a1171f38d5687309aed994c624a23392b395e10fde55979bd4c87558b809d913d08c6375cbc59314cd810
-EBUILD busybox-1.36.1.ebuild 10488 BLAKE2B 5e9d61e5c9682786e2137be08ac54d948101e479c3231bd4035e17bc8df1ae8a97c576218e8991f3b5b544ef09d2bc16885bd149ecb33daff1f8374acbfe1169 SHA512 8eab6a264efac5287cfd24fea758c96928ea5cfeb8f6fbb06ed1d7ff5f3421d3582a9d801f637ca35e89fa568ad9a2ae36e0afee8b29c32a1bc65924ad748eb3
EBUILD busybox-9999.ebuild 10860 BLAKE2B 3903f87f402225bdb9c90f91cf443ac23f2ae65187d507ccaf5d429bf694536377d0158bc56a631a3e1162a311b59764cb3c9c41d92e4a12f9c4540367630b5a SHA512 7bea77ed004f214032fe3e301833e381a94a848f6b8c4a45478b306831d1163ceb661f9ebcd76a18ffc88d97c4605c20c35782099bc83bf9c626ab8c24da0743
MISC metadata.xml 873 BLAKE2B d9c3725e1c3587d497894761d9eda08b670522d5c1a5518ea879cb5c9f222519005d28a36d6dea0b34d4bf4a2352e54aa151177f98ac730ce5b83e87ae4d35a2 SHA512 4c74f718046b41fbcf0111c797d6cdfa1f647914bfa5ff9aaedd6844ba1367722f225ed8ac17717d7b44c5ddc3b450e130da46cc0f6e21501b66cfd267a8f9ad
diff --git a/sys-apps/busybox/busybox-1.36.1.ebuild b/sys-apps/busybox/busybox-1.36.1.ebuild
deleted file mode 100644
index e252de9fe95c..000000000000
--- a/sys-apps/busybox/busybox-1.36.1.ebuild
+++ /dev/null
@@ -1,363 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-# See `man savedconfig.eclass` for info on how to use USE=savedconfig.
-
-EAPI=8
-
-inherit flag-o-matic savedconfig toolchain-funcs
-
-DESCRIPTION="Utilities for rescue and embedded systems"
-HOMEPAGE="https://www.busybox.net/"
-if [[ ${PV} == "9999" ]] ; then
- MY_P="${P}"
- EGIT_REPO_URI="https://git.busybox.net/busybox"
- inherit git-r3
-else
- MY_P="${PN}-${PV/_/-}"
- SRC_URI="https://www.busybox.net/downloads/${MY_P}.tar.bz2"
- KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux"
-fi
-S="${WORKDIR}/${MY_P}"
-
-LICENSE="GPL-2" # GPL-2 only
-SLOT="0"
-IUSE="debug livecd make-symlinks math mdev pam selinux sep-usr static syslog systemd"
-REQUIRED_USE="pam? ( !static )"
-RESTRICT="test"
-
-# TODO: Could make pkgconfig conditional on selinux? bug #782829
-RDEPEND="
- !static? (
- virtual/libc
- virtual/libcrypt:=
- selinux? ( sys-libs/libselinux )
- )
- pam? ( sys-libs/pam )
-"
-DEPEND="${RDEPEND}
- static? (
- virtual/libcrypt[static-libs]
- selinux? ( sys-libs/libselinux[static-libs(+)] )
- )
- sys-kernel/linux-headers"
-BDEPEND="virtual/pkgconfig"
-
-busybox_config_option() {
- local flag=$1 ; shift
- if [[ ${flag} != [yn] && ${flag} != \"* ]] ; then
- busybox_config_option $(usex ${flag} y n) "$@"
- return
- fi
- local expr
- while [[ $# -gt 0 ]] ; do
- case ${flag} in
- y) expr="s:.*\<CONFIG_$1\>.*set:CONFIG_$1=y:g" ;;
- n) expr="s:CONFIG_$1=y:# CONFIG_$1 is not set:g" ;;
- *) expr="s:.*\<CONFIG_$1\>.*:CONFIG_$1=${flag}:g" ;;
- esac
- sed -i -e "${expr}" .config || die
- einfo "$(grep "CONFIG_$1[= ]" .config || echo "Could not find CONFIG_$1 ...")"
- shift
- done
-}
-
-busybox_config_enabled() {
- local val=$(sed -n "/^CONFIG_$1=/s:^[^=]*=::p" .config)
- case ${val} in
- "") return 1 ;;
- y) return 0 ;;
- *) echo "${val}" | sed -r 's:^"(.*)"$:\1:' ;;
- esac
-}
-
-# patches go here!
-PATCHES=(
- "${FILESDIR}"/${PN}-1.26.2-bb.patch
- "${FILESDIR}"/${PN}-1.34.1-skip-selinux-search.patch
-
- "${FILESDIR}"/${PN}-1.36.0-fortify-source-3-fixdep.patch
-
- # "${FILESDIR}"/${P}-*.patch
-)
-
-src_prepare() {
- default
- unset KBUILD_OUTPUT #88088
- append-flags -fno-strict-aliasing #310413
- use ppc64 && append-flags -mminimal-toc #130943
-
- cp "${FILESDIR}"/ginit.c init/ || die
-
- # flag cleanup
- sed -i -r \
- -e 's:[[:space:]]?-(Werror|Os|falign-(functions|jumps|loops|labels)=1|fomit-frame-pointer)\>::g' \
- Makefile.flags || die
- #sed -i '/bbsh/s:^//::' include/applets.h
- sed -i '/^#error Aborting compilation./d' applets/applets.c || die
- use elibc_glibc && sed -i 's:-Wl,--gc-sections::' Makefile
- sed -i \
- -e "/^CROSS_COMPILE/s:=.*:= ${CHOST}-:" \
- -e "/^AR\>/s:=.*:= $(tc-getAR):" \
- -e "/^CC\>/s:=.*:= $(tc-getCC):" \
- -e "/^HOSTCC/s:=.*:= $(tc-getBUILD_CC):" \
- -e "/^PKG_CONFIG\>/s:=.*:= $(tc-getPKG_CONFIG):" \
- Makefile || die
- sed -i \
- -e 's:-static-libgcc::' \
- Makefile.flags || die
-
- # Print all link lines too
- sed -i -e 's:debug=false:debug=true:' scripts/trylink || die
-}
-
-src_configure() {
- # check for a busybox config before making one of our own.
- # if one exist lets return and use it.
-
- restore_config .config
- if [ -f .config ]; then
- yes "" | emake -j1 -s oldconfig >/dev/null
- return 0
- else
- ewarn "Could not locate user configfile, so we will save a default one"
- fi
-
- # setting SKIP_SELINUX skips searching for selinux at this stage. We don't
- # need to search now in case we end up not needing it after all.
- # setup the config file
- emake -j1 -s allyesconfig SKIP_SELINUX=$(usex selinux n y) >/dev/null #620918
- # nommu forces a bunch of things off which we want on #387555
- busybox_config_option n NOMMU
- sed -i '/^#/d' .config
- yes "" | emake -j1 -s oldconfig SKIP_SELINUX=$(usex selinux n y) >/dev/null #620918
-
- # now turn off stuff we really don't want
- busybox_config_option n DMALLOC
- busybox_config_option n FEATURE_2_4_MODULES #607548
- busybox_config_option n FEATURE_SUID_CONFIG
- busybox_config_option n BUILD_AT_ONCE
- busybox_config_option n BUILD_LIBBUSYBOX
- busybox_config_option n FEATURE_CLEAN_UP
- busybox_config_option n MONOTONIC_SYSCALL
- busybox_config_option n USE_PORTABLE_CODE
- busybox_config_option n WERROR
- # CONFIG_MODPROBE_SMALL=y disables depmod.c and uses a smaller one that
- # does not support -b. Setting this to no creates slightly larger and
- # slightly more useful modutils
- busybox_config_option n MODPROBE_SMALL #472464
- # triming the BSS size may be dangerous
- busybox_config_option n FEATURE_USE_BSS_TAIL
-
- # These cause trouble with musl.
- if use elibc_musl; then
- busybox_config_option n FEATURE_UTMP
- busybox_config_option n EXTRA_COMPAT
- busybox_config_option n FEATURE_VI_REGEX_SEARCH
- fi
-
- # Disable standalone shell mode when using make-symlinks, else Busybox calls its
- # applets by default without looking up in PATH.
- # This also enables users to disable a builtin by deleting the corresponding symlink.
- if use make-symlinks; then
- busybox_config_option n FEATURE_PREFER_APPLETS
- busybox_config_option n FEATURE_SH_STANDALONE
- fi
-
- # If these are not set and we are using a busybox setup
- # all calls to system() will fail.
- busybox_config_option y ASH
- busybox_config_option y SH_IS_ASH
- busybox_config_option n HUSH
- busybox_config_option n SH_IS_HUSH
-
- busybox_config_option '"/run"' PID_FILE_PATH
- busybox_config_option '"/run/ifstate"' IFUPDOWN_IFSTATE_PATH
-
- busybox_config_option pam PAM
- busybox_config_option static STATIC
- busybox_config_option syslog {K,SYS}LOGD LOGGER
- busybox_config_option systemd FEATURE_SYSTEMD
- busybox_config_option math FEATURE_AWK_LIBM
-
- # all the debug options are compiler related, so punt them
- busybox_config_option n DEBUG_SANITIZE
- busybox_config_option n DEBUG
- busybox_config_option y NO_DEBUG_LIB
- busybox_config_option n DMALLOC
- busybox_config_option n EFENCE
- busybox_config_option $(usex debug y n) TFTP_DEBUG
-
- busybox_config_option selinux SELINUX
-
- # this opt only controls mounting with <linux-2.6.23
- busybox_config_option n FEATURE_MOUNT_NFS
-
- # glibc-2.26 and later does not ship RPC implientation
- busybox_config_option n FEATURE_HAVE_RPC
- busybox_config_option n FEATURE_INETD_RPC
-
- # default a bunch of uncommon options to off
- local opt
- for opt in \
- ADD_SHELL \
- BEEP BOOTCHARTD \
- CRONTAB \
- DC DEVFSD DNSD DPKG{,_DEB} \
- FAKEIDENTD FBSPLASH FOLD FSCK_MINIX FTP{GET,PUT} \
- FEATURE_DEVFS \
- HOSTID HUSH \
- INETD INOTIFYD IPCALC \
- LOCALE_SUPPORT LOGNAME LPD \
- MAKEMIME MKFS_MINIX MSH \
- OD \
- RDEV READPROFILE REFORMIME REMOVE_SHELL RFKILL RUN_PARTS RUNSV{,DIR} \
- SLATTACH SMEMCAP SULOGIN SV{,LOGD} \
- TASKSET TCPSVD \
- RPM RPM2CPIO \
- UDPSVD UUDECODE UUENCODE
- do
- busybox_config_option n ${opt}
- done
-
- emake -j1 oldconfig > /dev/null
-}
-
-src_compile() {
- unset KBUILD_OUTPUT #88088
- export SKIP_STRIP=y
-
- emake V=1 busybox
-
- # bug #701512
- emake V=1 doc
-}
-
-src_install() {
- unset KBUILD_OUTPUT #88088
- save_config .config
-
- into /
- dodir /bin
- if use sep-usr ; then
- # install /ginit to take care of mounting stuff
- exeinto /
- newexe busybox_unstripped ginit
- dosym /ginit /bin/bb
- dosym bb /bin/busybox
- else
- newbin busybox_unstripped busybox
- dosym busybox /bin/bb
- fi
- if use mdev ; then
- dodir /$(get_libdir)/mdev/
- use make-symlinks || dosym /bin/bb /sbin/mdev
- cp "${S}"/examples/mdev_fat.conf "${ED}"/etc/mdev.conf || die
- if [[ ! "$(get_libdir)" == "lib" ]]; then
- #831251 - replace lib with lib64 where appropriate
- sed -i -e "s:/lib/:/$(get_libdir)/:g" "${ED}"/etc/mdev.conf || die
- fi
-
- exeinto /$(get_libdir)/mdev/
- doexe "${FILESDIR}"/mdev/*
-
- newinitd "${FILESDIR}"/mdev.initd mdev
- fi
- if use livecd ; then
- dosym busybox /bin/vi
- fi
-
- # add busybox daemon's, bug #444718
- if busybox_config_enabled FEATURE_NTPD_SERVER; then
- newconfd "${FILESDIR}"/ntpd.confd busybox-ntpd
- newinitd "${FILESDIR}"/ntpd.initd busybox-ntpd
- fi
- if busybox_config_enabled SYSLOGD; then
- newconfd "${FILESDIR}"/syslogd.confd busybox-syslogd
- newinitd "${FILESDIR}"/syslogd.initd busybox-syslogd
- fi
- if busybox_config_enabled KLOGD; then
- newconfd "${FILESDIR}"/klogd.confd busybox-klogd
- newinitd "${FILESDIR}"/klogd.initd busybox-klogd
- fi
- if busybox_config_enabled WATCHDOG; then
- newconfd "${FILESDIR}"/watchdog.confd busybox-watchdog
- newinitd "${FILESDIR}"/watchdog.initd busybox-watchdog
- fi
- if busybox_config_enabled UDHCPC; then
- sed -i 's:$((metric++)):$metric; metric=$((metric + 1)):' examples/udhcp/simple.script || die #801535
- local path=$(busybox_config_enabled UDHCPC_DEFAULT_SCRIPT)
- exeinto "${path%/*}"
- newexe examples/udhcp/simple.script "${path##*/}"
- fi
- if busybox_config_enabled UDHCPD; then
- insinto /etc
- doins examples/udhcp/udhcpd.conf
- fi
- if busybox_config_enabled ASH && ! use make-symlinks; then
- dosym -r /bin/busybox /bin/ash
- fi
- if busybox_config_enabled CROND; then
- newconfd "${FILESDIR}"/crond.confd busybox-crond
- newinitd "${FILESDIR}"/crond.initd busybox-crond
- fi
-
- # bundle up the symlink files for use later
- emake DESTDIR="${ED}" install
- # for compatibility, provide /usr/bin/env
- mkdir -p _install/usr/bin || die
- if [[ ! -e _install/usr/bin/env ]]; then
- ln -s /bin/env _install/usr/bin/env || die
- fi
- rm _install/bin/busybox || die
- tar cf busybox-links.tar -C _install . || : #;die
- insinto /usr/share/${PN}
- use make-symlinks && doins busybox-links.tar
-
- dodoc AUTHORS README TODO
-
- cd docs || die
- doman busybox.1
- docinto txt
- dodoc *.txt
- docinto pod
- dodoc *.pod
- docinto html
- dodoc *.html
-
- cd ../examples || die
- docinto examples
- dodoc inittab depmod.pl *.conf *.script undeb unrpm
-
- cd ../networking || die
- dodoc httpd_indexcgi.c httpd_post_upload.cgi
-}
-
-pkg_preinst() {
- if use make-symlinks ; then
- mv "${ED}"/usr/share/${PN}/busybox-links.tar "${T}"/ || die
- fi
-}
-
-pkg_postinst() {
- savedconfig_pkg_postinst
-
- if use make-symlinks ; then
- cd "${T}" || die
- mkdir _install
- tar xf busybox-links.tar -C _install || die
- # 907432: cp -n returns error if it skips any file, but that is expected here
- # TODO: check if a new coreutils release has a replacement option
- cp -nvpPR _install/* "${ROOT}"/
- fi
-
- if use sep-usr ; then
- elog "In order to use the sep-usr support, you have to update your"
- elog "kernel command line. Add the option:"
- elog " init=/ginit"
- elog "To launch a different init than /sbin/init, use:"
- elog " init=/ginit /sbin/yourinit"
- elog "To get a rescue shell, you may boot with:"
- elog " init=/ginit bb"
- fi
-}