summaryrefslogtreecommitdiff
path: root/sys-apps/busybox/busybox-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
commitd934827bf44b7cfcf6711964418148fa60877668 (patch)
tree0625f358789b5e015e49db139cc1dbc9be00428f /sys-apps/busybox/busybox-9999.ebuild
parent2e34d110f164bf74d55fced27fe0000201b3eec5 (diff)
gentoo resync : 25.11.2020
Diffstat (limited to 'sys-apps/busybox/busybox-9999.ebuild')
-rw-r--r--sys-apps/busybox/busybox-9999.ebuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/sys-apps/busybox/busybox-9999.ebuild b/sys-apps/busybox/busybox-9999.ebuild
index bf29c9fb1d87..a82a8aa33318 100644
--- a/sys-apps/busybox/busybox-9999.ebuild
+++ b/sys-apps/busybox/busybox-9999.ebuild
@@ -3,7 +3,7 @@
# See `man savedconfig.eclass` for info on how to use USE=savedconfig.
-EAPI=6
+EAPI=7
inherit flag-o-matic savedconfig toolchain-funcs
@@ -33,7 +33,7 @@ DEPEND="${COMMON_DEPEND}
RDEPEND="${COMMON_DEPEND}
mdev? ( !<sys-apps/openrc-0.13 )"
-S=${WORKDIR}/${MY_P}
+S="${WORKDIR}/${MY_P}"
busybox_config_option() {
local flag=$1 ; shift
@@ -298,7 +298,7 @@ src_install() {
}
pkg_preinst() {
- if use make-symlinks && [[ ! ${VERY_BRAVE_OR_VERY_DUMB} == "yes" ]] && [[ ${ROOT} == "/" ]] ; then
+ if use make-symlinks && [[ ! ${VERY_BRAVE_OR_VERY_DUMB} == "yes" ]] && [[ -z "${ROOT}" ]] ; then
ewarn "setting USE=make-symlinks and emerging to / is very dangerous."
ewarn "it WILL overwrite lots of system programs like: ls bash awk grep (bug 60805 for full list)."
ewarn "If you are creating a binary only and not merging this is probably ok."