summaryrefslogtreecommitdiff
path: root/sys-apps/busybox/busybox-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-24 21:03:24 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-24 21:03:24 +0100
commitcc6fb501ef0f4c443ce79d017dbfbd95072b14f4 (patch)
tree965126ea0cf6b9fb407442ac2be07121864205e4 /sys-apps/busybox/busybox-9999.ebuild
parent59c803bef0bf9b4f167918783e386c3ddb746751 (diff)
gentoo auto-resync : 24:05:2023 - 21:03:24
Diffstat (limited to 'sys-apps/busybox/busybox-9999.ebuild')
-rw-r--r--sys-apps/busybox/busybox-9999.ebuild28
1 files changed, 11 insertions, 17 deletions
diff --git a/sys-apps/busybox/busybox-9999.ebuild b/sys-apps/busybox/busybox-9999.ebuild
index 51f115d22ffb..a9f3d85703c7 100644
--- a/sys-apps/busybox/busybox-9999.ebuild
+++ b/sys-apps/busybox/busybox-9999.ebuild
@@ -3,9 +3,9 @@
# See `man savedconfig.eclass` for info on how to use USE=savedconfig.
-EAPI=7
+EAPI=8
-inherit eapi8-dosym flag-o-matic savedconfig toolchain-funcs
+inherit flag-o-matic savedconfig toolchain-funcs
DESCRIPTION="Utilities for rescue and embedded systems"
HOMEPAGE="https://www.busybox.net/"
@@ -18,10 +18,11 @@ else
SRC_URI="https://www.busybox.net/downloads/${MY_P}.tar.bz2"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
fi
+S="${WORKDIR}/${MY_P}"
LICENSE="GPL-2" # GPL-2 only
SLOT="0"
-IUSE="debug ipv6 livecd make-symlinks math mdev pam selinux sep-usr static syslog systemd"
+IUSE="debug livecd make-symlinks math mdev pam selinux sep-usr static syslog systemd"
REQUIRED_USE="pam? ( !static )"
RESTRICT="test"
@@ -42,8 +43,6 @@ DEPEND="${RDEPEND}
sys-kernel/linux-headers"
BDEPEND="virtual/pkgconfig"
-S="${WORKDIR}/${MY_P}"
-
busybox_config_option() {
local flag=$1 ; shift
if [[ ${flag} != [yn] && ${flag} != \"* ]] ; then
@@ -76,7 +75,9 @@ busybox_config_enabled() {
PATCHES=(
"${FILESDIR}"/${PN}-1.26.2-bb.patch
"${FILESDIR}"/${PN}-1.34.1-skip-selinux-search.patch
- "${FILESDIR}"/${PN}-1.36.0-fix-wx-sections.patch
+
+ "${FILESDIR}"/${PN}-1.36.0-fortify-source-3-fixdep.patch
+
# "${FILESDIR}"/${P}-*.patch
)
@@ -173,14 +174,6 @@ src_configure() {
busybox_config_option '"/run"' PID_FILE_PATH
busybox_config_option '"/run/ifstate"' IFUPDOWN_IFSTATE_PATH
- # disable ipv6 applets
- if ! use ipv6; then
- busybox_config_option n FEATURE_IPV6
- busybox_config_option n TRACEROUTE6
- busybox_config_option n PING6
- busybox_config_option n UDHCPC6
- fi
-
busybox_config_option pam PAM
busybox_config_option static STATIC
busybox_config_option syslog {K,SYS}LOGD LOGGER
@@ -261,7 +254,8 @@ src_install() {
use make-symlinks || dosym /bin/bb /sbin/mdev
cp "${S}"/examples/mdev_fat.conf "${ED}"/etc/mdev.conf || die
if [[ ! "$(get_libdir)" == "lib" ]]; then
- sed -i -e "s:/lib/:/$(get_libdir)/:g" "${ED}"/etc/mdev.conf || die #831251 - replace lib with lib64 where appropriate
+ #831251 - replace lib with lib64 where appropriate
+ sed -i -e "s:/lib/:/$(get_libdir)/:g" "${ED}"/etc/mdev.conf || die
fi
exeinto /$(get_libdir)/mdev/
@@ -301,7 +295,7 @@ src_install() {
doins examples/udhcp/udhcpd.conf
fi
if busybox_config_enabled ASH && ! use make-symlinks; then
- dosym8 -r /bin/busybox /bin/ash
+ dosym -r /bin/busybox /bin/ash
fi
if busybox_config_enabled CROND; then
newconfd "${FILESDIR}"/crond.confd busybox-crond
@@ -310,12 +304,12 @@ src_install() {
# bundle up the symlink files for use later
emake DESTDIR="${ED}" install
- rm _install/bin/busybox || die
# for compatibility, provide /usr/bin/env
mkdir -p _install/usr/bin || die
if [[ ! -e _install/usr/bin/env ]]; then
ln -s /bin/env _install/usr/bin/env || die
fi
+ rm _install/bin/busybox || die
tar cf busybox-links.tar -C _install . || : #;die
insinto /usr/share/${PN}
use make-symlinks && doins busybox-links.tar