summaryrefslogtreecommitdiff
path: root/sys-apps/busybox/busybox-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-04-28 20:02:04 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-04-28 20:02:04 +0100
commita4e2a46beb5e4858ef27bdedbb0ff6d2ced430ad (patch)
tree852c90a4bf354c30ea66504f70bfab5401fba18d /sys-apps/busybox/busybox-9999.ebuild
parent5e8702bcbbed438e6c6cce023e7ef0cc9baa3e02 (diff)
gentoo resync : 28.04.2018
Diffstat (limited to 'sys-apps/busybox/busybox-9999.ebuild')
-rw-r--r--sys-apps/busybox/busybox-9999.ebuild15
1 files changed, 10 insertions, 5 deletions
diff --git a/sys-apps/busybox/busybox-9999.ebuild b/sys-apps/busybox/busybox-9999.ebuild
index 68000bffa174..f28bf04dfd72 100644
--- a/sys-apps/busybox/busybox-9999.ebuild
+++ b/sys-apps/busybox/busybox-9999.ebuild
@@ -3,8 +3,9 @@
# See `man savedconfig.eclass` for info on how to use USE=savedconfig.
-EAPI="5"
-inherit eutils flag-o-matic savedconfig toolchain-funcs multilib
+EAPI=6
+
+inherit flag-o-matic savedconfig toolchain-funcs
DESCRIPTION="Utilities for rescue and embedded systems"
HOMEPAGE="https://www.busybox.net/"
@@ -62,14 +63,18 @@ busybox_config_enabled() {
esac
}
+# patches go here!
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.26.2-bb.patch
+ # "${FILESDIR}"/${P}-*.patch
+)
+
src_prepare() {
+ default
unset KBUILD_OUTPUT #88088
append-flags -fno-strict-aliasing #310413
use ppc64 && append-flags -mminimal-toc #130943
- # patches go here!
- epatch "${FILESDIR}"/${PN}-1.26.2-bb.patch
-# epatch "${FILESDIR}"/${P}-*.patch
cp "${FILESDIR}"/ginit.c init/ || die
# flag cleanup