summaryrefslogtreecommitdiff
path: root/sys-apps/bubblewrap
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-10-22 11:09:47 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-10-22 11:09:47 +0100
commit64e107b9b6058580ff0432107eb37cefb0b2a7d8 (patch)
tree9a44e603e2ae365e2b1fe35ac37f73e830cdee1d /sys-apps/bubblewrap
parent957235cf19a691360c720f7913672adda4258ed0 (diff)
gentoo resync : 22.10.2018
Diffstat (limited to 'sys-apps/bubblewrap')
-rw-r--r--sys-apps/bubblewrap/Manifest3
-rw-r--r--sys-apps/bubblewrap/bubblewrap-0.3.1.ebuild45
-rw-r--r--sys-apps/bubblewrap/metadata.xml11
3 files changed, 59 insertions, 0 deletions
diff --git a/sys-apps/bubblewrap/Manifest b/sys-apps/bubblewrap/Manifest
new file mode 100644
index 000000000000..93e1fd6e357a
--- /dev/null
+++ b/sys-apps/bubblewrap/Manifest
@@ -0,0 +1,3 @@
+DIST bubblewrap-0.3.1.tar.gz 62768 BLAKE2B a8c29102f9b69bfbd6b6aebb9aa0878bd1e31b52a6cb6374b8341c1410526872d4063ff0524ab4f98d7cac7358dad3190144d12bb0b11cf26eeed2730c4ec475 SHA512 fbc44976f53fdf8913b94c57d1f26a3b87c773e86a289e58fd3d7b1c4ea7f33c862f1a38a4f791315358990928768a68334f0a171302c18a16c7e2e9f1a146dd
+EBUILD bubblewrap-0.3.1.ebuild 1020 BLAKE2B 929f69c3a456c30f581dd393e3c3cb919c0026d6d71a03ecec19f05de48e423a4758692a5ba9328279062724f06c159a8b41973cbb270bc017db75e0182c2d13 SHA512 bb7421b23f7eef4890779fc716cf2c5a76ccd1824f58f2172db3f77158b2f048968df100796c7da310983ff47b62aa743f2ac61dac19ecc7ed5395ef332c1f67
+MISC metadata.xml 342 BLAKE2B de8d3ba1c95b39bd6e582b27b186ef0805fd9be1fe6c806fb8bcfa28f7cafb3a2068be0e21baa13ca08895db0d0b666b5c1eab573f38fac251ce9d41c793866e SHA512 25752c1aae465ac49409e35c32863b945c1dc8989ddb4fab2999cf890cf4ec33fc82e9324e3af49c15a8580a566e5f737ec270646b4cc569c3c5dd472eb1b2bb
diff --git a/sys-apps/bubblewrap/bubblewrap-0.3.1.ebuild b/sys-apps/bubblewrap/bubblewrap-0.3.1.ebuild
new file mode 100644
index 000000000000..6a54ac1e8458
--- /dev/null
+++ b/sys-apps/bubblewrap/bubblewrap-0.3.1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit autotools bash-completion-r1 linux-info
+
+DESCRIPTION="Unprivileged sandboxing tool, namespaces-powered chroot-like solution"
+HOMEPAGE="https://github.com/projectatomic/bubblewrap"
+SRC_URI="https://github.com/projectatomic/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2+"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="selinux"
+
+DEPEND="
+ dev-libs/libxslt
+ sys-libs/libseccomp
+ sys-libs/libcap
+ selinux? ( >=sys-libs/libselinux-2.1.9 )
+"
+# FIXME: we don't need bashcomp righ??
+RDEPEND="${DEPEND}"
+# FIXME: bash comp is not working
+# FIXME: test is not working
+pkg_setup() {
+ if [[ ${MERGE_TYPE} != buildonly ]]; then
+ CONFIG_CHECK="~UTS_NS ~IPC_NS ~USER_NS ~PID_NS ~NET_NS"
+ linux-info_pkg_setup
+ fi
+}
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+
+ econf \
+ $(use_enable selinux) \
+ "--enable-man" \
+ "--with-bash-completion-dir=${get_bashcompdir}" \
+ "--with-priv-mode=none"
+}
diff --git a/sys-apps/bubblewrap/metadata.xml b/sys-apps/bubblewrap/metadata.xml
new file mode 100644
index 000000000000..29a569e6d411
--- /dev/null
+++ b/sys-apps/bubblewrap/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>gnome@gentoo.org</email>
+ <name>Gentoo GNOME Desktop</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">projectatomic/bubblewrap</remote-id>
+ </upstream>
+</pkgmetadata>