summaryrefslogtreecommitdiff
path: root/sys-apps/bubblewrap/bubblewrap-0.5.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /sys-apps/bubblewrap/bubblewrap-0.5.0.ebuild
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'sys-apps/bubblewrap/bubblewrap-0.5.0.ebuild')
-rw-r--r--sys-apps/bubblewrap/bubblewrap-0.5.0.ebuild46
1 files changed, 0 insertions, 46 deletions
diff --git a/sys-apps/bubblewrap/bubblewrap-0.5.0.ebuild b/sys-apps/bubblewrap/bubblewrap-0.5.0.ebuild
deleted file mode 100644
index 6f58a64f538b..000000000000
--- a/sys-apps/bubblewrap/bubblewrap-0.5.0.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit bash-completion-r1 linux-info
-
-DESCRIPTION="Unprivileged sandboxing tool, namespaces-powered chroot-like solution"
-HOMEPAGE="https://github.com/containers/bubblewrap/"
-SRC_URI="https://github.com/containers/${PN}/releases/download/v${PV}/${P}.tar.xz"
-
-LICENSE="LGPL-2+"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 ppc ppc64 ~riscv x86"
-IUSE="selinux +suid"
-
-RDEPEND="
- sys-libs/libseccomp
- sys-libs/libcap
- selinux? ( >=sys-libs/libselinux-2.1.9 )
-"
-DEPEND="${RDEPEND}"
-BDEPEND="
- app-text/docbook-xml-dtd:4.3
- app-text/docbook-xsl-stylesheets
- dev-libs/libxslt
- virtual/pkgconfig
-"
-
-# tests require root priviledge
-RESTRICT="test"
-
-pkg_setup() {
- if [[ ${MERGE_TYPE} != buildonly ]]; then
- CONFIG_CHECK="~UTS_NS ~IPC_NS ~USER_NS ~PID_NS ~NET_NS"
- linux-info_pkg_setup
- fi
-}
-
-src_configure() {
- econf \
- $(use_enable selinux) \
- "--enable-man" \
- "--with-bash-completion-dir=$(get_bashcompdir)" \
- "--with-priv-mode=$(usex suid setuid none)"
-}