summaryrefslogtreecommitdiff
path: root/sys-apps/bolt/bolt-0.8.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-07-14 11:04:34 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-07-14 11:04:34 +0100
commitdd762ff83c330186ee2ede002e08b2f780cddd51 (patch)
tree63198edcc3ad5df8e2566c28ff9bd8af50cc2174 /sys-apps/bolt/bolt-0.8.ebuild
parent51af5f0eb4cddbe6aa7953717873691d77aae9ff (diff)
gentoo resync : 14.07.2019
Diffstat (limited to 'sys-apps/bolt/bolt-0.8.ebuild')
-rw-r--r--sys-apps/bolt/bolt-0.8.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/sys-apps/bolt/bolt-0.8.ebuild b/sys-apps/bolt/bolt-0.8.ebuild
new file mode 100644
index 000000000000..28823c01d33e
--- /dev/null
+++ b/sys-apps/bolt/bolt-0.8.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit meson systemd
+
+DESCRIPTION="Userspace system daemon to enable security levels for Thunderbolt 3."
+HOMEPAGE="https://gitlab.freedesktop.org/bolt/bolt"
+SRC_URI="https://gitlab.freedesktop.org/${PN}/${PN}/-/archive/${PV}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="doc systemd"
+
+DEPEND="
+ >=dev-libs/glib-2.50.0:2
+ dev-util/glib-utils
+ virtual/libudev
+ virtual/udev
+ dev-util/umockdev
+ sys-auth/polkit[introspection]
+ systemd? ( sys-apps/systemd:0= )
+ doc? ( app-text/asciidoc )"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local emesonargs=(
+ -Dman=$(usex doc true false)
+ --sysconfdir=/etc
+ --localstatedir=/var
+ --sharedstatedir=/var/lib
+ -Dsystemd=$(usex systemd true false)
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+ keepdir /var/lib/boltd
+}