summaryrefslogtreecommitdiff
path: root/sys-apps/bleachbit
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-01-22 20:28:19 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-01-22 20:28:19 +0000
commitabaa75b10f899ada8dd05b23cc03205064394bc6 (patch)
treeeca3dd248b73b92013cba00a0fcc1edf2696e19a /sys-apps/bleachbit
parent24fd814c326e282c4321965c31f341dad77e270d (diff)
gentoo resync : 22.01.2021
Diffstat (limited to 'sys-apps/bleachbit')
-rw-r--r--sys-apps/bleachbit/Manifest2
-rw-r--r--sys-apps/bleachbit/bleachbit-4.2.0.ebuild82
2 files changed, 84 insertions, 0 deletions
diff --git a/sys-apps/bleachbit/Manifest b/sys-apps/bleachbit/Manifest
index 51d21590dba5..43a2d731565b 100644
--- a/sys-apps/bleachbit/Manifest
+++ b/sys-apps/bleachbit/Manifest
@@ -1,3 +1,5 @@
DIST bleachbit-4.0.0.tar.bz2 599756 BLAKE2B 05a4dbf9e0b6bbcba528875a82e36eb9f91ae84c5bdc6f8f69063a54bd192332f5dd1d22ee5a737243eb5fb74cf0362eace1b50a73f7c1d0557a8cba146dea01 SHA512 ce120239b411c6e177af0e22a16b583ac3ae8903ba13579878942492e4e221355da28f737d6c78811312bfcc888af7c8dba6c153673f4e1542cc2aceedf2d2c9
+DIST bleachbit-4.2.0.tar.bz2 606223 BLAKE2B c45a11db556b9c3e3a19583bfaa633244e2ea2e374ec8b883cba486126cfb33617cd7930af79d379711980ad4b56426b39a3e68532462be1918da1386369d137 SHA512 6d43da42c6a2a328c8fb766a3f00f4511e72a00836316c279c8dc3a24468abb4c2ce909b42c568ee0b8417c08827c7cb79ae197ae693b8d6ce60faf22422effb
EBUILD bleachbit-4.0.0.ebuild 1482 BLAKE2B 070e66a4c002c3a47f4987e9b000a5d78e05dc41ba3b597cf91e4100da9c6811ee39fccf1ada4bc703b70e9e156690a58181ddad754f1427be681bcbd2213733 SHA512 b860352fbe80dbe550646de268cfc73fcc96cde4fc90153314fcaf53b03eef2f213342612de6f76fc58b24f69406fc2af3b1e1577b6055c8de5eeff8af47d310
+EBUILD bleachbit-4.2.0.ebuild 1644 BLAKE2B e0ce7f3565f2300f1cc151bcf575de7b1c104e7ed5271744d29411d09784c8bac683bdac3587a4ce711f3bbeca9df4a430ec5d8d7364b623f85480691ff647a6 SHA512 03ba6a6ce72c9569567644f60197cb081cb1aae8762cfa23448f0f247645fd88c5505c567689fc3f6f44a9805bfcf3e36e0e2aeeae8e7660ec97fc93ab27dc0e
MISC metadata.xml 526 BLAKE2B f55f30792d579d5fc57553b3aa8a8f97d450778a1813c53e82a0fea4cc01fe3039d249ed89c8097a973c1bd923390e3bd1b85ae1a1d2386ab3373a9baae08623 SHA512 d2179dee28e6bacaa540039b726eb5ab47b87abc73a5c86621de3230f3d6355d082e8189c9e167871fb8c15975815341ce02bbef80195b984728c3b1b0652bf1
diff --git a/sys-apps/bleachbit/bleachbit-4.2.0.ebuild b/sys-apps/bleachbit/bleachbit-4.2.0.ebuild
new file mode 100644
index 000000000000..c3523862ab44
--- /dev/null
+++ b/sys-apps/bleachbit/bleachbit-4.2.0.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8,9} )
+PYTHON_REQ_USE="sqlite(+)"
+DISTUTILS_SINGLE_IMPL=1
+
+inherit desktop distutils-r1 virtualx
+
+DESCRIPTION="Clean junk to free disk space and to maintain privacy"
+HOMEPAGE="https://www.bleachbit.org"
+SRC_URI="https://download.bleachbit.org/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ $(python_gen_cond_dep '
+ dev-python/chardet[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ ')
+"
+BDEPEND="
+ sys-devel/gettext
+ test? (
+ $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]')
+ )
+"
+
+distutils_enable_tests unittest
+
+# tests fail under FEATURES=usersandbox
+RESTRICT="test"
+
+python_prepare_all() {
+ if use test; then
+ # avoid tests requiring internet access
+ rm tests/Test{Chaff,Update}.py || die
+
+ # fails due to non-existent $HOME/.profile
+ rm tests/TestInit.py || die
+
+ # these fail on upstream Travis CI as well as on Gentoo
+ sed -e "s/test_notify(self)/_&/" \
+ -i tests/TestGUI.py || die
+
+ sed -e "s/test_get_proc_swaps(self)/_&/" \
+ -i tests/TestMemory.py || die
+ fi
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ emake -C po local
+}
+
+python_test() {
+ virtx emake tests
+}
+
+python_install() {
+ distutils-r1_python_install
+ python_newscript ${PN}.py ${PN}
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ emake -C po DESTDIR="${D}" install
+
+ insinto /usr/share/bleachbit/cleaners
+ doins cleaners/*.xml
+
+ insinto /usr/share/bleachbit
+ doins data/app-menu.ui
+
+ doicon ${PN}.png
+ domenu org.${PN}.BleachBit.desktop
+}