summaryrefslogtreecommitdiff
path: root/sys-apps/bleachbit
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-11-22 23:21:15 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-11-22 23:21:15 +0000
commit40d8bc05c536b6c3fa0bd58c50480dc79c6b9e92 (patch)
tree390b30b3f1aea86e16973b82eb5fa14406fcab7f /sys-apps/bleachbit
parentfd87b7c771378b2116981e3924bee5805148e118 (diff)
gentoo auto-resync : 22:11:2023 - 23:21:15
Diffstat (limited to 'sys-apps/bleachbit')
-rw-r--r--sys-apps/bleachbit/Manifest2
-rw-r--r--sys-apps/bleachbit/bleachbit-4.6.0.ebuild87
2 files changed, 89 insertions, 0 deletions
diff --git a/sys-apps/bleachbit/Manifest b/sys-apps/bleachbit/Manifest
index fc9c38903d3c..bc89f09d46ec 100644
--- a/sys-apps/bleachbit/Manifest
+++ b/sys-apps/bleachbit/Manifest
@@ -1,3 +1,5 @@
DIST bleachbit-4.4.2.tar.bz2 653525 BLAKE2B ae65e310d33c2e523244a32de1ff28081be940a6a2ed2aadf682218ebe7346de3b5f37ab457d4f16542730d617678effbcda461e7080c43cd81c17f6b959018d SHA512 247a1ed0e491e5e02c4bc9a5c2d11d5f1511ef9644b9edf34b1c9326e6515c33dfd60b98bb2dab59eac36ab5e1c9b5ed1e8d7c749261bde90450a2fc717dae6f
+DIST bleachbit-4.6.0.tar.bz2 667238 BLAKE2B c150ef9ff5c5f3d8241c5d8a8b8ad5b3f7a23aef24c21ef67a8680f56f3844893fd0e8513f47936ac3a667a15f0d6df2186658be282846309f3ad79f545a380d SHA512 fd0888195bc1fd6dfdc19ca4b35906554e0b6bf22c7f12db01ff8a5790a8a358aedd39f0c0906eb98e67ea5344c655e7f042516cc0c17b59637463d01927a33a
EBUILD bleachbit-4.4.2-r1.ebuild 1784 BLAKE2B e2edd231e5559fc48b88eb54a08745ff3fa5c6b42c2ba1d9d7a130ec8c10f2cd55f591c1a72b4094c311a82a0e6a26be5a39799810cb615329fc092901639129 SHA512 e58472a468efd65203197bd87386284f75dcd4476a257fc35c09f27131c39d9d8ed577e6549b753ce837c22074074da56fa32e346cbe15c10e20cb962b4b946f
+EBUILD bleachbit-4.6.0.ebuild 1787 BLAKE2B 95eac6d103b422632880026139972c8490958fd450096ac84195d6e5081df4b43e4c0f2680862019edf837790bbd2bae5e7bd3f7d0f48a06f5ffdf8c553c38c7 SHA512 44a608ad5f5c438d93d159319009a7f6cc37ffdc8719fc31afb01a379b2381a93e093f44772ef52e9e9295b562e38f42a2496eac5b476582d0be4cb7e44b316b
MISC metadata.xml 557 BLAKE2B 61de1eec1e533aea9a008403d40069d8e7fb3ca2e1217f1ebf8746adf07725bf82011ee6597961443e6474de9908e3b8a70a6aef42439b4aa62a562212846378 SHA512 dc31e0aa896798f20540c5f7119aa7cf60a8ec5e498d8a7a7baf3d73b5287b03083e33f0816d84467acfc221d8bf0dfdeea59734b3048e4194693d63ec453214
diff --git a/sys-apps/bleachbit/bleachbit-4.6.0.ebuild b/sys-apps/bleachbit/bleachbit-4.6.0.ebuild
new file mode 100644
index 000000000000..a0c5f395e430
--- /dev/null
+++ b/sys-apps/bleachbit/bleachbit-4.6.0.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+PYTHON_REQ_USE="sqlite(+)"
+DISTUTILS_SINGLE_IMPL=1
+
+inherit desktop distutils-r1 virtualx
+
+DESCRIPTION="Clean junk to free disk space and to maintain privacy"
+HOMEPAGE="https://www.bleachbit.org"
+SRC_URI="https://download.bleachbit.org/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ $(python_gen_cond_dep '
+ dev-python/chardet[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ ')
+ x11-libs/gtk+:3
+"
+BDEPEND="
+ sys-devel/gettext
+ test? (
+ $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]')
+ )
+"
+
+distutils_enable_tests unittest
+
+# tests fail under FEATURES=usersandbox
+RESTRICT="test"
+
+python_prepare_all() {
+ if use test; then
+ # avoid tests requiring internet access
+ rm tests/Test{Chaff,Update}.py || die
+
+ # fails due to non-existent $HOME/.profile
+ rm tests/TestInit.py || die
+
+ # only applicable to Windows installer
+ rm tests/TestNsisUtilities.py || die
+
+ # these fail on upstream Travis CI as well as on Gentoo
+ sed -e "s/test_notify(self)/_&/" \
+ -i tests/TestGUI.py || die
+
+ sed -e "s/test_get_proc_swaps(self)/_&/" \
+ -i tests/TestMemory.py || die
+ fi
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ emake -C po local
+}
+
+python_test() {
+ virtx emake tests
+}
+
+python_install() {
+ distutils-r1_python_install
+ python_newscript ${PN}.py ${PN}
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ emake -C po DESTDIR="${D}" install
+
+ insinto /usr/share/bleachbit/cleaners
+ doins cleaners/*.xml
+
+ insinto /usr/share/bleachbit
+ doins data/app-menu.ui
+
+ doicon ${PN}.png
+ domenu org.${PN}.BleachBit.desktop
+}