summaryrefslogtreecommitdiff
path: root/sys-apps/bfs/bfs-3.1.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-03-02 05:41:39 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-03-02 05:41:39 +0000
commita4036575de835600b3085b97974d0766ef7c7bc2 (patch)
tree545e8444bbb80f76c5faf48f8fef3719b931fd44 /sys-apps/bfs/bfs-3.1.2.ebuild
parent1331637681273dc8391d7a7caa6175405dceb735 (diff)
gentoo auto-resync : 02:03:2024 - 05:41:39
Diffstat (limited to 'sys-apps/bfs/bfs-3.1.2.ebuild')
-rw-r--r--sys-apps/bfs/bfs-3.1.2.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/sys-apps/bfs/bfs-3.1.2.ebuild b/sys-apps/bfs/bfs-3.1.2.ebuild
new file mode 100644
index 000000000000..ba8cd9bde472
--- /dev/null
+++ b/sys-apps/bfs/bfs-3.1.2.ebuild
@@ -0,0 +1,46 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit flag-o-matic toolchain-funcs
+
+DESCRIPTION="Breadth-first version of the UNIX find command"
+HOMEPAGE="https://tavianator.com/projects/bfs.html"
+SRC_URI="https://github.com/tavianator/bfs/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="0BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~sparc"
+IUSE="acl caps debug io-uring unicode xattr"
+
+DEPEND="
+ acl? ( virtual/acl )
+ caps? ( sys-libs/libcap )
+ io-uring? ( sys-libs/liburing:= )
+ unicode? ( dev-libs/oniguruma:= )
+ xattr? ( sys-apps/attr )
+"
+RDEPEND="${DEPEND}"
+
+bfsmake() {
+ emake \
+ USE_ACL=$(usev acl '1') \
+ USE_ATTR=$(usev xattr '1') \
+ USE_LIBCAP=$(usev caps '1') \
+ USE_LIBURING=$(usev io-uring '1') \
+ USE_ONIGURUMA=$(usev unicode '1') \
+ "$@"
+}
+
+src_compile() {
+ tc-export CC
+ use debug || append-cppflags -DNDEBUG
+
+ bfsmake
+}
+
+src_test() {
+ # -n check gets confused so need manual src_test definition?
+ bfsmake check
+}