summaryrefslogtreecommitdiff
path: root/sys-apps/attr
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-01-10 05:25:01 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-01-10 05:25:01 +0000
commit456dbeaab3e2f71f527eae542ab44d1e372b0655 (patch)
tree5cee708ec6e4b4e530a4337e7389598dc7cd6144 /sys-apps/attr
parent65737cf14a7220bd9a487aa2af4ae0e79bd23e86 (diff)
gentoo resync : 10.01.2018
Diffstat (limited to 'sys-apps/attr')
-rw-r--r--sys-apps/attr/Manifest2
-rw-r--r--sys-apps/attr/attr-2.4.48.ebuild55
2 files changed, 57 insertions, 0 deletions
diff --git a/sys-apps/attr/Manifest b/sys-apps/attr/Manifest
index 4040ba05544c..adbb28fbba3a 100644
--- a/sys-apps/attr/Manifest
+++ b/sys-apps/attr/Manifest
@@ -1,3 +1,5 @@
DIST attr-2.4.47.src.tar.gz 343692 BLAKE2B af4d509f156cb2e693f0faebf1a6cfb4a27cbdd3fd7f8b436cc01419c905ff9ac36214ada2ca8269e49c2e276917b1178dcda97050cf25cecd65382f22bdf9bb SHA512 2a333f63655758298650cf8f89c175efdc0112dcc4013e8d023e2a9a69f177e4bcb1f1d10b6666d6f2027dca4dec0833d54749952ab153d28367e1a72e6e2831
+DIST attr-2.4.48.tar.xz 346292 BLAKE2B eeffc17bf485749b5d0a1fce4ac3702c33a0bacce3ad635400e8b0b52981f14c5e750ef570f8fd19657e460e51e6e09f972134ef8a3e6efc15c2a7203682df75 SHA512 78b8160303aec9e01f63b5cf725a9e16432ff1d4a6e0065ce1a52715ae1266572e0c01f9be25c938c484deea288fdff2ce27981c3aea578753ad854084957e8b
EBUILD attr-2.4.47-r2.ebuild 1849 BLAKE2B 85b4f61c38d025e9f00d95afc3272b02d0c39b191414f462477c23478eee13f26cd92a5266ca06a9ba350928de64606a41947dee125fa6fada542c0c05b1c2fc SHA512 23f6808bedd1beb0267c81a60703cedebb3c64ebf5c27f5846aec20cc1187bd75a5e13a35a91c802abbd6f97b30f16e806d2569513a4b4f58a73ddbb213485ee
+EBUILD attr-2.4.48.ebuild 1363 BLAKE2B 8d1f59de3de05c9ac029024e46e13a513cbde27a268e4850f7c607c0821fb2b551d58ac0a79ceb6631d07e28c396c4783d0fe7d6724a13dabfd92bcdb486e1c3 SHA512 80681f32456ecf7cc48a571c4c2127a8f0e6e146ce95563b90adb9c21ec8867f1892c4631c5b365870938f5cbb961ffcbd05a867a4d133d8bc9ec64303517371
MISC metadata.xml 253 BLAKE2B 295e9d6d93aaa12af413972e1590c67087801cc09c9aa6b59d4606c0f4106d1dacf2baa9858559083b4c6d91beeef218d0729e8593a33788958da6d2897e8ce2 SHA512 54a9069aeb4165d2dff3d473c8001bc51613aac9dff3f7f5e9971a9891a737a31511ffa11cbd523febe581ac1d9de2bdf2f40410f0c4239138f2ccca3ef15555
diff --git a/sys-apps/attr/attr-2.4.48.ebuild b/sys-apps/attr/attr-2.4.48.ebuild
new file mode 100644
index 000000000000..086cfe28d390
--- /dev/null
+++ b/sys-apps/attr/attr-2.4.48.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit libtool ltprune toolchain-funcs multilib-minimal
+
+DESCRIPTION="Extended attributes tools"
+HOMEPAGE="https://savannah.nongnu.org/projects/attr"
+# Self-hosting as savannah does not provide a tarball on their download
+# area and the tarball in their git repo requires autoreconf to be run.
+SRC_URI="https://dev.gentoo.org/~polynomial-c/dist/${P}.tar.xz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~arm-linux ~x86-linux"
+IUSE="debug static-libs"
+
+DEPEND="
+ sys-devel/autoconf
+ sys-devel/gettext
+"
+
+src_prepare() {
+ default
+ elibtoolize #580792
+}
+
+multilib_src_configure() {
+ unset PLATFORM #184564
+ export OPTIMIZER=${CFLAGS}
+ export DEBUG=-DNDEBUG
+
+ local myeconfargs=(
+ --bindir="${EPREFIX}"/bin
+ --enable-shared $(use_enable static-libs static)
+ --libexecdir="${EPREFIX}"/usr/$(get_libdir)
+ $(use_enable debug)
+ )
+ ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
+}
+
+multilib_src_install() {
+ emake DESTDIR="${D}" install
+
+ if multilib_is_native_abi; then
+ # we install attr into /bin, so we need the shared lib with it
+ gen_usr_ldscript -a attr
+ fi
+}
+
+multilib_src_install_all() {
+ use static-libs || prune_libtool_files --all
+ einstalldocs
+}