summaryrefslogtreecommitdiff
path: root/sys-apps/attr/attr-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /sys-apps/attr/attr-9999.ebuild
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'sys-apps/attr/attr-9999.ebuild')
-rw-r--r--sys-apps/attr/attr-9999.ebuild44
1 files changed, 26 insertions, 18 deletions
diff --git a/sys-apps/attr/attr-9999.ebuild b/sys-apps/attr/attr-9999.ebuild
index 58d5e41c2738..c8051fdd82e4 100644
--- a/sys-apps/attr/attr-9999.ebuild
+++ b/sys-apps/attr/attr-9999.ebuild
@@ -1,30 +1,34 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="7"
+EAPI=8
-inherit flag-o-matic libtool toolchain-funcs multilib-minimal usr-ldscript
+# autotools inherit only needed for 2.5.1-r1 patch for symvers
+# hopefully in next release
+inherit autotools flag-o-matic toolchain-funcs multilib-minimal usr-ldscript
if [[ ${PV} == 9999 ]] ; then
EGIT_REPO_URI="https://git.savannah.gnu.org/git/${PN}.git"
-
inherit autotools git-r3
else
+ inherit libtool
+
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
SRC_URI="mirror://nongnu/${PN}/${P}.tar.xz"
fi
DESCRIPTION="Extended attributes tools"
HOMEPAGE="https://savannah.nongnu.org/projects/attr"
+
LICENSE="LGPL-2.1"
SLOT="0"
-
IUSE="debug nls static-libs"
-BDEPEND="
- sys-devel/binutils
- nls? ( sys-devel/gettext )
-"
+BDEPEND="nls? ( sys-devel/gettext )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.5.1-fix-symver.patch
+)
src_prepare() {
default
@@ -34,35 +38,38 @@ src_prepare() {
eautopoint
eautoreconf
else
- elibtoolize #580792
+ # bug #580792
+ #elibtoolize
+
+ # Temporarily for 2.5.1-r1 for symver patch
+ eautoreconf
fi
}
src_configure() {
- # Remove -flto* from flags as this breaks binaries (bug #644048)
- filter-flags -flto*
- append-ldflags "-Wl,--no-gc-sections" #700116
- tc-ld-force-bfd #644048
- append-lfs-flags #760857
+ # bug #760857
+ append-lfs-flags
+
multilib-minimal_src_configure
}
multilib_src_configure() {
local myeconfargs=(
--bindir="${EPREFIX}"/bin
+ --libexecdir="${EPREFIX}"/usr/$(get_libdir)
--enable-shared
$(use_enable static-libs static)
$(use_enable nls)
- --libexecdir="${EPREFIX}"/usr/$(get_libdir)
$(use_enable debug)
)
+
ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
}
multilib_src_install() {
emake DESTDIR="${D}" install
- # Sanity check until we track down why this is happening. #644048
+ # Sanity check until we track down why this is happening. bug #644048
local lib="${ED}/usr/$(get_libdir)/libattr.so.1"
if [[ -e ${lib} ]] ; then
local versions=$($(tc-getREADELF) -V "${lib}")
@@ -76,18 +83,19 @@ multilib_src_install() {
echo "${versions}"
echo "# readelf -sW ${lib}"
echo "${symbols}"
- die "symbol version sanity check failed; please comment on https://bugs.gentoo.org/644048"
+ die "Symbol version sanity check failed; please comment on https://bugs.gentoo.org/644048"
else
einfo "${lib} passed symbol checks"
fi
fi
if multilib_is_native_abi; then
- # we install attr into /bin, so we need the shared lib with it
+ # We install attr into /bin, so we need the shared lib with it
gen_usr_ldscript -a attr
fi
# Add a wrapper until people upgrade.
+ # TODO: figure out when this was added & when we can drop it!
insinto /usr/include/attr
newins "${FILESDIR}"/xattr-shim.h xattr.h
}