summaryrefslogtreecommitdiff
path: root/sys-apps/asahi-scripts
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-02-24 17:40:43 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-02-24 17:40:43 +0000
commit24ee8c58752f0dc4376961a28f7364e6d7c7a7aa (patch)
tree0a71618e774dce4efc0ddc7808557a03925de8d9 /sys-apps/asahi-scripts
parenta625efe29cec7f7c437cf33a956ea99eed1e4bd9 (diff)
gentoo auto-resync : 24:02:2024 - 17:40:43
Diffstat (limited to 'sys-apps/asahi-scripts')
-rw-r--r--sys-apps/asahi-scripts/Manifest5
-rw-r--r--sys-apps/asahi-scripts/asahi-scripts-20231219.1.ebuild46
-rw-r--r--sys-apps/asahi-scripts/files/makefile.patch6
-rw-r--r--sys-apps/asahi-scripts/files/update-m1n1-dtbs.patch13
-rw-r--r--sys-apps/asahi-scripts/metadata.xml14
5 files changed, 84 insertions, 0 deletions
diff --git a/sys-apps/asahi-scripts/Manifest b/sys-apps/asahi-scripts/Manifest
new file mode 100644
index 000000000000..82fb8d394c3c
--- /dev/null
+++ b/sys-apps/asahi-scripts/Manifest
@@ -0,0 +1,5 @@
+AUX makefile.patch 175 BLAKE2B e1858dec75b6d5b285c689ea2ce5187dbbda54b3cb3f72f3df29db7dc6133f57c5a361cdb493f0fe4ea624cda5e997f102840708111ef1b3aa682c92c1610342 SHA512 805d04d990698e1bdff54433ce4eeca0e45bc4a5cde1f3b539dabe2ee48f9dda49ff1a75e4ddc08e4f335ca99a5216d41fd0232f9771732996689446614a4ffc
+AUX update-m1n1-dtbs.patch 399 BLAKE2B 610da1ca6ba4cc0d465b9c998a6a5a47931db6d0660539eabe2e6b4e73cf2fc235bccb2b30305415a8c33f5f2553e77869cfa34448e49b9c29eb2a3a99ca46f4 SHA512 3ad9fbf771a2d26b60f496c433f45495ace0d60317934221fe829a74c8621d7e13d85d3f26085aab2a44c00dc2ab8e91afbb222eba8c4d1c8526f681a4096304
+DIST asahi-scripts-20231219.1.tar.gz 10696 BLAKE2B 1a3103f093fa87f33f7bdc64340dbd61705ac88832b1a9a2cb015ae8ff7ccfc138b91d0f38505dcdb916ccef03a0f788dd2bbaac66fc32118ce8acb536791bdd SHA512 ab4462bd8b98558f57a1edb4ac9fb21535e6a2b8396f6774a3ea1160ad2de4f64ffb65a93d08e6112ea2d90050a1a368fd32d8a6e5b0d7a545961c57ac9d0639
+EBUILD asahi-scripts-20231219.1.ebuild 1276 BLAKE2B 8a7f1cc306006466bcd584a391981c05f6dea6772f2092457188532b36d9b5b82af3bcd7c85153220a3224aff66a953586d49b58d89d7e91239fa237f3ec715b SHA512 d8b99769245151ab4c1fda94e5e26819a06e36ec6ad9eebcfef355a22a10fb18f26648f505a4acd56dea9a3d28c875ea7d0ff231588790926f00e013195243c4
+MISC metadata.xml 423 BLAKE2B 4bfaa21a10fe7fd713795044151c993a1ac6bec3d266ee60ff2713e8856d19a85d3bea0806ed7f3382aa58fe7388732478ce518668f131637a8758233829adbc SHA512 1fde5b23da68b00da65f6f3c7ed2510247b6e05828d3b5b66a48e01ee8b7e6565d7b39778da42a3059ed15a5af13c4f732eb8c70cc9d30b7e617c80913956a33
diff --git a/sys-apps/asahi-scripts/asahi-scripts-20231219.1.ebuild b/sys-apps/asahi-scripts/asahi-scripts-20231219.1.ebuild
new file mode 100644
index 000000000000..4e4b1fe2eda2
--- /dev/null
+++ b/sys-apps/asahi-scripts/asahi-scripts-20231219.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+DESCRIPTION="Apple Silicon support scripts"
+HOMEPAGE="https://asahilinux.org/"
+SRC_URI="https://github.com/AsahiLinux/${PN}/archive/refs/tags/${PV}.tar.gz -> ${PN}-${PV}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~arm64"
+
+PATCHES=(
+ "${FILESDIR}/makefile.patch"
+ "${FILESDIR}/update-m1n1-dtbs.patch"
+)
+
+src_install() {
+ default
+ emake DESTDIR="${D}" SYS_PREFIX="" install-dracut
+}
+
+pkg_postinst() {
+ if [[ ! -e ${ROOT}/usr/lib/asahi-boot ]]; then
+ ewarn "These scripts are intended for use on Apple Silicon"
+ ewarn "machines with the Asahi tooling installed! Please"
+ ewarn "install sys-boot/m1n1, sys-boot/u-boot and"
+ ewarn "sys-firmware/asahi-firmware!"
+ fi
+
+ if [[ -e ${ROOT}/bin/update-m1n1 ]]; then
+ ewarn "You need to remove /bin/update-m1n1."
+ fi
+
+ if [[ -e ${ROOT}/usr/local/share/asahi-scripts/functions.sh ]]; then
+ ewarn "You have upgraded to a new version of ${PN}. Please"
+ ewarn "remove /usr/local/share/asahi-scripts/,"
+ ewarn " /usr/local/bin/update-m1n1, and"
+ ewarn "/usr/local/bin/update-vendor-firmware."
+ fi
+
+ if [[ -e ${ROOT}/etc/dracut.conf.d/10-apple.conf ]]; then
+ ewarn "Please remove /etc/dracut.conf.d/10-apple.conf"
+ fi
+}
diff --git a/sys-apps/asahi-scripts/files/makefile.patch b/sys-apps/asahi-scripts/files/makefile.patch
new file mode 100644
index 000000000000..b7a9db6585f5
--- /dev/null
+++ b/sys-apps/asahi-scripts/files/makefile.patch
@@ -0,0 +1,6 @@
+--- a/Makefile 2022-10-31 17:46:24.536323376 +1000
++++ b/Makefile 2022-10-31 17:47:13.510116412 +1000
+@@ -1,2 +1,2 @@
+-PREFIX=/usr/local
++PREFIX=/usr
+ CONFIG_DIR=/etc/default
diff --git a/sys-apps/asahi-scripts/files/update-m1n1-dtbs.patch b/sys-apps/asahi-scripts/files/update-m1n1-dtbs.patch
new file mode 100644
index 000000000000..a1127c440fd6
--- /dev/null
+++ b/sys-apps/asahi-scripts/files/update-m1n1-dtbs.patch
@@ -0,0 +1,13 @@
+diff --git a/update-m1n1 b/update-m1n1
+index 0e55ead..f014a52 100755
+--- a/update-m1n1
++++ b/update-m1n1
+@@ -17,7 +17,7 @@ fi
+ : ${M1N1:="$SOURCE/m1n1.bin"}
+ : ${U_BOOT:="$SOURCE/u-boot-nodtb.bin"}
+ : ${TARGET:="$1"}
+-: ${DTBS:=$(/bin/ls -d /lib/modules/*-ARCH | sort -rV | head -1)/dtbs/*.dtb}
++: ${DTBS:=/usr/src/linux/arch/arm64/boot/dts/apple/*.dtb}
+ : ${CONFIG:=/etc/m1n1.conf}
+
+ umount=false
diff --git a/sys-apps/asahi-scripts/metadata.xml b/sys-apps/asahi-scripts/metadata.xml
new file mode 100644
index 000000000000..e0d402772ba2
--- /dev/null
+++ b/sys-apps/asahi-scripts/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>jcalligeros99@gmail.com</email>
+ <name>James Calligeros</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>asahi@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">AsahiLinux/asahi-scripts</remote-id>
+ </upstream>
+</pkgmetadata>